LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-24-2005, 07:37 AM   #1
libertine
LQ Newbie
 
Registered: Jun 2005
Location: China,Jinan
Posts: 13

Rep: Reputation: 0
mplayer's questions


i used debian
and using apt get the mplayer
but ,when i open mplayer
it will give me this error message,
mplayer: relocation error: /usr/lib/libavcodec-cvs.so: undefined symbol: faacDecOpen
who can tell me what can i do
 
Old 07-24-2005, 11:55 PM   #2
julot
Member
 
Registered: Feb 2005
Location: Bogotá, Colombia
Distribution: Slackware
Posts: 36

Rep: Reputation: 15
I don't know if this is the case, but probably mplayer was compiled using the CVS version and who did it forgot to get the libavcodec, which doesn't come with the CVS version. I suggest you to download the source from the page and compile it.
 
Old 07-25-2005, 01:22 AM   #3
detpenguin
Senior Member
 
Registered: Oct 2003
Location: lost in the midwest...
Distribution: Slackware
Posts: 1,098

Rep: Reputation: 54
i agree...the only way i ever got mplayer to work on my box was by compiling it...you can find the source here....
 
Old 08-13-2005, 04:32 PM   #4
bluesdog
LQ Newbie
 
Registered: Aug 2005
Posts: 2

Rep: Reputation: 0
I had the same error message whenever I attempted to start mplayer. Solved by forcing a downgrade to libfaad2-0 version 2.0.0-0.5 from the stable repository, and making sure I had removed conflicting repositories, such as rarewares...

For more information, see: http://hpisi.nerim.net/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
basic questions on hostname and domain name + related postfix questions Moebius Linux - Newbie 7 09-04-2007 12:50 PM
mplayer's /usr/local/lib/codecs work... but what of ffmpeg? babyphil Slackware 1 09-06-2005 03:49 AM
mplayer's output to tv-out ZeroKun Linux - Hardware 0 08-07-2005 10:26 PM
MPlayer's graphic interface? ShadowMetis Linux - Software 9 12-05-2004 07:19 PM
Mplayer's Bad Behavior Amerist Linux - Software 2 10-15-2002 03:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration