LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-05-2004, 12:54 PM   #1
ShadowMetis
Member
 
Registered: Dec 2004
Location: Newburgh
Distribution: Gentoo
Posts: 85

Rep: Reputation: 15
MPlayer's graphic interface?


What do I have to do to get the controls to come up? I've only been able to get it to run through the commandline and the controls don't show up when I do it like that.
 
Old 12-05-2004, 12:57 PM   #2
randyding
Member
 
Registered: May 2004
Posts: 552

Rep: Reputation: 31
The gui comes up when you run 'gmplayer'.
 
Old 12-05-2004, 01:04 PM   #3
ShadowMetis
Member
 
Registered: Dec 2004
Location: Newburgh
Distribution: Gentoo
Posts: 85

Original Poster
Rep: Reputation: 15
GMPlayer isn't there o_O
 
Old 12-05-2004, 01:15 PM   #4
randyding
Member
 
Registered: May 2004
Posts: 552

Rep: Reputation: 31
Oh ya, sorry...

Create a symbolic link from gmplayer to mplayer.

# cd /usr/local/bin { or whereever mplayer is }
# ln -s mplayer gmplayer
# ./gmplayer

and the GUI should come up.
 
Old 12-05-2004, 01:21 PM   #5
Boow
Member
 
Registered: Feb 2004
Distribution: Slackware 10.2
Posts: 669

Rep: Reputation: 32
when you compile mplayer you have to use the ./configure --enable-gui option. you also need to install a skin and font if you haven't already RTFM

Last edited by Boow; 12-05-2004 at 01:24 PM.
 
Old 12-05-2004, 02:38 PM   #6
ShadowMetis
Member
 
Registered: Dec 2004
Location: Newburgh
Distribution: Gentoo
Posts: 85

Original Poster
Rep: Reputation: 15
What GTK package does the it require? It keeps giving me an error about the GUI needing GTK dev packages, but it doesn't state the name of the package.
 
Old 12-05-2004, 03:33 PM   #7
ShadowMetis
Member
 
Registered: Dec 2004
Location: Newburgh
Distribution: Gentoo
Posts: 85

Original Poster
Rep: Reputation: 15
Anyone?
 
Old 12-05-2004, 05:11 PM   #8
randyding
Member
 
Registered: May 2004
Posts: 552

Rep: Reputation: 31
I forgot about the skin, I used the Blue skin and picked one of the fonts.
The gtk devel that is installed on my system is
gtk2-devel-2.2.4-8.1
gtk+-devel-1.2.10-31
 
Old 12-05-2004, 05:53 PM   #9
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 85
Per the LQ Rules, please do not bump your own thread until at least 24 hours have elapsed without a reply. Because the LQ membership is global, people in other time zones may not have seen this post yet, and thus it may take some time before a response is received.

http://www.linuxquestions.org/rules.php

ShadowMetis - I understand your eagerness to solve the problem, however, please keep in mind that LQ is not a real time chat room and that answers may not arrive for a day or two. Please don't bump your own posts unless at least 24 hours have passed without a reply. Thanks -- J.W.
 
Old 12-05-2004, 07:19 PM   #10
ShadowMetis
Member
 
Registered: Dec 2004
Location: Newburgh
Distribution: Gentoo
Posts: 85

Original Poster
Rep: Reputation: 15
Ok, I got it all compiled and everything, but still no GUI.....\

EDIT:
Code:
[cfg] read config file: /home/shadowmetis/.mplayer/gui.conf
vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0.0" => local display)
Failed to open /dev/rtc: Device or resource busy (it should be readable by the user.)
SKIN dir 1: '/home/shadowmetis/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'
The console just freezes up at that point until I close it. Then I get a graphic error.



And sorry about the bump before.

Last edited by ShadowMetis; 12-05-2004 at 07:23 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
lost my graphic interface ! vwal_13 Slackware 2 04-14-2004 08:35 AM
installing graphic interface vs59 Linux - Newbie 3 03-22-2004 08:40 AM
mplayer graphic interface linx win Linux - Software 9 03-10-2004 07:44 AM
graphic interface diamo Linux - Newbie 2 10-28-2003 08:16 PM
No graphic interface barDo Linux - Software 1 02-08-2002 10:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration