LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   mpi++.h missing in redhat9??? (https://www.linuxquestions.org/questions/linux-software-2/mpi-h-missing-in-redhat9-102126/)

drapaca 10-09-2003 01:38 PM

mpi++.h missing in redhat9???
 
Hi;
I've just upgraded to Redhat 9.0 from Redhat 7.2 and everything looked fine till I tried to recompile my VTK 4.2 stuff. The error I got was regarding the mpi.h file where on line 1064 it is mentioned the mpi++.h file which lam-6.5.8-4 doesn't have!! I tried to take it out and of course it didn't work either. How can I put this file back? Or how can I modify mpi.h such that I don't need this ++ stuff anymore.
Any help will be greatly appreciated.
Thank you.
Corina

webtoe 10-09-2003 04:54 PM

why not try installing the file?

search rpmfind.net for mpi++.h and it should tell you which package would provide this.

Alex

drapaca 10-10-2003 06:39 PM

redhat 9 and mpi++.h
 
Hi, Alex;
Thank you for your replay. I did check for the mpi++.h file and the only one I found, written in 1997 and never upgraded (?) was in mpi2c++-1.0.1-3.i386.rpm (from redhat 8) which, after I installed, and compiled again vtk, I got other errors, regarding some other .h files which are mentioned in this old mpi++.h file but don't exist in redhat 9 anymore. Now I really don't know what else to do. This is obviously a redhat 9 problem and not a vtk problem. What I really don't understand is how come redhat 9 (which, by the way, I bought and not download from the internet!) comes without this mpi++.h file but it is still used in the mpi.h file !?! What else can I do/try?
Thank you.
Corina


All times are GMT -5. The time now is 10:04 PM.