LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-10-2003, 04:01 AM   #1
Haploness
LQ Newbie
 
Registered: Mar 2003
Posts: 18

Rep: Reputation: 0
Angry Mozilla mime problem


I am trying to change the mime-types in mozilla (0.9.2.1) that comes
with Redhat7.2. I do ne usal edit/prefs./Nav/HelpApps and add an
application/pdf mime type to acroread (I have installed acroread 5).
Nevertheless mozillaALWAYS tries to open xpdf (I have it installed too)
and it results in a blank page and a xpdf process defunct (if I open xpdf
on the command line it works fine).

Any idea?


Thanks
 
Old 03-10-2003, 11:28 AM   #2
raven
Member
 
Registered: Dec 2001
Location: Basel, Switzerland
Distribution: ubuntu
Posts: 297

Rep: Reputation: 31
upgrade to mozilla 1.3.

make sure, there is no other definition for application/pdf in the helper apps list. you may try to remove all mime types that refer to pdf. the next time, you open a pdf doc form the browser, it should ask you what to do. there you can enter the application you want to work with pdf.

hope this helps

raven
 
Old 03-11-2003, 01:42 AM   #3
Haploness
LQ Newbie
 
Registered: Mar 2003
Posts: 18

Original Poster
Rep: Reputation: 0
Talking

Ty raven, in fact the problem was somehow like that. There was no other
application/pdf definition, but the 'plugger' plug-in. It was taking the definition
for app./pdf. I had to remove the plugger from the plugin-path, restart mozilla,
close it again (after verifying the plugger defs were removed), then modify
manually the /etc/pluggerrc removing the entry for app./pdf and then start
mozilla again and add the entry for app./pdf using acroread. It works fine.

Ty.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
K Enviroment MIME Problem J_7D5 Linux - Software 0 08-29-2005 12:34 AM
qmail mime problem marsguy Linux - General 2 04-29-2005 09:13 AM
Webmail under Mozilla: Attachments of mime type image/jpeg do not open SkipHuffman Linux - Software 2 03-28-2005 08:12 AM
Mozilla + mime.type on SUSE 9 desbondo Linux - General 0 11-09-2004 10:04 AM
mozilla MIME handling eantoranz Linux - Software 0 06-16-2004 02:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration