LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-28-2003, 11:30 PM   #1
lt1derful
Member
 
Registered: Jul 2003
Distribution: Slackware 9.1; Gentoo
Posts: 68

Rep: Reputation: 15
Mozilla HTTP Authentification


OK...I did a search, but can't find this anywhere.

I have a couple ftp sites of my own that are set up for HTTP Auth; ie prompt for user/password to enter.

However, when I'm in Slack 9 running Mozilla 1.4; and I go to either of the ftps...I don't get prompted, I just get a "530 User Login Incorrect" error.

Is there a setting or something in the config that I need to check out to fix this?
 
Old 07-28-2003, 11:37 PM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
does it only happen when you do it this way, or can you log in successfully with a ftp client?
and maybe try typing the ftp address with username/pass included such as:
ftp://usernameass@IPort
in the location bar and see what happens..
 
Old 07-28-2003, 11:39 PM   #3
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
ack!! lemme do that with spaces but remember that its all together and don't mind that [url] stuff cause that was automatically inserted..
ftp : // username : pass @ IP : port
but put it all together in the location bar
 
Old 07-29-2003, 08:10 AM   #4
lt1derful
Member
 
Registered: Jul 2003
Distribution: Slackware 9.1; Gentoo
Posts: 68

Original Poster
Rep: Reputation: 15
I was going to try the user/pass in the URL, but forgot the format. I'll give that a shot. I generally don't use an ftp client, so I'm not sure...I would think it would work. Works in Internet Eplorer and even Konqueror - which is odd, cause it's the ONLY thing I can get Konqueror to do that I haven't got Mozilla to do.

Thanks, I'll update and let you know.
 
Old 07-29-2003, 07:16 PM   #5
lt1derful
Member
 
Registered: Jul 2003
Distribution: Slackware 9.1; Gentoo
Posts: 68

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by DrOzz
ack!! lemme do that with spaces but remember that its all together and don't mind that [url] stuff cause that was automatically inserted..
ftp : // username : pass @ IP : port
but put it all together in the location bar
Works just fine. I added these as bookmarks so I don't have to type it everytime. Thanks!
 
Old 11-21-2003, 02:43 PM   #6
retiem
Member
 
Registered: Jul 2003
Location: Frankfurt, Germany
Distribution: Mint, Ubuntu, Knoppix, RHEL
Posts: 65

Rep: Reputation: 15
hey folks...

I have proftpd 1.2.7 running on my Mdk 9.1 box. Here is the thing:

I can perfectly log in from another machine via http if I use Explorer or an ftp client, but it would return a "530 login incorrect" error if I use Mozilla (1.4) or Konqueror.

However, I did tried typing the ftp address with username/pass in the URL as suggested above and it worked just fine!!!! For both Mozilla and Konqueror ....BUT this is not good because my passwd remains visible thereafter!!!

WHAT IS GOING ON? IS THIS A MOZILLA/KONQUEROR BUG ?????

Does anyone know the fix?

Thanks in advance for your help!
 
Old 11-21-2003, 03:07 PM   #7
retiem
Member
 
Registered: Jul 2003
Location: Frankfurt, Germany
Distribution: Mint, Ubuntu, Knoppix, RHEL
Posts: 65

Rep: Reputation: 15
I wanna add the following:

I also tried ftp://localhost in Mozilla and Galeon from within the machine itself and got the same "530 login incorrect"

I think proftpd is running fine, but for some reason I can only do HTTP authentication using Internet Explorer... I can't believe this! I don't wanna give MS any credits!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
apache: http://localhost (work) http://ipaddress (not working) sarmad Linux - Newbie 7 02-05-2013 08:47 AM
http-equiv and mozilla atomicx Linux - Software 1 07-30-2004 07:17 PM
Active Directory proxy authentification with Mozilla meldar Linux - Networking 6 05-03-2004 07:45 AM
authentification proftpd aracna Linux - Software 0 01-14-2004 01:35 PM
server for authentification abd_bela Linux - Networking 1 09-03-2003 07:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration