-   Linux - Software (
-   -   Mozilla/Firefox streaming content problems. (

lcbest 11-13-2005 03:18 PM

Mozilla/Firefox streaming content problems.
Hello all,

I'm using Debian unstable (latest upgrade from a couple weeks ago). I have the Mozilla, Mozilla Firefox, Galeon, and Epiphany browsers installed. Both Mozilla and Firefox have TabBrowserExtensions (just in case that's relevant), MozPlugger, and RealPlayer10 (and plugin) installed. They all work OK for ordinary web content. Epiphany and Galeon handle streaming content OK, but both Mozilla and Firefox have problems with streaming content. All the plugins show up and are "active" in the "About PlugIns" page. The error symptoms are variable. For example, in Mozilla going to Yahoo! movies, clicking on "Harry Potter and the Goblet of Fire", then on "Exclusive clip: "The Maze"" creates a pop-up window but instead of the video there is a message saying

No Matching Stream

The media you are trying to access does not have a stream that matches your default settings. You might try running the Media HelperTM again. Check that you have all required software installed to get the most out of your audio and video experience.

plus buttons for "Run Media Helper" and "Cancel". Clicking "Run Media Helper" gets me a list of players and connection speeds. Only RealPlayer is selectable (and is already selected) and the speed selection is correct too. I click them anyway just to be sure then click "Accept Settings". The result is the same error message again.

Firefox is similar except it initially shows a blank frame (i.e. no video). Clicking "Change Settings" underneath runs the so-called "Media Helper" which always shows all three player plugins (Windows Media, RealPlayer, and QuikckTime) as installed and "OK". However, none of them actually does anything (BTW WindowsMedia is always preselected regardless of my previous choice).

Similarly streaming sound does not work. Looking up a word in Meriam-Wedbster Online and clicking the little speaker to hear the pronunciation results in a pop-up but no sound. Again, both Galeon and Epiphany work fine.

Just for the record the Mozilla RealPlayer plugin files are symlinked as:

/usr/lib/mozilla/plugins/ -> /usr/local/RealPlayer10/mozilla/*
/usr/lib/mozilla/components/nphelix.xpt -> /usr/local/RealPlayer10/mozilla/nphelix.xpt*

Similarly for Firefox. Also /usr/local/bin/realplay -> /usr/local/RealPlay10/realplay which is in my path. It seems like /etc/mozpluggerrc must be OK because Galeon and Epiphany work OK? I can post it though if that'd be useful.

Anyway, the question is: Has anybody seen this before and, if so, how does one fix it? Thanks in advance for any help.


GL1800 11-14-2005 07:57 AM

While I cannot help you with what's broken, and I wish I could, for what it's worth, there's a linux project called "plugger", which can be found by googling. I have used it for a long time, now, and it ends all web multinedia issues for me, while doing many other interesting browser helper things.

RedShirt 11-14-2005 08:17 AM

I know that the mplayer plugin works. I have not tried real, nor do I personally have any desire to have real or helix on my system, but that is just me. Perhaps getting the mplayer mozilla plugins will fix your errors. I know I stream the yahoo movies, mms feeds from my radio station, and others, in FireFox 1.0.7. So I know mplayer plugin works...though there is a bit of a tricky spot if you have a 64bit version of the OS, and try to play things like yahoo movies, which are 32bit windows things. A lot of dependency issues. But if you have 32bit OS, it will all work fine. You can get the mplayer codecs directly from the mplayer website and compile yourself, or I am sure, you can find .Debs for debian.

All times are GMT -5. The time now is 07:09 AM.