LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 08-18-2006, 04:35 PM   #1
PingFloyd
Member
 
Registered: Jun 2006
Posts: 94

Rep: Reputation: 16
Mozilla Firefox mouse scroll wheel behavior.


I've got an irritating problem with Firefox. Perhaps it's actually a feature, but it's it really drives me nuts either way. The problem is that if I flick scroll up or down real fast, it wants to navigate through my history.

For example:
If I scroll down real fast with the scroll wheel, it acts the like I hit "back" one page on the toolbar. If I scroll up real fast with the scroll wheel, it acts like I hit "forward" one page on the toolbar. Hopefully it makes sense what I'm trying to say.

Some people may have this enabled, but don't run into a problem with it. It's one of those things that probably certain browsing habits are going to encounter while others aren't. For me, Firefox behaves in this manner by default. It may be one of those things that specific to the package for Firefox from my distro (I'm not sure). For reference, this is with Arch Linux 7.2's "mozilla-firefox 1.5.0.6-1" package. Which is Mozilla Firefox 1.5.0.6 as far as Firefox's own versioning goes.

If you want to test what I'm talking about, try scrolling really fast up or down on your mouse scroll wheel. I don't know if this is a default behavior acrossed the board for different version and distros or not.

I can't find any settings that have an effect on this in Mozilla Firefox. Maybe someone else knows how to fix my problem, or knows the setting that controls this behavior.

Anyone know how to disable this behavior in Mozilla Firefox?
 
Old 08-18-2006, 05:36 PM   #2
PingFloyd
Member
 
Registered: Jun 2006
Posts: 94

Original Poster
Rep: Reputation: 16
Right on!

I think I found the cause and fix of this. I changed the following in my xorg.conf.

It was originally:

zaxismapping "4 5 6 7"

I changed it to:

zaxismapping "4 5"

What it appears to be is that, at least in my case and perhaps in others, is that when you generate an xorg.conf in Xorg, it defaults to the former. In my case, I originally configured Xorg via the "xorgconfig" script.

I believe what is going on is that in most cases "6 7" is for scrolling horizontally (by default anyway). In my case, I have just a real standard scrollwheel that is only vertical. So I assume that horizontal scrolling is often mapped to back and forward in history for some web browsers by default (maybe most of them for all I know). I think what was going on is that when I flicked the scroll wheel fast enough X was enterpretting it as "6" and "7" for "zaxismapping" setting instead of confining it to "4 5" like it should in my case.

So if you're having this same problem, try changing that setting like I show to see if it takes care of it for you.
 
Old 12-06-2006, 11:49 AM   #3
wodowik
LQ Newbie
 
Registered: Dec 2006
Posts: 1

Rep: Reputation: 0
i have another similar yet diffrent problem.
i recently installed a new mouse with more buttons, in doing so i was hoping to have the extra buttons scripted to firefox only actions, ie. open new tab. but in doing so i have now lost the use of my scroll wheel. its realy anoying please assist
 
Old 12-24-2006, 04:07 PM   #4
ygloo
Member
 
Registered: Aug 2006
Distribution: slack
Posts: 323

Rep: Reputation: 30
sometimes "page scroll" is useful

Last edited by ygloo; 12-24-2006 at 04:11 PM.
 
Old 12-24-2006, 07:54 PM   #5
petersum
Member
 
Registered: May 2006
Location: Karachi, Pakistan
Posts: 140

Rep: Reputation: 15
Yes, there is definitely some kind of bug here! I have Firefox-2.0. The mousewheel does very strange things, not always repeatable. When I load a page with some kind of video (flash) which I don't have the plugin for, scrolling over that area of the page sometimes closes the browser completely!


Merry Christmas, Happy New Year and Eid Mubarrak to everyone.
 
Old 01-19-2007, 12:41 PM   #6
jonaskoelker
Senior Member
 
Registered: Jul 2004
Location: Denmark
Distribution: Ubuntu, Debian
Posts: 1,524

Rep: Reputation: 46
Quote:
Originally Posted by PingFloyd
Anyone know how to disable this behavior in Mozilla Firefox?
See http://www.macosxhints.com/article.p...6688&lsrc=osxh

Executive summary: In about:config, set mousewheel.horizscroll.withnokey.action to 1.
 
Old 01-19-2007, 06:28 PM   #7
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
Originally Posted by jonaskoelker
See [url]In about:config, set mousewheel.horizscroll.withnokey.action to 1.
well, yeah... but keep in mind that when you *only* have a vertical scroll wheel then this should not be an issue... hence, what PingFloyd did was the proper fix, and the mousewheel.horizscroll thing you are suggesting would (in this case) be more of an ugly work-around (he would have had to sacrifice his vertical scroll in firefox because it was not properly configured in X.org)...
 
Old 01-20-2007, 04:50 AM   #8
jonaskoelker
Senior Member
 
Registered: Jul 2004
Location: Denmark
Distribution: Ubuntu, Debian
Posts: 1,524

Rep: Reputation: 46
Gee, I must've been really tired when I posted that...
 
Old 02-13-2007, 12:46 PM   #9
tome2
LQ Newbie
 
Registered: Feb 2007
Posts: 2

Rep: Reputation: 0
Scroll Wheel Per Page

How do I get my wheel mouse to scroll by page instead of per line?
 
Old 02-14-2007, 12:51 AM   #10
jonaskoelker
Senior Member
 
Registered: Jul 2004
Location: Denmark
Distribution: Ubuntu, Debian
Posts: 1,524

Rep: Reputation: 46
Tome2: Welcome to LQ, nice to see new members

I think you would be better served by creating a new thread for your question. Sure, we're discussing mozilla in this thread, so we might know something about it; but all the people who know more about mozilla than we do aren't going to see your question--something they are more likely to do if you post a new thread. Also, keeping one thread per issue is a custom around here, so you'll have fewer people frowning at you (meaning a larger fraction of those who read your question are willing to help).

I don't know the answer to your question, but it sounds like google could be helpful. If you've already tried google, let us know; in fact, every time you have a problem, let us know exactly what you've done to diagnose and/or solve it yourself. See also http://www.chiark.greenend.org.uk/~sgtatham/bugs.html.
 
Old 03-08-2007, 04:10 AM   #11
s26c.sayan
Member
 
Registered: Nov 2006
Location: Kolkata, India
Distribution: Arch Linux, Ubuntu Feisty, Knoppix Live CD
Posts: 37

Rep: Reputation: 15
I was having exactly the same problem as mentioned in the starting post. It didn't happen in my Ubuntu Edgy, but happened in my new Arch installation.
I think its sorted now by setting the key "mousewheel.horizscroll.withnokey.action" in about:config to value 1 (instead of 2).
 
Old 02-15-2008, 05:50 PM   #12
fozner
Member
 
Registered: Aug 2006
Posts: 147

Rep: Reputation: 16
I thought you would find it amusing that

firefox does this in Windows 2000 too (mouse wheel scrolls through the history list instead of scrolling the page).

Good to see consistent behavior across platforms.

Edit: worse in 2.0.0.12

Last edited by fozner; 02-15-2008 at 06:24 PM.
 
Old 05-28-2008, 10:18 AM   #13
Flying
LQ Newbie
 
Registered: May 2008
Posts: 1

Rep: Reputation: 0
Just unplug and replug mouse

I had this same unwanted behavior, which is apparently particularly troublesome if you use a KVM (which I do). The recommendation from another forum worked wonderfully: unplug and replug the mouse to the KVM.
 
Old 10-03-2008, 01:26 PM   #14
agf
LQ Newbie
 
Registered: Oct 2008
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by Flying View Post
I had this same unwanted behavior, which is apparently particularly troublesome if you use a KVM (which I do). The recommendation from another forum worked wonderfully: unplug and replug the mouse to the KVM.
Hi, im new. So hi everyone.

I deactivated mousewheel.horizscroll.withnokey.sysnumlines in about:config and apparently fixed this behavior. Can someone confirm these?
 
Old 05-20-2009, 04:18 PM   #15
dwalton
LQ Newbie
 
Registered: May 2009
Posts: 2

Rep: Reputation: 0
It seemed to help some.

Quote:
Originally Posted by agf View Post
Hi, im new. So hi everyone.

I deactivated mousewheel.horizscroll.withnokey.sysnumlines in about:config and apparently fixed this behavior. Can someone confirm these?
I was having the same problem. Making the changes in this thread helped but I still have the problem. It seems to only happen when I scroll to the top of the web page.
 
  


Reply

Tags
firefox, history, mouse, mozilla, scroll, settings, wheel


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox 1.0.2 scroll wheel navigation otchie1 Linux - Software 9 04-15-2007 12:49 PM
Scroll Wheel in Firefox gilman824 Linux - Newbie 6 08-01-2005 01:02 PM
Firefox scroll wheel gunblade Linux - Software 6 06-21-2005 03:45 PM
scroll wheel behavior SamerAdra Linux - Newbie 6 11-06-2004 02:59 AM
4d wheel mouse - scroll wheel no worky CamelofCamelot Linux - Hardware 1 10-28-2004 08:33 PM


All times are GMT -5. The time now is 01:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration