LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-27-2004, 04:54 PM   #1
e88z4
LQ Newbie
 
Registered: Feb 2004
Location: Canada
Distribution: Debian Sid
Posts: 29

Rep: Reputation: 15
Mozilla/Firefox "Document contains no data"


Hi,
Does anyone have with this error in Mozilla or Firefox
Quote:
Document contains no data
I went to Ebay, everytime I used their search engine I got that error.

There was a suggestion from mozilla forums to change this line in the configuration
Quote:
browser.xul.error_pages.enable = true
but it didn't help at all.

It also suggested that firewall might be the problem, so in my linux gateway I changed my iptables rules to ACCEPT all the connection.
Quote:
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
For your information, my linux gateway serves two machines, one running linux and the other is windows. This problem only occured in my linux machines with Mozilla and Mozilla Firefox.

Does anyone have any suggestion?

Thanks
 
Old 12-27-2004, 06:15 PM   #2
flipcode
Member
 
Registered: Dec 2004
Distribution: Red Hat 9, Fedora Core 3, KNOPPIX
Posts: 33

Rep: Reputation: 15
Can you post your entire firewall script and a description of your LAN design?
 
Old 12-27-2004, 06:43 PM   #3
e88z4
LQ Newbie
 
Registered: Feb 2004
Location: Canada
Distribution: Debian Sid
Posts: 29

Original Poster
Rep: Reputation: 15
For troubleshooting purpose, I created the script bellow so that there are no rules which can possibly blocking the connection.

My LAN design:
I have 3 computers, one is linux gateway which is connected to my ISP and the other two computers. My second computer is running Linux and connected to this gateway, so does the others which running windows XP.

Code:
#!/bin/sh
IPTABLES=/sbin/iptables

$IPTABLES -F INPUT
$IPTABLES -F OUTPUT
$IPTABLES -F FORWARD
$IPTABLES -P INPUT ACCEPT
$IPTABLES -P OUTPUT ACCEPT
$IPTABLES -P FORWARD ACCEPT
 
Old 12-27-2004, 09:31 PM   #4
IraB
LQ Newbie
 
Registered: Jul 2004
Location: Swamp east Missouri
Distribution: FC12/ubuntu/linux mint/Debian
Posts: 27

Rep: Reputation: 15
document contains no data

For what is's worth, I get that also. I am unable to offer a fix for it, it is just something that has been happening on this box. This is a stand alone, running FC3, Mozilla/firefox 1.0 and the FC3 firewall.....seems that when it takes a while for page to load is when it happens. I added a zero to the cashe for a total of 500,000 kb..
Not much help I know.....
 
Old 12-27-2004, 10:25 PM   #5
e88z4
LQ Newbie
 
Registered: Feb 2004
Location: Canada
Distribution: Debian Sid
Posts: 29

Original Poster
Rep: Reputation: 15
I tried to access ebay from my windows machine, it worked. It seems there is something different in the configuration between Firefox 1.0 in win32 and Linux. We can opt out the firewall issue here because both machines shares the common gateway with the same iptables rules.

Flushing the cache in Firefox did not solve the problem either.
 
Old 12-28-2004, 03:12 AM   #6
flipcode
Member
 
Registered: Dec 2004
Distribution: Red Hat 9, Fedora Core 3, KNOPPIX
Posts: 33

Rep: Reputation: 15
Are you running squid? If not, try running that and analyse the logs. You may see several MISS/00 entries which from memory is a problem with an unknown fix.

I was having the same problems. Nobody could seem to help me.

I doubt squid alone will fix the problem, but I have to assume that the network configuration on both the windows and linux machine are the same (netmask, gateway, dns, etc).

Also, make sure that you are not viewing SSL pages and that there isn't a difference in SSL timeouts.

Are you able to try using perhaps Opera on the Linux box to see if it is indeed a Mozilla oriented problem?

Also, I don't know if this is possible, but are you able to turn on a verbose logging in your apparently faulty browsers? If so, do that as it might lead you to an answer. Perhaps a debug mode?

For the record, I just ignored the support calls for this problem within my network and after a while the problem went away. Interestingly though, this was occuring on Windows machines using Internet Explorer.
 
Old 12-28-2004, 10:54 AM   #7
e88z4
LQ Newbie
 
Registered: Feb 2004
Location: Canada
Distribution: Debian Sid
Posts: 29

Original Poster
Rep: Reputation: 15
I am not running squid or any type or proxy.

I have a spare hardrive then I installed win xp as the second hardrive on my linux box so the machine was dual booted. Mozilla/Firefox did not have this problem.

Another test was installing IE running under WINE and used Epiphany on my linux machine. Both had the same problem. As your info that on my linux itself I have IPTABLES but all the policy are ACCEPT

Quote:
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
This are the routing tables

Quote:
Chain PREROUTING (policy ACCEPT)
target prot opt source destination

Chain POSTROUTING (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
The page I saw was not SSL pages. I went to Ebay and only used their search engine.
Do you know how to run Firefox under debug mode?
 
Old 12-28-2004, 08:18 PM   #8
flipcode
Member
 
Registered: Dec 2004
Distribution: Red Hat 9, Fedora Core 3, KNOPPIX
Posts: 33

Rep: Reputation: 15
No I don't know how to do it under debug mode.

Did Opera exhibit the same problem?
 
Old 12-28-2004, 09:14 PM   #9
e88z4
LQ Newbie
 
Registered: Feb 2004
Location: Canada
Distribution: Debian Sid
Posts: 29

Original Poster
Rep: Reputation: 15
I had the same behaviour with Opera. What I noticed was all browser (Mozilla, Firefox, Opera, IE, Epiphany) stucked at the same place. I could saw half of page which they were trying to display. I must miss something silly.
 
Old 01-19-2005, 04:28 PM   #10
jaa1180
Member
 
Registered: Oct 2003
Location: USA, Tennessee
Distribution: Ubuntu
Posts: 307

Rep: Reputation: 30
I have the same problem with linux web browsers from my machine. On my wife's laptop (XP) it is fine. I replaced the router and it is much faster but it will not work on ebay. I am going to clear out the cache and see if that helps. Any other suggestions??
 
Old 01-20-2005, 12:08 PM   #11
Ruler2112
Member
 
Registered: Oct 2004
Location: Michigan, US
Distribution: Redhat 7.3, 9.0; Slackware 10, 10.1, 10.2, 11; FreeBSD 7.0; KnoppMyth 5.5
Posts: 125

Rep: Reputation: 16
I have had the same problem with Mozilla on both win and linux at home and at work. Seems to happen with orifacemax's ad page quite a bit. Reloading the page usually makes the problem disappear. (Again, no fix; only peace of mind in knowing that you are not alone. )
 
Old 01-21-2005, 10:07 PM   #12
malharsire
LQ Newbie
 
Registered: Jan 2005
Posts: 2

Rep: Reputation: 0
Same problem on Mandrake

I am having the same problem on Mandrake. Windows machine sitting alongside is completely fine! AM gatewayed thru DSL router. THis problem is driving me nuts!!. It seems every second click says "Document contains No data". Was working fine just the other day. I am using Firefox - also tried Epiphany same problem....
 
Old 01-24-2005, 11:02 PM   #13
jaa1180
Member
 
Registered: Oct 2003
Location: USA, Tennessee
Distribution: Ubuntu
Posts: 307

Rep: Reputation: 30
I cleaned out the cache and that did not help. I replaced my router, needed replacing, and that did not help. What could be going on? I go to ebay and the browser LOCKS on me. Everytime! My wife is running Fedora Core 3 and it is working fine for her. ?? What is the deal here?

Is there a reset command or perhaps reinstalling?
 
Old 02-04-2005, 07:03 AM   #14
madhead
LQ Newbie
 
Registered: Jul 2002
Location: UK
Distribution: mandrake 9.1, 9.2
Posts: 17

Rep: Reputation: 0
I've justed started getting this too !

I have also this problem on Linux mandrake 10.1 and all updates.
The fonts are screwed now too.

What ISP's are you using?
I'm using NTL.
What I did find was that by making the proxy settings point to an ntl proxy on port 8080 ntl no longer routed me through a transparent proxy server which it does apparently under normal use. This is really annoying its only just started happening.

Andy


Update:.... I was getting this problem on this site using mozilla 1.7.2 and after changing the HTTP proxy settings manually to asfd-cache-2.server.ntli.net port 8080 it cures the problem.

Sounds like a problem with the proxies that NTL are using.

Last edited by madhead; 02-04-2005 at 07:10 AM.
 
Old 02-04-2005, 07:44 AM   #15
BruceCadieux
Member
 
Registered: Apr 2002
Location: Wales MA.
Distribution: openSuSE 11.1
Posts: 409

Rep: Reputation: 32
I did a simple google search on it, the answer was to clear the cahce in the browser. Worked great for me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mozilla or firefox : "ALERT document contains no data!" maxut Fedora 8 06-08-2006 08:12 AM
Apache and Firefox "Document contains no data" error. ]SK[ Linux - Software 0 08-16-2005 01:44 AM
The document contains no data. " mozilla " j.vilon Debian 8 09-29-2004 07:44 AM
"document contains no data" error when i try to connect to SWAT on local machine squeaky-steve Linux - Networking 2 12-03-2003 08:12 AM
apache2 w/ ssl - "document contains no data" with https tree_buddy Linux - Security 2 11-23-2003 08:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration