LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Mozilla and xft (https://www.linuxquestions.org/questions/linux-software-2/mozilla-and-xft-293440/)

Warg 02-22-2005 12:24 PM

Mozilla and xft
 
I'm running Slackware 10.0.

I've been working with a custom build of Mozilla 1.7 for quite a while. It was a bit slow but I didn't care. However, recently it's been causing really serious memory problems, and has been really buggy (like opening a new window making it crash, etc). I removed it and ran the standard installer I'd downloaded before (same version). It worked perfectly fine, really fast and without any problems, save one....

Now, the sole reason that made me download 30+ MB's of source over a dial-up and go into the trouble of compiling was xft. The standard build didn't come with it so I had to build it myself. I decided to compile it again with more configure options so the memory issues would be gone. I don't really remember what were the options I applied when I compiled the build I'd been using, but they probably were --enable-crypto and --enable-xft. Now I compiled with a few extra options, but this time, it wouldn't run at all. It eithe gave some weird Relocation error, or didn't output anything, neither the program nor any errors. I tried to compile it several times, with different options that I'm going to mention below, to no avail.

Here are the options I tried:

--enable-crypto --enable-xft --enable-default-toolkit=gtk2 --enable-optimize

--enable-crypto --enable-xft --enable-default-toolkit=gtk2 --enable-optimize=-O2 --disable-debug --disable-tests

--enable-crypto --enable-xft --enable-default-toolkit=gtk2 --enable-optimize=-O2 --disable-debug --disable-tests --without-system-nspr

--enable-mathml --enable-crypto --enable-xft --enable-default-toolkit=gtk2 --enable-optimize=-O2 --disable-debug --disable-tests --without-system-nspr --without-system-zlib --without-system-jpeg --without-system-png --without-system-mng


My main question is, does anyone know what are the default options they apply to their standard builds? This wasn't mentioned anywhere on the mozilla website, or the web. The build that the installer included was perfect, only excluding xft. So I'm wondering if I can find out how to build the exact same binaries with the addition of xft.

Any help will be greatly appreciated.

Warg 02-23-2005 08:22 AM

Still no replies? Come on......

reddazz 02-23-2005 10:45 AM

The latest version of Mozilla from Slackware has gtk and xft support, so you may want to try it out.

Warg 02-24-2005 11:12 PM

Ok, after downloading the mozilla 1.7.5 which is included in the official release of 10.1 twice (the first time the file turned out to be corrupt), running mozilla doesn't result in anything, no mozilla window, no output, absolutely nothing. It is probably because of some other dependencies which Mr. Volkerding assumed would be already present from the installation of 10.1.

reddazz 02-25-2005 02:56 AM

Just run it from a terminal emulator and usually an error gets printed to the screen. This should give you an idea of how to fix your problem.

Warg 02-25-2005 03:46 AM

Sure by "absolutely no output" I was already pointing to terminal output as well.

Warg 02-25-2005 04:09 AM

I didn't mention something because I believed it was not important, but since this is the only clue I have I'd better mention it.

The first time I tried to run mozilla there was this output:

*** Registering -webcal handler.
*** Registering text/calendar handler.
*** Registering webcal protocol handler.


Then it stopped right there, no more output, not even jumping back to the command line untill it was manually terminated. Everytime I attempted to run mozilla there was the exact same result. But, after running the command as root, there was the same output and same result but only once. After that it would only freeze without a single character output, and the same thing happened as a normal user.

reddazz 02-25-2005 04:27 AM

I don't know whats up with your Slack installation. Mozilla works fine for me, but I use swaret to install packages so it automatically resolves missing libraries. Maybe you ought to try and reinstall Mozill using swaret or some other tool such as slpt-get. Some people have had problems with swaret so make sure you read the docs.

Warg 02-25-2005 11:09 AM

Swaret might attempt to download +20MBs over one session which is out of the question due to my connection.

Thanks for the tips anyway.

95se 02-25-2005 01:25 PM

I know with firefox the first time you run it you have to run it as root, have you tried that?

Warg 02-25-2005 07:09 PM

I didn't have such problem with firefox, but yes I did anyway (it's mentioned in post #7).


All times are GMT -5. The time now is 06:17 PM.