LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Mounting Vfat (https://www.linuxquestions.org/questions/linux-software-2/mounting-vfat-11839/)

paradoxlight 01-15-2002 02:17 PM

Mounting Vfat
 
I am attempting to setup a Fat32 disk as a shared resource but the way that it mounts with defaults make the root the owner and everybody else read. I have tried to change this in fstab but am unable. Can anybody help

finegan 01-15-2002 02:23 PM

chmod the mount point before mounting the disk. Something like:

chmod 777 /mnt/windows

You might also want to change the group and owner with chown and chgrp.

If I'm barking up the wrong tree, I could post you my /etc/fstab and mount point permissions from my dual boot box in a few hours when I get off work.

cheers,

finegan

paradoxlight 01-15-2002 04:25 PM

Ya I tried that too sorry. I was thinking that because it is vfat the system V permissions won't apply.

When I do a dir listing it shows as rwxr-xr-x

Thanx for your help in advance.

bluecadet 01-15-2002 05:48 PM

my fstab line

/dev/hdb1 /windows vfat defaults,umask=000,quiet,user 0 0

paradoxlight 01-15-2002 06:29 PM

Thanx. That worked. Although I am kinda baffled as to why the mask is 000 is giving -rw-rw-rw? Wouldn't that be 333?


All times are GMT -5. The time now is 04:44 AM.