-   Linux - Software (
-   -   Mounting RAID filesystem (

manudath 02-24-2005 09:32 PM

Mounting RAID filesystem
Hi everyone,

I have one complicated problem here: I built a Red hat enterprise system with RAID 5 using 2 hard drives.

hda1 - /boot - 100MB
hda2 - swap - 1GB
hda3 - Linux raid autodetect - / - 3GB (FS type = fd)

hdb1: - Linux raid autodetect - / - 3GB
hdb2: - Linux raid autodetect - / - 3GB

So, my /dev/md0 consists of {hda3, hdb1, hdb2}

I wrote some sample data on / (ie., md0). I removed the drives and connected only one of them as a slave with another red hat system (that has no RAID support).

When I do fdisk -l, I can see the partitions (either hda1,hda2, and hda3 or hdb1,hdb2), but I cannot mount them.

[root@mySystem mnt]# mount /dev/hdb2 /mnt/raid/
mount: wrong fs type, bad option, bad superblock on /dev/hdb2,
or too many mounted file systems
I tried all options such as "mount -t ext3 /dev/hdb2 /mnt/raid/"...

I also tried giving fd as the file system type...
[root@mySystem mnt]# mount -t fd /dev/hdb2 /mnt/raid/
mount: fs type fd not supported by kernel

But, if I put the original 2 hard drives and boot, I can boot it easily. Can you please let me know how can I see the data in the RAID hard drives?

Thanks a lot,

All times are GMT -5. The time now is 10:25 AM.