LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-11-2004, 08:39 PM   #1
Garoth
Member
 
Registered: Oct 2004
Location: Canada -> Ontario -> Toronto
Posts: 34

Rep: Reputation: 15
Mounting a Hard Drive


I wish to mount my Windows hard drive. I am using FC2.

Now, I have a folder created, I have fstab recognizing that there is a vfat windows drive as hda1, but I need to be root to actually mount it. Unfortunatly, I cannot figure out how to mount it. Is there a way to sign in as root, so I dont have to deal with permissions?

The location is: /mnt/hda1
The drive is:... hda1

Please, someone tell me how to mount my hard drive.
 
Old 11-11-2004, 08:43 PM   #2
Samsara
Member
 
Registered: May 2003
Distribution: Ubuntu, Mac OS X Tiger
Posts: 481

Rep: Reputation: 32
To sign in as root, type

su

it will ask for your password. su stands for "substitute user".

HTH,

Samsara
 
Old 11-11-2004, 08:45 PM   #3
Garoth
Member
 
Registered: Oct 2004
Location: Canada -> Ontario -> Toronto
Posts: 34

Original Poster
Rep: Reputation: 15
All right, but how do I actually mound my drive?
 
Old 11-11-2004, 08:58 PM   #4
Grim Reaper
Member
 
Registered: Apr 2002
Distribution: Gentoo 2006.0 AMD64
Posts: 399

Rep: Reputation: 30
do you want read-write access to this partition? If you only want Read-Only then put this into fstab for the partition you're after:
Code:
/dev/hda1        /mnt/hdd1        vfat        ro,user,noauto,umask=002      1   0
To get Read-Write, you'll need to change the umask value from 002 to 000 and the ro to rw like so:

Code:
/dev/hda1        /mnt/hdd1        vfat        rw,user,noauto,umask=000 1   0
I think that should work....

Edit: do this all as root too, then simply type mount and it should mount all filesystems that it reads from the fstab file...
 
Old 11-11-2004, 09:09 PM   #5
perfect_circle
Senior Member
 
Registered: Oct 2004
Location: Athens, Greece
Distribution: Slackware, arch
Posts: 1,783

Rep: Reputation: 53
if fstab is OK
then
mount /mnt/hda1
or
mount /dev/hda1
.
Both do the same.

Also if you erase the noauto option of the device in fstab, then the drive will be mounted automatic at startup
 
Old 11-11-2004, 09:11 PM   #6
Garoth
Member
 
Registered: Oct 2004
Location: Canada -> Ontario -> Toronto
Posts: 34

Original Poster
Rep: Reputation: 15
Great! Thats a leap forward. I think I had the wrong thing in mf fstab.... but now a new problem arizes:

Error!

"mount: wrong fs type, bad option, bad superblock on /dev/hda1, or too many mounted file systems."

Any... ideas as what to do?
 
Old 11-11-2004, 09:21 PM   #7
mAineAc
Member
 
Registered: Nov 2000
Location: Hermon, ME
Distribution: slackware
Posts: 201

Rep: Reputation: 30
are you sure it is fat32? If you are working with XP it could be NTFS
 
Old 11-11-2004, 09:22 PM   #8
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 64
What type of partition file system is it ntfs or vfat

If ntfs and using orginal fc2 kernel you need to recompile kernel to add ntfs support.
 
Old 11-11-2004, 09:32 PM   #9
Garoth
Member
 
Registered: Oct 2004
Location: Canada -> Ontario -> Toronto
Posts: 34

Original Poster
Rep: Reputation: 15
it very well could be ntfs, but if I need to recompile the cernel, I have no clue what I am doing.

And. I checked, NTFS is not supported by my Kernel. Can someone tell me how to recompile my Kernel? Is it very difficult?

Last edited by Garoth; 11-11-2004 at 09:33 PM.
 
Old 11-11-2004, 09:47 PM   #10
perfect_circle
Senior Member
 
Registered: Oct 2004
Location: Athens, Greece
Distribution: Slackware, arch
Posts: 1,783

Rep: Reputation: 53
DO NOT RECOMPILE THE KERNEL!!!

download the suitable rpm from:
http://linux-ntfs.sourceforge.net/rpm/fedora2.html
and follow the instructions.

It works for the precompiled version of FC2
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help mounting a hard drive cevilgenius Linux - Newbie 15 04-12-2005 03:35 PM
mounting hard drive thug_poet22 Linux - Hardware 14 01-04-2005 03:11 AM
Mounting a Hard Drive Bill413 Linux - Newbie 6 11-15-2004 06:19 PM
mounting a second hard drive evilRhino Linux - General 2 10-17-2002 02:22 AM
Mounting hard drive Runt888 Linux - Newbie 1 08-29-2001 03:02 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration