-   Linux - Software (
-   -   mounted windows volume folders are hidden on linux, visible from mac or windows (

florenceit 10-11-2010 02:40 AM

mounted windows volume folders are hidden on linux, visible from mac or windows
I have this new perplexing problem:

I have a hard drive shared on my netgear router (full r+w for everyone), on my linux mint system I mount the drive in fstab:

// /mnt/net smbfs netdev,nounix,nosuid,fmask=0777,dmask=0777 0 0
when i copy files to the drive via a mac or a windows machine i see and can work with them fine, but the linux system doesn't see them. but here's the weird part: they are there but just hidden. both visible and non visible files have full permissions and the same user:group. i have tried using various fstab options and user settings with the same results.

i have a shared itunes library using the same shared media folder for my ampache install (which camt see imported music!). you will be my bestest friend ever if you can help me figure out what I am doing wrong ;) ..... seriously: thanks much for any input!

fatra2 10-11-2010 02:55 AM

Hi there,

Just to get a bit more information about your problem. What is the partition of this shared hard drive??? I just noticed that you are mounting a samba partition in Linux. Samba is, from my point of view, a way to share information between Linux and Windows. If this shared hard drive is a Linux (ext3, ext4) partition, you are probably better to make a NFS out of it also.


florenceit 10-11-2010 03:10 AM

thanks for your help!

well i think it is a ext3 partition as Ive read that the netgear wndr3700 router uses open source.

however, I have used samba as the type (cifs worked too) as the directions for mounting it from mac or windows are to use smb. so as far as the mac or pc is concerned it is a windows server shared folder. i had hoped mounting from linux would be the same. I actually had this working at one point so i know i must be missing something.

whats odd is that the files are there and work fine (i have no permissions issues) other than the fact that they are hidden when i try to access a newly copied folder on the linux side (but not hidden from the mac or pc).

one thing that may be a clue: do you know what the second field is on an ls-lr command? on files i copy it is a zero, and i noticed other files that are visible have various other numbers that arent 0.

fatra2 10-11-2010 03:23 AM

Hi there,

So it is a good clue that you gave there. ls command is simply a listing command. The options -l uses a long listing format, and -r reverses the order while sorting. What you can add to you command is -a to list all the entries without ingoring the entries starting with a . (period), and therefore listing all the hidden files.

You also mentioned certain numbers appearing (0 and non 0). Where do these numbers appear (give an example)???

Otherwise, try mounting this shared hard drive with the option NFS, instead of smb or cifs. Just to see if it works.


florenceit 10-11-2010 03:55 AM

I found the problem! I had wrong permissions on my /mnt/net folder.

thank you for helping Switzerland :) , you got me on the RIGHT track!

All times are GMT -5. The time now is 05:47 AM.