-   Linux - Software (
-   -   Mount Issue in Gnome of FC7 (

shreks 06-05-2007 11:23 AM

Mount Issue in Gnome of FC7
I just installed FC7 a few days ago and am using Gnome as my desktop environment. One of my daily jobs is to back up my files from my hard drive to my USB portable drive. I use rsync to synchronize the data from ext3 hard drive partition to vfat portable drive partition. I use the following command to do the job:

rsync -v -t --modify-window=2 -r -u --delete -z "${SRC_DIR}" "${DEST_DIR}"

Everything was fine in FC6. But things were not going well in freshly installed FC7: some of my files were kept being backed up every time when I ran rsync command. I tracked down the problem by revealing the default mount options stored in /media/.hal-mtab, as shown here:

/dev/sdb1 501 0 vfat nosuid,nodev,uhelper=hal,shortname=lower,uid=501 /media/PHD

The culprit is the mount option "shortname=lower" which created lower-case directory names in vfat partition regardless of its original case in Linux ext3 partition. Therefore every time rsync deleted the lower-case directory in vfat, copied the source directory from ext3 to vfat, and then changed the case to lower ones. I checked out the manpage of mount and ran some tests, and found out that the mount option "shortname=winnt" does the right job: everything was kept exactly the same in vfat partition as those in ext3 one.

So my question is that where to put my customized mount option in FC7 system, so that every time when a removable device is plugged in, the correct mount option can be used automatically. It seems to have something to do with HAL but I have no idea where to store my mount options. Anyone could help me on this? Thanks a lot in advance!!!

BTW. I found a config file /etc/gconf/schemas/gnome-mount.schemas which contains something like:


I changed "lower" to "winnt", but had no effects at all on mounting plugged drives.

All times are GMT -5. The time now is 07:20 PM.