LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Mount ISO Read/Write (https://www.linuxquestions.org/questions/linux-software-2/mount-iso-read-write-329688/)

Johnsernickle 06-02-2005 04:25 PM

Mount ISO Read/Write
 
Hello, I am trying to edit a Live CD, Overclockix, to fold for my username. I downlaoded the ISO and mounted it using

Code:

mount  -o rw,loop -t iso9660 /home/luser/Overclockix_3.8.iso /mnt/iso/
But the filesystem is still read only! i just want to edit a textfile inside the ISO, and then burn it. It seems like it shouldnt be that hard. After that failed i extracted the ISO to a directory edited the file and was unable to figure out how to rebuild the ISO. If thats what i have to do how do i put the ISO back together? Thanks alot,

Petes

kencaz 06-02-2005 04:42 PM

you'll have to copy the files from /mnt/iso/ to another /home/directory/ make your changes then create a new .iso image file.

KC

king_nothingzzz 06-02-2005 04:47 PM

*mkisofs* is your friend.

I personally havent used it, but i know a few people who swear by it.

You can download it here --> http://freshmeat.net/projects/mkisofs/

There's also a nice write up to make your live cd/edit iso etc here --> http://www.asylumnation.com/blogs/am...post-2775.html

Hope this helps

Cheers

king_nothingzz

Johnsernickle 06-02-2005 09:33 PM

I have no idea how to remake this image. Ive been trying to do it for a while and i cant get it to work. I followed that guide, and tried to remake the ISO by

Code:

mkisofs -o /new.iso -b /home/luser/cdrom/boot/isolinux/isolinux.bin -c /home/luser/cdrom/boot/isolinux/boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table -J -R /home/luser/
but i always get the same error and i dont know whats wrong

INFO: UTF-8 character encoding detected by locale settings.
Assuming UTF-8 encoded filenames on source filesystem,
use -input-charset to override.
Unknown file type (unallocated) /home/luser/.. - ignoring and continuing.
call to search_tree_file with an absolute path, stripping
initial path separator. Hope this was intended...
mkisofs: Uh oh, I cant find the boot catalog directory '/home/luser/cdrom/boot/isolinux'!

Whats wrong!? i really want to get this working. Does anyone have an easier way of doign this, this is making me crazy!

Petes

jimsvoboda 06-03-2005 03:19 PM

Since you want to burn a cd anyway and since mkisofs is giving you trouble, instead of concentrating on regenerating the iso, just burn the files you recovered from the iso directly to a cd using k3b or your favorite cd burning software. Then if you really need the iso file, you can generate it from the cd.

Jason Swartz 11-29-2016 04:18 PM

@Johnsernickle

I know this thread is old but if anyone else came here to figure this out try the following
To Rebuild/Remake an ISO with mkisofs:

Lets assume the working folder for you extracted ISO image is ~/Desktop/CD
and for simplicity your boot file located at ~/Desktop/CD/boot.img

The code below will output the new ISO image at ~/Desktop/BOOTCD.iso

put the contents of the script below in a file called:
createiso.sh

Code:

#!/bin/bash

CDLABEL="BOOTCD"
ISONAME="BOOTCD.ISO"
 
mkisofs -o "$ISONAME" -v -J -R -D -A "$CDLABEL" -V "$CDLABEL" \
-no-emul-boot -boot-info-table -boot-load-size 4 \
-b boot.img CD

Open a terminal at ~/Desktop and run the script:
sh ./create-iso.sh

I have always has issues with mkisofs using true paths or ./CD
seems like mkisofs has issues with full paths and or using ./

This works for me and I hope this method and script helps someone else.

Good luck!

jefro 12-02-2016 11:32 PM

Jason Swartz, hello and welcome to LQ.

Thanks for the information.

The original post is 11 years ago :)

rob.rice 12-03-2016 12:11 AM

Thanks for the info


All times are GMT -5. The time now is 06:09 AM.