LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   mount cdrom in RHEL5 (https://www.linuxquestions.org/questions/linux-software-2/mount-cdrom-in-rhel5-587708/)

ust 09-27-2007 06:15 AM

mount cdrom in RHEL5
 
I usually use "mount /mnt/cdrom" to mount the cdrom in RH server , but after upgrade to RHEL5 , the command is longer used to mount cdrom , could advise how to mount cdrom on RHEL5 ? thx

reddazz 09-27-2007 07:08 AM

Try
Code:

#mount /media/cdrom
or
Code:

#mount /dev/hdX /media/cdrom
/dev/hdX would be your cd/dvd device name e.g. /dev/hdc, /dev/sdc etc.

ust 10-03-2007 03:17 AM

Quote:

Originally Posted by reddazz (Post 2905311)
Try
Code:

#mount /media/cdrom
or
Code:

#mount /dev/hdX /media/cdrom
/dev/hdX in would be your cd/dvd device name e.g. /dev/hdc, /dev/sdc etc.

thx
I tried /dev/hda-z but still not work , what is wrong ? thx

b0uncer 10-03-2007 03:24 AM

Quote:

I tried /dev/hda-z but still not work , what is wrong ? thx
hda usually refers to a harddisk (IDE), cd/dvd-drives are hdc, hdd or sdc, sdd or so..so try
Code:

mount /dev/hdc /media/cdrom
as root, provided that /media/cdrom exists. If it doesn't work, try hdd, sdc, sdd, ...

The defice files are under /dev so when you put the disc in, you can either have a look at /dev
Code:

ls /dev
or try to figure the device from dmesg for example:
Code:

dmesg | tail
The reason why a simple "mount /media/cdrom" doesn't work is probably that your /etc/fstab doesn't contain an entry that would tell what device (of your CD/DVD) should be mounted to what mountpoint with what options. Without such a line mount can't figure out what to mount to /media/cdrom unless you tell the exact device. Nowadays things are automated so if you're using a graphical desktop, you just put the disc in and it's mounted to the right place automatically (you can edit your udev rules file to change this behaviour). So, if you like to do it like you've done it so far, with "mount /media/cdrom", you're going to have to add an fstab entry. It's not difficult, but first figure out what device file it is that you use (hdc, hdd, ...?) -- after you successfully mount the drive, remember that device file and add a line to /etc/fstab. For more information about fstab, take a look at it's manpage.

jackofalltrades 11-13-2009 12:38 PM

mount cdrom in rhel 5
 
Try mount /dev/cdrom /mnt. I realize that may sound simplistic, but it is what I use and it works well.


All times are GMT -5. The time now is 09:45 AM.