-   Linux - Software (
-   -   Most YouTube videos and Facebook games won't play. (

LinuxLiker 04-02-2012 11:52 AM

Most YouTube videos and Facebook games won't play.
Hi --
I'm running Ubuntu vers. 10.04LTS and I installed a set of Ubuntu upgrades (the various fixes that are sent from Ubuntu periodically) and after this installation, I can't play most YouTube videos I try to play. Additionally, my wife says she can't play Facebook games.
After a few minutes of google-ing, I saw a suggestion the problem might be that flash player has "hardware acceleration" turned on -- the suggestion was to turn it off. I think the flash player is the problem because, YouTube will play HTML 5 videos but most of the videos I try to play on YouTube are Adobe Flash videos. (I haven't tried the Facebook games, but I'm hoping it's the same problem).
The instructions I found for fixing the hardware acceleration problem suggested right-clicking on the YouTube player window (while YouTube is parked on a channel page), selecting the "settings" submenu, display option and turning off hardware acceleration. However, when I right click the player window, I don't get to a submenu for settings.
I subsequently read a post that said you have to have moving video in the YouTube Player window in order to bring up the "settings" submenu.
Is there anyone who recognizes this problem and could suggest a fix?


273 04-02-2012 03:55 PM

It sounds like you don't have Flash installed at all. Try following the relevant instructuoons here:
That ought to install Flash or re-install it if it has been removed in the upgrade for some reason.
The unticking hardware accelleration is, as far as I know, a fix for the "blue people" problem NVIDIA useres are currently seeing.

r.stiltskin 04-02-2012 06:13 PM

The Flash update that was released last Thursday (3/29) completely broke Flash for many users, including myself. As far as I know no "update-update" has been been released yet, but an easy temporary solution is to extract and copy a previous version of to folder /usr/lib/adobe-flashplugin.

You can find a link to a usable version of that module here. I've been using that one in my 10.04LTS machine since last Thurs & haven't had any trouble with it.

hydraMax 04-03-2012 12:53 AM

I won't use a proprietary flash plug-in or encourage anyone else to do so. However, regarding the YouTube HTML5 issue: There is a program/script called "youtube-dl" available for Gnu/Linux which will download the video from any YouTube page and save it to disk as an .flv video, which you can then play easily with the VLC video player. I watch most videos as HTML5 through Firefox, but then if I come across one that isn't available through HTML5, I just download it quickly with youtube-dl. This is also handy if I come across any YouTube video that I want to save permanently.

For Ubuntu, just "apt-get youtube-dl" then use the command "youtube-dl -t <copy-page-url-here>" in a directory in which you want the video saved.

hydraMax 04-03-2012 01:10 AM

BTW, another neat thing about "youtube-dl" (let me know if I'm boring anyone): If you start downloading a video, the partially downloaded video is saved to a <name-of-video>.part file. If you are impatient, you can play this video with VLC because VLC can handle partially downloaded flv video files, so long as you are downloading video at least as fast as VLC is playing it.

The *.part file might get deleted while you are in the middle of watching it (because it is copied to the full video file) but this will not interrupt your playback of the video. This is because the Gnu/Linux system will not actually delete any file's data until all open file descriptors to that file have been closed. (I.e., until VLC is actually done using it.)

273 04-03-2012 07:19 AM

I won't "encourage" people do do so, however, I use it because:
Firefox has never been able to play HTML5 properly on my system and sometimes messing about downloading is not convenient.
The main TV stations over here stream in Flash on their webisites, the only alternative being that one of them (BBC iPlayer) can be accesed through a script.
The one movie site I've found which gives decent, free streaming movies uses Flash.
A few games I find amusing use Flash (e.g. Fantastic Contraption).
Ocasionally a new game or joke will come up which uses Flash. I could justignore these things but man is a social animal so it's nice to see them.

As a Linux user without Silverlight I've already limited my entertainment choices by ruling out things like Netflix and Lovefilm -- I'm not about to limit them further by eschewing flash player on principal.
If Flash were dropped by everyone tomorrow then the only video entertainment consistently available to me on the internet would be YouTube through Chromium. I don't have any love at all for Flash but I also have no viable alternative -- if Flash on Linux goes I'll have to buy Windows or a Mac.
Apologies for going on about it, but it gets a little wearing to bo told Flash is evil all the time and be given a couple of download scripts as an alternative.

LinuxLiker 04-03-2012 09:09 AM

Thanks for ideas
Thanks for the different ideas. So far I've tried numerous times to solve the problem using different packages -- older versions of flash, or open source players that are supposed to play flash videos. Nothing's working -- I can't find a package version of an older flash application, invariably all links lead back to the Adobe site and the current version of flash. And the applications I tried that are supposed to play flash -- gnash and swifdec (I've heard swifdec is old) -- won't play flash videos on my computer.
I'm not great at compiling .tar software, but I think I can possibly find an older version of flash that way, so that's probably my next step. (I use a lot of my free time doing computer work for my job, so I haven't invested a lot of time getting better at my linux skills).
I was reading some information online about flash that noted that the latest update 11.2xxxxx is the last flash update for linux and that from now on later versions of flash will be included with google chrome. Does this mean linux users will have to find the linux version of the google chrome browser to access flash videos?


r.stiltskin 04-03-2012 10:53 AM

No. You don't have to compile anything.

I had the same problem. Whatever I tried to install, it ended up reinstalling the same new version. So with that (non-working) version still installed:

1. download this file install_flash_player_11_linux_i386.tar.gz

2. extract it

3. directly inside the extracted folder there is a file called Just copy that file and paste it into your already-existing folder /usr/lib/adobe-flashplugin, e.g.:

sudo cp /usr/lib/adobe-flashplugin
That will replace the non-working module that was installed by the update.

purevw 04-03-2012 11:26 AM

I'm not a Ubuntu user and may be way off base, but is your architecture x86 or x_64? I ask because in OpenSuSE, mixing architectures may cause problems. If this is the case, then the path for would be different also. It might be /usr/lib64/*** I use Flash 64 bit in OpenSuSE 12 and have never had problems.

TobiSGD 04-03-2012 11:47 AM


Originally Posted by LinuxLiker (Post 4643584)
I was reading some information online about flash that noted that the latest update 11.2xxxxx is the last flash update for linux and that from now on later versions of flash will be included with google chrome. Does this mean linux users will have to find the linux version of the google chrome browser to access flash videos?

That is not quite true. The Adobe developers will give 5 years support for 11.2, newer versions will be released, but limited to the Pepper plug-in interface. Currently only Chrome is using that, but nothing is prohibiting any other development team to implement that plug-in API into their browsers.

cfdisk 04-04-2012 12:01 AM


I have Slackware and bumped into the same problem. The latest sits in /usr/lib/mozilla/plugins yet none of Adobe-laced sites/players works.

Did we, penguins, finally reach the end of the Adobe flash tunnel?

Is the latest flash working on your Slackware box, please?

TobiSGD 04-04-2012 07:10 AM

Yes, Flashplayer running on 32 and 64 bit Slackware boxes. I recommend to either use the Flashplayer SlackBuild, or, even easier, the ready-built packages from AlienBob to install it, that way I have installed them.

cfdisk 04-04-2012 08:25 AM

Thanks, TobiSGD.

I will give it a try.

I already got the patched Flashplayer version 10.3 from Adobe website and it works ( Adobe put that for those who are unable to update to 11.2, as they say ). They released the latest 11.2 and that patched 10.3 on the same day March 29 so I feel safe for a while :D

Thanks again!

cfdisk 04-19-2012 09:54 AM


Long time no talk ;)

Unfortunately, Flashplayer SlackBuild won't work for me. It passed the clean instal, in other words, the script *SBo.tgz was successfully executed.

However, the plugin made by the script is dead for me as if I would put file directly from Adobe site into /usr/lib/mozilla/plugins folder.

The latest Adobe Flash Player is version ( they updated just a few days ago ) Just to make it clear, neither Flashplayer SlackBuild plugin with nor version from the Adobe site work for me.

What did I miss? Are you running the latest Flash Player

Thanks in advance.

All times are GMT -5. The time now is 03:42 PM.