-   Linux - Software (
-   -   More Rsync help please (

wh33t 09-06-2007 11:36 AM

More Rsync help please
Hey guys,

I've managed to figure out how to get Rsync working across the network with ssh with out needing a log in password. I ran rsync yesterday against our main server in the office and it backed up 600GB of data in a few hours. I ran it this morning expecting to see it only update <50mb but it looks like its gonna download all 600GB again...

What I would like is for it to only download the changed files, or even better, just download the binary differences from the server. Could someone post me an rsync command that would allow me to do this? I've read the manpage and there is so many options, i have no idea in what order or which ones to use to pull this off and i've tried a few, and at 600GB a try it's quickly wasting my life. Thanks guys.

AlucardZero 09-06-2007 12:02 PM

It only transfers the changes, by default. Are you backing up to a different place?

wh33t 09-06-2007 12:17 PM

Well I should say, I am running rsync through rsync for windows, and using the win32 binary of openSSH and cygwin.dll to make all this happen. I ran the exact same command and I saw it downloading all these files again. I was expecting it to see it update just a few changes and that's all. The files I am backing up are all Virtual Machines. Rsync would have the ability to read the difference of binary data and just send that wouldn't it?

wh33t 09-06-2007 12:23 PM

I'm running


rsync -avzr --progress user@ipaddress:/mnt/ x:\
And that ended up downloading 191GB. Much less than the 600Gb before. So I was wrong about it downloading everything all over again, but I promise 191GB haven't changed since last night.

wh33t 09-06-2007 12:41 PM

Ok, after doing more research I have discovered that I am probably reading the progress bars incorrectly. When I see the progress bar saying 32MB/s I think that means it's scanning the file for changes at that speed. Not transfering? I think 191GB is the size of everything that it checked. The transfered data might be as small as a few hundred kilobytes. That sounds a little better doesn't it?

All times are GMT -5. The time now is 12:49 AM.