-   Linux - Software (
-   -   MonoDevelop won't start as regular user (

nagromo 05-11-2005 04:49 PM

MonoDevelop won't start as regular user
I'm using Debian and Monodevelop 0.5.1-2

As root, MonoDevelop runs fine. When I try to use it as a regular user, though, it shows the splash screen and exits. Here's the command line output:


morgan@morgan-debian:~/.config$ sudo monodevelop
Creating DefaultWorkbench
Parsing assembly: /usr/lib/mscorlib.dll

(MonoDevelop:15836): Gtk-CRITICAL **: gtk_container_remove: assertion `GTK_IS_TOOLBAR (container) || widget->parent == GTK_WIDGET (container)' failed

morgan@morgan-debian:~/.config$ monodevelop

** (./MonoDevelop.exe:15883): WARNING **: Shared memory sanity check failed.

** (./MonoDevelop.exe:15883): WARNING **: status: 1

** (./MonoDevelop.exe:15883): WARNING **: daemon: [, Culture=neutral, PublicKeyToken=9c7a200e36c0094e"']

** (./MonoDevelop.exe:15883): WARNING **: Failed to attach shared memory! Falling back to non-shared handles
See: for details
Loading error, please reinstall :
System.ComponentModel.Win32Exception: Cannot find the specified file
in <0x0068c> System.Diagnostics.Process:Start_common (System.Diagnostics.ProcessStartInfo,System.Diagnostics.Process)
in <0x00015> System.Diagnostics.Process:Start ()
in <0x0005d> (wrapper remoting-invoke-with-check) System.Diagnostics.Process:Start ()
in <0x000cf> MonoDevelop.Services.SystemAssemblyService:GetVariableFromPkgConfig (string,string)
in <0x000b1> MonoDevelop.Services.SystemAssemblyService:ProcessPiece (string,string)
in <0x0017d> MonoDevelop.Services.SystemAssemblyService:GetAssembliesWithoutLibInfo (string,string)
in <0x0015a> MonoDevelop.Services.SystemAssemblyService:ParsePCFile (string)
in <0x00475> MonoDevelop.Services.SystemAssemblyService:InitializeService ()
in <0x001d1> MonoDevelop.Core.Services.ServiceManager:InitializeServicesSubsystem (string)
in <0x004db> MonoDevelop.SharpDevelopMain:Main (string[])

Writing /home/morgan/.config/MonoDevelop/CodeCompletionData/mscorlib_1.0.5000.0_b77a5c561934e089.pidb
As you can see, it runs fine as root but not as me. This output was made after I moved the ~/.config/MonoDevelop directory to a new location.

Does anyone have any ideas on fixing this?


sausagejohnson 05-25-2005 12:42 AM

Similar problem. Although I run as root all the time and even then, sometimes I get a similar page of garbage. Eventually it runs. If you leave it a while, it may come good. If anyone knows why this happens let us know. I'm on v1.1.7

sausagejohnson 05-25-2005 01:48 AM

Solved my problem. My mono version is the latest 1.1.7 and the monodevelop is latest 0.7. I went to and downloaded the 0.6 source. I removed the old mono develop package with rpm -e monodevelop and then compiled and installed the 0.6 source with:


. Seems to be running nicely and loading previous projects.

By the way, I'm running FC3. Hope this helps you out.

All times are GMT -5. The time now is 01:48 AM.