-   Linux - Software (
-   -   mondorestore on ubuntu, fatal error! (

brianpbarnes 03-11-2009 04:40 PM

mondorestore on ubuntu, fatal error!
I have both Suse 11.1 and Ubuntu 8.10 on 2 different hard drives. Ubuntu has always been flaky on Ubuntu. I have to unmount all ntfs drives and comment them out of my fstab before I have any chance to get a mondoarchive to run to completion. It still crashes most of the time and often ignores my exclude list. But, I can look at the files in the resulting ISO image in Ubuntu. I loaded mondo/mindi with Synaptic and then reloaded them in case they got corrupted somehow. No difference.

No problem. It works flawlessly in Suse. So, I just image "golden versions" both system drives in Suse and I am done.

Until a recent update to the proprietary ATI video card driver. It destroyed my X windows. When I startx, it looks like 6, overlapping text windows on top of the screen and my cursor is a 1 inch jagged square.

So, I rebooted to ubuntu and tried a mondorestore. As expected, complete crash and burn. The people at do not respond to messages sent to their mailing list after repeated tries including a zipped version of their log files. I followed the instructions and have heard nothing.

Then, I tried booting from the boot ISO. Completely worthless. It can not even find the image on either the dvd or a hard drive and almost always crashes in the process. "Please insert your floppy or cd. FATAL ERROR!". After some monkeying around by stripping my system down to just 1 dvd, my suse system drive and my ubuntu hard drive, I got it to go for about 10 seconds. The restore was at 1% and it croaked with an error message: "MOMMY!". Now, I can not even boot to the command line.

The moral of the story is an ISO archive is useless for disaster recovery if the restore doesn't work. I am going to buy another hard drive, put on a skeletal Suse 11.1, install nothing but mondo, archive the system drive and then see if restore __actually__ works.

Part of the problem may be my bleeding edge hardware. It has one of Intel's latest, P45 chipset and ddr3. Maybe mondo and the gang are developing and testing on 386s.

Acronis True Image is also broken on my win xp system on another hard drive on this same workstation. It sees everything except my SATA drives! I had to compile up a BartPE boot disk with the original windoz install files and an Acronis module slipstreamed in. BartPE is pretty cool for disaster recovery. THANKS BART!!! I looked for a mondo module for BartPE, but can't seem to find one. Is there one? I would rather have to reboot than reinstall.


All times are GMT -5. The time now is 02:30 PM.