-   Linux - Software (
-   -   modprobe usb-storage: FATAL: Error inserting (

annekaelber 06-05-2010 06:29 AM

modprobe usb-storage: FATAL: Error inserting
I took some pictures tonight and plugged in my flash card reader (via usb) as always. Only this time, the device isn't assigned a proper location (like "sdc3").

A little research later and I *think* I need the module "usb-storage", which I can't get to load. It's been a *long* time since I had to mess with modules and I'd like some fresh eyes on what the problem might be.

This is my lsmod output:

# lsmod
Module                  Size  Used by
oss_usb                99276  1
oss_hdaudio          128356  3
osscore              548308  2 oss_usb,oss_hdaudio
ipv6                  243508  27
pcmcia                33772  0
pcmcia_core            32016  1 pcmcia
lp                      9316  0
fuse                  54008  1
nvidia              9965252  28
psmouse                41676  0
serio_raw              5024  0
agpgart                29256  1 nvidia
k8temp                  4156  0
sg                    24912  0
forcedeth              54636  0
i2c_nforce2            6368  0
rtc_cmos              10124  0
thermal                15096  0
rtc_core              15992  1 rtc_cmos
parport_pc            24036  1
processor              38600  1 thermal
thermal_sys            10756  2 thermal,processor
rtc_lib                2332  1 rtc_core
parport                30700  2 lp,parport_pc
button                  5708  0
hwmon                  2104  2 k8temp,thermal_sys
evdev                  9152  10

I also ran modprobe with -n -v:

# modprobe -n -v usb-storage   
insmod /lib/modules/

I have run depmod -a and tried the modprobe again...

# depmod -a
# modprobe usb-storage
FATAL: Error inserting usb_storage (/lib/modules/ Invalid argument

If I drill down to the /lib/modules/<kernel -r>/drivers/usb/storage/ where the .ko file is and say:

# insmod ./usb-storage.ko
insmod: error inserting './usb-storage.ko': -1 Invalid parameters

So.... since I haven't changed anything that I can think of since the last time I took pictures...what happened? How do I fix this?

(Note: I'll be honest. It's 3:30 in the morning and we've been packing for a move. I don't recall how I came to the idea that I might be missing usb-storage. Is this a red herring? Am I barking down the wrong path?)

Thanks in advance!


annekaelber 06-05-2010 06:38 AM


I'm loathe to reveal the level of idiocy I just discovered... but, in the interests of saving you all time: I figured it out. I put the compact flash card into the reader backwards.

I *swear* I thought it couldn't do that... *sigh*

*trundles off to bed in shame*


alan99 06-08-2010 12:07 AM

I think usb storage should be automatically loaded by the udev hotplug system. But if you do need to load it manually, you should give the command as modprobe usb_storage (you must use the underscore, note the underscores in the module names when you lsmod)

annekaelber 06-08-2010 12:34 AM


Originally Posted by alan99 (Post 3996128)
you should give the command as modprobe usb_storage (you must use the underscore, note the underscores in the module names when you lsmod)

Since my problem is solved, I'm responding to share something my man pages told me which contradicts this. I typed "man modprobe". It said this in the entry: "modprobe intelligently adds or removes a module from the Linux kernel: note that for convenience, there is no difference between _ and - in module names." I *did* still try typing it both ways -- but the result wasn't different. In the end, my problem was PEBKAC: Problem exists between keyboard and chair. :doh:


All times are GMT -5. The time now is 01:18 AM.