LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-01-2004, 09:53 AM   #1
byebluescreen
LQ Newbie
 
Registered: Dec 2003
Posts: 1

Rep: Reputation: 0
modem-modem everywhere but not the internet met


Modem Modem Modem...

The other day I had enough of the BS of death...So here I am with fedora... I am very happy with it so far...but I can not figure out even with finding books on support...why my modem can not be read...I just installed a new US Robotics modem...and I can fedora activate it but it refuses to dail in.

If anyone can please tell me how to get this modem to work... I can leave the ms world behind and join the living.

Steps taken:
-added new hardware... with dns and number...fedora says "active"
-when I "minicom" set port info...no problem...init- no problem...but when I try to dail in trought minicom...it just ...does not dail-in.
I hope that makes it easier.

Thank you.
BSscreen
 
Old 01-01-2004, 11:08 AM   #2
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Post the output (concerning your modem) of cat /proc/pci

If it's a hardware pci modem, here is how it's done:
# Configuring a real hardware pci modem
To configure a pci modem, open an x terminal and su - to the root account:
Code:
[fancy@tinwhistle fancy]$ su -
Password: 
[root@tinwhistle root]# cat /proc/pci
Look for your modem in the returned list. Look for something similar to mine:
Code:
  Bus  2, device   2, function  0:
    Communication controller: PCI device 151f:0000 (TOPIC SEMICONDUCTOR Corp) (rev 0).
      IRQ 5.
      I/O at 0xc400 [0xc407].
With this info, I use the setserial command:
Code:
[root@tinwhistle root]# setserial /dev/ttyS0 irq 5 port 0xc400 uart 16550a
Then I test the modem with the internet connection wizard and it works. I edit /etc/rc.d/rc.local and enter the setserial command:
Code:
[root@tinwhistle root]# pico -w /etc/rc.d/rc.local
My file for an example
Code:
#!/bin/sh
# Redhat /etc/rc.d/rc.local file
# This script will be executed *after* all the other init scripts.
# You can put your own initialization stuff in here if you don't
# want to do the full Sys V style init stuff.

touch /var/lock/subsys/local
# configure modem
setserial /dev/ttyS0 irq 5 port 0xc400 uart 16550a
Now, it remains configured after a reboot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Modem internet connection appasamy Linux - Hardware 1 12-20-2004 12:34 PM
Nic card -> cable internet modem no internet connection zeshan_b Mandriva 21 09-26-2004 12:48 PM
INTERNET on linux thru modem? lakhil Linux - Newbie 2 05-23-2004 07:36 AM
No internet with my cable modem. hitekrednek Linux - Newbie 5 02-20-2004 04:28 PM
Modem connects but no internet dibblethewrecke Linux - Networking 8 11-28-2003 01:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration