LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-28-2011, 08:07 AM   #1
RKris
Member
 
Registered: May 2002
Location: UK
Distribution: Mandriva linux
Posts: 152

Rep: Reputation: 15
mklivestatus compile issue on nagios


i am trying to integrate nagios with mklivestatus and during the compilation of livestatus.o module, it fails, i have installed all the packages which are required according to the documentation.

output of rpm -qa on my centos 5.6 box:

libstdc++-4.1.2-50.el5
libstdc++-4.1.2-50.el5
libstdc++-devel-4.1.2-50.el5
make-3.81-3.el5
gcc-4.1.2-50.el5
libgcc-4.1.2-50.el5
gcc-c++-4.1.2-50.el5
libgcc-4.1.2-50.el5

i have attached the full log of mklivestatus here

http://chopapp.com/#erojbw91


any ideas why the install fails???
 
Old 09-28-2011, 06:16 PM   #2
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware 14.2
Posts: 2,815
Blog Entries: 1

Rep: Reputation: 261Reputation: 261Reputation: 261
As it states on line 384 of your build log --> "bits/c++config.h: No such file or directory".
 
Old 09-30-2011, 07:49 AM   #3
RKris
Member
 
Registered: May 2002
Location: UK
Distribution: Mandriva linux
Posts: 152

Original Poster
Rep: Reputation: 15
Wink

Quote:
Originally Posted by weibullguy View Post
As it states on line 384 of your build log --> "bits/c++config.h: No such file or directory".
thanks for that i upgraded libstdc++-devel-4.1.2

yum install libstdc++-devel-4.1.2

and that got it compiled!!!!!!cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Issue during Nagios Installation? your_shadow03 Linux - Server 7 09-03-2009 08:11 AM
Nagios - Latency issue amrit.singh Linux - Server 3 05-15-2008 06:04 AM
Issue during Nagios Setup????? ajeetraina Linux - Software 1 12-07-2007 03:52 PM
regarding nagios issue wellspringblossom Linux - Server 1 02-21-2007 09:28 AM
Nagios Plugin Compile Anarusis Linux - Software 3 04-10-2005 03:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration