LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-19-2008, 11:47 AM   #1
serafimg
Member
 
Registered: Jan 2006
Distribution: Ubuntu 10.10 64-bit
Posts: 60

Rep: Reputation: 16
Question mixxx starting problem


Hallo!

I run Ubuntu Linux 7.10 on my notebook with an amd 64-bit processor and ATI graphic card. I successfully installed mixxx but when I try to start it from the menu it does absolutely nothing.
When I typed in the Terminal "mixxx" it returned me the following results:

Debug: Starting up...
Debug: Api name: OSS
Debug: Api name: ALSA
Segmentation fault (core dumped)

Do you have any ideas?

Thanks for advance and sorry for my english level.
 
Old 02-19-2008, 03:19 PM   #2
weisso5
Member
 
Registered: Oct 2007
Location: New York City
Distribution: Gentoo, FC
Posts: 133

Rep: Reputation: 16
Hello,

Couple Questions for you:

1. How did you install mixxx, i know you can either use apt-get or install via binary?

2. Do you have sound working on your box?


Thanks,
weisso
 
Old 02-20-2008, 12:48 PM   #3
serafimg
Member
 
Registered: Jan 2006
Distribution: Ubuntu 10.10 64-bit
Posts: 60

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by weisso5 View Post
Hello,

Couple Questions for you:

1. How did you install mixxx, i know you can either use apt-get or install via binary?

2. Do you have sound working on your box?


Thanks,
weisso
1. I installed it via Synaptic.
2. The sound is working perfectly. The only sound problem that I face is that when I plug in my headphones the sound is still playing from the speakers.

Thanks for the response!
 
Old 02-20-2008, 01:08 PM   #4
weisso5
Member
 
Registered: Oct 2007
Location: New York City
Distribution: Gentoo, FC
Posts: 133

Rep: Reputation: 16
So according to the lack of information on Mixxx, there could be a few things causing this problem.
Apparently if you don't have up-to-date graphic drivers, it could cause Mixxx to crash in Xorg.

1. Please make sure you have the latest graphic drivers, if you want help with that i can help you.
1a. Make sure you have these dependencies:
QT >= 3.1
libmad
libid3tag
libsndfile
vorbisfile
pkg-config

2. Once that is confirmed, we are going to try and install from binary (as root).
A. Download package:
http://prdownloads.sourceforge.net/m...r.bz2?download
b. tar -xvjf mixxx-1.5.0.1-linux.tar.bz2
c. cd mixxx (tab complete it)
d. ./install.pl

The install script will install the program in /usr/bin with midi configs and skins in
/usr/share/mixxx. The placement of the skin, keyboard and midi configs can be
changed in the users ~/.mixxx.cfg file created after the first startup of the program.

let me know how it goes,

-weisso
 
Old 05-03-2008, 04:14 AM   #5
serafimg
Member
 
Registered: Jan 2006
Distribution: Ubuntu 10.10 64-bit
Posts: 60

Original Poster
Rep: Reputation: 16
I have upgraded to Ubuntu 8.04.
Now Mixxx can open, it seems playing the tracks but nothing. There is no sound.
There may be something in preferences but I didn't managed to find out.
 
Old 10-14-2010, 04:31 AM   #6
serafimg
Member
 
Registered: Jan 2006
Distribution: Ubuntu 10.10 64-bit
Posts: 60

Original Poster
Rep: Reputation: 16
Thumbs up

This problem fixed by the newer versions of mixxx.

Thanks a lot to the developers!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting problem...please help.... kitz809 Linux - Laptop and Netbook 3 07-22-2007 10:45 PM
problem on starting X satimis *BSD 0 06-27-2007 01:40 AM
Problem starting X alexklant Slackware 5 04-02-2005 04:41 AM
mixxx under suse 9.1 fatal error Unable to resolve GL/GLX symbols ranjo Linux - Software 3 06-20-2004 03:27 PM
a problem with starting x sometimes php Linux - General 2 07-12-2002 02:22 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration