LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-05-2010, 09:22 AM   #1
ninja master
Member
 
Registered: May 2008
Distribution: funtoo/gentoo amd64 xwrt
Posts: 412

Rep: Reputation: 31
mixxx compilation problems


scons =( not my strong suit...

im using

Code:
scons prefix=/usr qtdir=/opt/qt4
to configure and i get these compilation errors

Code:
 scons prefix=/usr qtdir=/opt/qt4
scons: Reading SConscript files ...
Platform: Linux i686

scons: warning: The build_dir keyword has been deprecated; use the variant_dir keyword instead.
File "/mixxx-1.7.2/SConstruct", line 42, in <module>
WE ARE IN: /mixxx-1.7.2/linux_build
QT path: /opt/qt4
Loading qt4 tool...
sh: bzr: command not found
Checking for C library portaudio... (cached) yes
Checking for C library id3tag... (cached) yes
Checking for C library mad... (cached) yes
Checking for C library sndfile... (cached) yes
Checking for C library vorbisfile... (cached) yes
Checking for C library vorbis... (cached) yes
Checking for C library ogg... (cached) yes
Checking for C library mp4... (cached) yes
Checking for C library faad... (cached) yes
Checking for C library GL... (cached) yes
Checking for C library GLU... (cached) yes
Not working FFMPEG support... disabled
Checking for pkg-config (at least version 0.15.0)... (cached) yes
Checking for QtCore (4.3 or higher)... 	(cached) yes
Checking for C library asound... (cached) yes

Features Summary:
================
libdjconsole support... disabled
High quality EQs... enabled
iPod support... disabled
Shoutcast support... disabled
LADSPA support... enabled
Vinyl Control... enabled
Tonal analysis... disabled
Apple M4A audio file support... disabled
Test suite... disabled
MixxxScript Studio... disabled
MIDI Scripting... enabled
Optimizations... enabled
gprof profiling support... disabled
Optimizing for this CPU... no
Debugging message output... enabled
ALSA API... Sequencer
MSVS 2005 hacks... disabled
Force 32-bit GCC compile... disabled
Case Metrics profiling... disabled
================
Building with flags: hifieq ladspa vinylcontrol midiscript optimize=1 qdebug 
================

Install root: /usr
scons: done reading SConscript files.
scons: Building targets ...
g++ -o linux_build/analyserbpm.o -c -pthread -pipe -Wall -W -g -DQT_GUI_LIB -D__SNDFILE__ -DQT_SHARED -DQT3_SUPPORT -DSETTINGS_PATH=\".mixxx/\" -DBPMSCHEME_FILE=\"mixxxbpmscheme.xml\" -DSETTINGS_FILE=\"mixxx.cfg\" -DTRACK_FILE=\"mixxxtrack.xml\" -DUNIX_SHARE_PATH=\"/usr/share/mixxx\" -Di686 -D__LINUX__ -D__UNIX__ -D__PORTAUDIO__ -DQT3_SUPPORT -DQT3_SUPPORT_WARNINGS -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_TABLET_SUPPORT -D_REENTRANT -DT_LINUX -D__LADSPA__ -D__VINYLCONTROL__ -D__MIDISCRIPT__ -D__ALSASEQMIDI__ -I/opt/qt4/include -I/usr/include/QtCore -I/usr/include/QtGui -I/usr/include/QtOpenGL -I/usr/include/Qt3Support -I/usr/include/QtNetwork -I/usr/include/QtSql -I/usr/include/QtXml -I/usr/include/QtSvg -I/usr/include/QtScript -Ilinux_build -Isrc -I. -I/home/edited/Downloads -I/opt/qt4/include/Qt3Support -I/opt/qt4/include/QtCore -I/opt/qt4/include/QtGui -I/opt/qt4/include/QtXml -I/opt/qt4/include/QtOpenGL -I/opt/qt4/include/Qt -Ilib/soundtouch-1.4.1 -Ilib/kissfft -Ilib/fidlib-0.9.9 -Ilib/ladspa -Ilib/xwax -Ilib/scratchlib -I/opt/qt4/include/QtScript src/analyserbpm.cpp
In file included from /usr/include/QtCore/QtDebug:1,
                 from src/analyserbpm.cpp:2:
/usr/include/QtCore/qdebug.h: In destructor 'QDebug::~QDebug()':
/usr/include/QtCore/qdebug.h:84: error: 'QT_TRY' was not declared in this scope
/usr/include/QtCore/qdebug.h:84: error: expected `;' before '{' token
/usr/include/QtCore/qdebug.h:86: error: expected primary-expression before '&' token
/usr/include/QtCore/qdebug.h:86: error: expected primary-expression before ')' token
/usr/include/QtCore/qdebug.h:86: error: 'QT_CATCH' was not declared in this scope
/usr/include/QtCore/qdebug.h:86: error: expected `;' before '{' token
In file included from src/analyserbpm.h:6,
                 from src/analyserbpm.cpp:6:
src/analyser.h: At global scope:
src/analyser.h:19: warning: unused parameter 'tio'
src/analyser.h:19: warning: unused parameter 'sampleRate'
src/analyser.h:19: warning: unused parameter 'totalSamples'
src/analyser.h:21: warning: unused parameter 'tio'
src/analyserbpm.cpp: In member function 'virtual void AnalyserBPM::initialise(TrackInfoObject*, int, int)':
src/analyserbpm.cpp:18: warning: unused variable 'defaultrange'
src/analyserbpm.cpp: At global scope:
src/analyserbpm.cpp:14: warning: unused parameter 'totalSamples'
scons: *** [linux_build/analyserbpm.o] Error 1
scons: building terminated because of errors.
ive been scratching my head at this one for days, i turned on the ubuntu virtual machine and checked what apt wanted to pull, and im suspecting that i need to find the source versions of several packages in regard to qt4 and libqt4 and various libqt4 extensions.
 
Old 12-05-2010, 09:37 AM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,489

Rep: Reputation: 2614Reputation: 2614Reputation: 2614Reputation: 2614Reputation: 2614Reputation: 2614Reputation: 2614Reputation: 2614Reputation: 2614Reputation: 2614Reputation: 2614
what version of gcc is installed ?
the errors look a bit like gcc 4.5 for code wrote fore gcc 4.1

and a question on passing this "DQT3_SUPPORT" ?is qt3 and it's source and config files also installed

scons is also not something i use a lot
Only for the HP calculator rom's ( hp11c & 41c-the one i learned on )

you also are pointing to the qt4 "qtdir=/opt/qt4" but scons is grabbing from "/usr/include/QtCore"
is 3 AND 4 installed on the same OS ?

if so then you might need to edit the link /usr/bin/qmake to point to the qt4 version
 
Old 12-05-2010, 10:43 AM   #3
ninja master
Member
 
Registered: May 2008
Distribution: funtoo/gentoo amd64 xwrt
Posts: 412

Original Poster
Rep: Reputation: 31
yes on 2 qts, i use the qt3 for kde 3.5 when i put kde 4 on here it flipped out, in general i use xfce, and if it flips out kde is my fallback

gcc (GCC) 4.2.3

im trying to stick to community centric ideas and work via sources only.... (usually if i post its because i need a source i cannot find, or i cant put the pieces together quite right) in general screwing with every single source / package on a system is a GREAT IDEA
 
Old 12-05-2010, 11:25 AM   #4
ninja master
Member
 
Registered: May 2008
Distribution: funtoo/gentoo amd64 xwrt
Posts: 412

Original Poster
Rep: Reputation: 31
thanks for the help... it was actually looking for something else qt is clearly not my strong suit either....


Quote:
[ /usr/bin ]# ln -s /opt/qtsdk-2010.05/bin/qmake .
Quote:
scons prefix=/usr qtdir=/opt/qtsdk-2010.05
the specific package is still erroring, but im pretty sure i can hammer anything out past that. i think i actually have 3-4 versions of qt?!? how do i purge the old ones? LOL
 
Old 12-05-2010, 11:29 AM   #5
ninja master
Member
 
Registered: May 2008
Distribution: funtoo/gentoo amd64 xwrt
Posts: 412

Original Poster
Rep: Reputation: 31
Not working FFMPEG support... disabled i dont get why this is flagged disabled, i just installed it!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] mixxx starting problem serafimg Linux - Software 5 10-14-2010 04:31 AM
C++ compilation problems madhatter301 Programming 4 03-16-2005 05:13 PM
mixxx under suse 9.1 fatal error Unable to resolve GL/GLX symbols ranjo Linux - Software 3 06-20-2004 03:27 PM
Compilation Problems kamransoomro84 Programming 9 05-04-2004 06:39 PM
X compilation problems da Perp Linux From Scratch 2 07-16-2002 02:46 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration