LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-15-2004, 03:42 PM   #1
mrsolo
Member
 
Registered: Jun 2002
Location: Where ever the Navy sends me
Distribution: Gentoo
Posts: 320

Rep: Reputation: 30
missing pilot conduits in MDK 10.1?


I just did a clean upgrade to mandrake 10.1 and it seems that the addressbook and calendar conduits in gnome-pilot-conduits-2.0.11 are missing? When I was running MDK 10, I could sync my contacts and calendar and a few other things. Why are these conduits missing in 10.1?
 
Old 11-15-2004, 04:18 PM   #2
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
That is strange. However, I just searched "available software" on my 10.1 system, and find that this package IS available on the distro CD's. So apparently I could install it if I missed it. (I don't use Gnome desktop, though; I use jpilot and the pilot-link software instead.)

See if you can get the missing conduits package off your CD's.
 
Old 11-15-2004, 04:26 PM   #3
mrsolo
Member
 
Registered: Jun 2002
Location: Where ever the Navy sends me
Distribution: Gentoo
Posts: 320

Original Poster
Rep: Reputation: 30
I did what you did but under gnome-pilot-conduits-2.0.11-1 this is wha it says:

This is a collection of additional conduits for gnome-pilot, it currently features
- MAL conduit
- email conduit
- expense conduit
- memo file conduit
- time conduit

Does that mean by saying that it's an "additional" collection that the package gnome-pilot-2.0.11-4 already has conduits and it's just my installation that is messed up?
 
Old 11-15-2004, 04:31 PM   #4
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
Quote:
Originally posted by mrsolo
I did what you did but under gnome-pilot-conduits-2.0.11-1 this is wha it says:

This is a collection of additional conduits for gnome-pilot, it currently features
- MAL conduit
- email conduit
- expense conduit
- memo file conduit
- time conduit

Does that mean by saying that it's an "additional" collection that the package gnome-pilot-2.0.11-4 already has conduits and it's just my installation that is messed up?
It sure does sound that way. Hmm. I don't see how it could hurt anything to go ahead and install this, and see (1) if additional packages show up as required in the process; (2) if, assuming the installation succeeds, it solves your problem. You can always uninstall it again if you don't get what you want.

Wish I knew more, but that's the best I can do at present, not using the Gnome desktop myself.

Any other Gnome people have ideas or experience with this?
 
Old 11-15-2004, 04:47 PM   #5
mrsolo
Member
 
Registered: Jun 2002
Location: Where ever the Navy sends me
Distribution: Gentoo
Posts: 320

Original Poster
Rep: Reputation: 30
OK, I have an update. When I upgraded from MDK 10, I first installed FC3 and then decided that it sucked, so I wiped the root partition without getting rid of my /home partition. I did this because I didn't want my user settings messed up. When I was syncing in FC3, everything worked fine. Now that I am in MDK 10.1, the syncing is messed up. Somehow I was able to get my addresses and calendar to sync but there are three notifications that pop-uo and say "unknown conduit" without telling me what the unknown is. I am assuming that a few setting left over from FC3 are interferring in the syncing process and this is why I am getting those three annoying pop-ups. Is there a log somewhere or something I can delete to make it stop popping up and giving me errors?
 
Old 11-15-2004, 05:06 PM   #6
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
I'll watch this thread but afraid I have no more suggestions. Sorry.

Meanwhile, investigating this (or trying to), I found out my own installation is no longer sync'ing the time on the handheld! It did it under 9.2, but now it doesn't. The plugin for doing it is there. I copied over the plugin from my 9.2 installation (which I preserved) and it still doesn't sync the time.

Wonder if it's a kernel thing.
 
Old 11-15-2004, 06:38 PM   #7
mrsolo
Member
 
Registered: Jun 2002
Location: Where ever the Navy sends me
Distribution: Gentoo
Posts: 320

Original Poster
Rep: Reputation: 30
BINGO!!

OK, the problem was that I didn't have the evolution-pilot package installed. The default evolution package that came with MDK 10.1 is 2.0.0 and the only evolution-pilot package I could find was 2.0.1. So what I did was just forced the evolution-pilot installation and now everything works smoothly. Those pop-ups are gone now.
 
Old 11-15-2004, 07:11 PM   #8
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
Good! Now just fix my time-sync problem for me, and we'll have our Palm problems solved.
 
Old 11-15-2004, 07:16 PM   #9
mrsolo
Member
 
Registered: Jun 2002
Location: Where ever the Navy sends me
Distribution: Gentoo
Posts: 320

Original Poster
Rep: Reputation: 30
Which version of Palm OS are you using? I read some where that some previous versions (possibly 3 and below) can't be time synced.
 
Old 11-15-2004, 07:23 PM   #10
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
It's version 3.5-something, pretty new--I just bought the Tungsten E in July I think.

It was syncing time just fine under 9.2. I can still sync the time using "pilot-xfer -t" in a console, but it was nicer when I didn't have to do anything. Not that I'm lazy, understand...!
 
Old 11-15-2004, 07:30 PM   #11
mrsolo
Member
 
Registered: Jun 2002
Location: Where ever the Navy sends me
Distribution: Gentoo
Posts: 320

Original Poster
Rep: Reputation: 30
That's what I have and the time sync works well for me. Are you using evolution or gpilotd?
 
Old 11-15-2004, 07:32 PM   #12
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
Quote:
Originally posted by mrsolo
That's what I have and the time sync works well for me. Are you using evolution or gpilotd?
Neither, just Jpilot with the pilot-link package which it requires.

"Sync time" used to show up as a choice under the Jpilot preferences (conduits), too, but it doesn't now.

The plugin's where it's supposed to be. I figured it was something about 10.1 or the newer kernel that was causing the problem. I dunno...
 
Old 11-15-2004, 07:37 PM   #13
mrsolo
Member
 
Registered: Jun 2002
Location: Where ever the Navy sends me
Distribution: Gentoo
Posts: 320

Original Poster
Rep: Reputation: 30
I'm not using jpilot. Try the gnome-pilot packages and then put the applet on the panel and then you can sync anytime you want. That's what works for me.
 
Old 11-15-2004, 08:34 PM   #14
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
Quote:
Originally posted by mrsolo
I'm not using jpilot. Try the gnome-pilot packages and then put the applet on the panel and then you can sync anytime you want. That's what works for me.
Hmm. I installed them, but can't find what I need to do to get anything to run. If it requires using Gnome Desktop, forget it--I just don't care for desktop environments.

Jpilot is OK, just wish the one feature were not broken now.
 
Old 12-22-2004, 03:05 PM   #15
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
Quote:
Originally posted by jonr
I'll watch this thread but afraid I have no more suggestions. Sorry.

Meanwhile, investigating this (or trying to), I found out my own installation is no longer sync'ing the time on the handheld! It did it under 9.2, but now it doesn't. The plugin for doing it is there. I copied over the plugin from my 9.2 installation (which I preserved) and it still doesn't sync the time.

Wonder if it's a kernel thing.
UPDATE: I fixed this problem. Why the plugin was not working I don't know. But I decided to work on the problem again today and I found the directory ~/.pilot/plugins EMPTY. Hmm.

I then created a symbolic link like this in ~/.pilot/plugins ---

ln -s /usr/lib/jpilot/plugins/libsynctime.so.0 libsynctime.so

--and reopened JPilot and it synced the time just like it used to (and was supposed to).

Beats me. Anyway, it fixed it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing MDK 10.1 GUI DesyphER Linux - Software 4 02-20-2005 02:26 AM
Missing Conduits for Palm Sync Steve Auerbach SUSE / openSUSE 0 11-20-2004 03:29 PM
MDK 10 - KDE 3.2 missing menu entries HawkEye4077 Mandriva 2 06-04-2004 04:35 PM
Mdk 10.0: Konqueror's Settings missing after 9.1=>10.0 upgrade bri_holland Mandriva 3 05-24-2004 10:51 AM
Missing Interrupt --- MDK 10 1kyle Mandriva 0 03-16-2004 04:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration