LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-06-2010, 04:58 PM   #1
firewiz87
Member
 
Registered: Jan 2006
Distribution: OpenSUSE 11.2, OpenSUSE 11.3,Arch
Posts: 240

Rep: Reputation: 37
Miro fails to start


Upon running miro (openSUSE 11.3 and arch) I get the following error:
Code:
PyNotify support disabled on your platform.
2010-10-07 02:25:45,730 INFO     Starting up Miro
2010-10-07 02:25:45,731 INFO     Version:    3.0.3
2010-10-07 02:25:45,736 INFO     OS:         Linux 2.6.34.7-0.3-desktop i686
2010-10-07 02:25:45,737 INFO     Revision:   ssh://wguaraldi@git.participatoryculture.org:2191/var/git/miro - 51067950
2010-10-07 02:25:45,737 INFO     Builder:    abuild@gefjon
2010-10-07 02:25:45,738 INFO     Build Time: 1286224422.19
2010-10-07 02:25:45,738 INFO     Starting event loop thread
2010-10-07 02:25:45,739 INFO     Restoring database...
2010-10-07 02:25:45,739 INFO     Python version:    2.6.5 (r265:79063, Jul  5 2010, 11:47:21) 
[GCC 4.5.0 20100604 [gcc-4_5-branch revision 160292]]
2010-10-07 02:25:45,740 INFO     Sqlite3 version:   3.6.23
2010-10-07 02:25:45,740 INFO     Gtk+ version:      (2, 20, 1)
2010-10-07 02:25:45,740 INFO     Pysqlite version:  2.4.1
2010-10-07 02:25:45,741 INFO     PyGObject version: (2, 21, 1)
2010-10-07 02:25:45,741 INFO     opening database /home/nithin/.miro/sqlitedb
2010-10-07 02:25:45,741 INFO     PyGtk version:     (2, 17, 0)
2010-10-07 02:25:45,742 INFO     Language:          [('LANG', 'en_US.UTF-8')]
2010-10-07 02:25:45,744 INFO     set_renderer: trying to add gstreamerrenderer
/usr/bin/python: symbol lookup error: /usr/lib/python2.6/site-packages/gst-0.10/gst/_gst.so: undefined symbol: gst_pad_link_check_get_type
What could be the problem???

thanks in advance
 
Old 10-06-2010, 07:04 PM   #2
alan99
Member
 
Registered: Mar 2010
Distribution: Debian
Posts: 180

Rep: Reputation: 31
Do you have the python module for gstreamer (python-gst) installed? That sounds like it might be the problem.
 
Old 10-07-2010, 10:30 AM   #3
firewiz87
Member
 
Registered: Jan 2006
Distribution: OpenSUSE 11.2, OpenSUSE 11.3,Arch
Posts: 240

Original Poster
Rep: Reputation: 37
I cannot find a package called python-gst however python-gstreamer-0_10-devel and python-gstreamer-0_10 packages are already installed.
 
Old 10-08-2010, 12:15 AM   #4
alan99
Member
 
Registered: Mar 2010
Distribution: Debian
Posts: 180

Rep: Reputation: 31
Quote:
I cannot find a package called python-gst however python-gstreamer-0_10-devel and python-gstreamer-0_10 packages are already installed.
In my distribution (debian) the package is named python-gst0.10
Perhaps the name difference is causing some sort of incompatibility?
 
Old 10-15-2010, 12:09 PM   #5
firewiz87
Member
 
Registered: Jan 2006
Distribution: OpenSUSE 11.2, OpenSUSE 11.3,Arch
Posts: 240

Original Poster
Rep: Reputation: 37
Quote:
Originally Posted by alan99 View Post
In my distribution (debian) the package is named python-gst0.10
Perhaps the name difference is causing some sort of incompatibility?
So what should i do now?? Any ideas??
 
Old 10-17-2010, 02:15 AM   #6
alan99
Member
 
Registered: Mar 2010
Distribution: Debian
Posts: 180

Rep: Reputation: 31
What version of gstreamer do you have?
Check this out.

http://gstreamer.freedesktop.org/rel...r/0.10.30.html

Quote:
API additions

* gst_caps_steal_structure()
* gst_clock_id_wait_async_full()
* gst_element_link_pads_full()
* GstPadLinkCheck
* gst_pad_link_check_get_type()
* gst_pad_link_full()
* gst_structure_fixate_field_string()
* GST_TAG_D
Notice it says gst_pad_link_check_get_type() is added.
Since it seems to be 'choking' on this function, maybe gstreamer needs to be updated?
 
Old 11-11-2010, 05:03 AM   #7
firewiz87
Member
 
Registered: Jan 2006
Distribution: OpenSUSE 11.2, OpenSUSE 11.3,Arch
Posts: 240

Original Poster
Rep: Reputation: 37
Sorry for the late reply... I am using Arch which is frequently updated..
I should be having the latest version.... I ll check anyway...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
x fails to start deemacsee Linux - Hardware 1 03-20-2009 09:59 AM
X Server fails to Start arindom SUSE / openSUSE 5 10-25-2007 04:17 AM
X fails to start 3zzz Ubuntu 2 08-31-2007 04:29 AM
X window fails to start satimis Ubuntu 2 08-07-2006 07:53 PM
Session fails to start borrrden Fedora 2 06-03-2004 07:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration