-   Linux - Software (
-   -   Mint 7 Instal from Labs CD re-boots to GRUB error 18 (

widda 07-19-2009 03:08 AM

Mint 7 Instal from Labs CD re-boots to GRUB error 18
Newbie talking here
Had Mandriva, wanted to add Mint7,tried directdownloadfile, which each time installed 2.3 of 2.5Gb. then bought CD.
Installed that side-by-side in a partitioning mess with the 3 unsuccesful 2.3s (which it called ubuntu), 'cos didnt want to lose Mandriva.
Grub error 18 on restart.
Then tried clean instal.
error 18
Re-installed mandriva side-by-side
clean installed mandriva
working, back to where I started!
The Mint CD works fine as diskdriveOS, but not as onboard OS.
The partitioning shown now is normal looking just Mandriva and Swap and 140G free etc.
I see some ref.s here to Grub errors, but nothing I can understand.
When bootloading stops at error 18, there's a cursor there which looks as tho there's something useful I could type in?

ANO1453 07-19-2009 06:46 AM


18 : Selected cylinder exceeds maximum supported by BIOS
This error is returned when a read is attempted at a linear block address beyond the end of the BIOS translated area. This generally happens if your disk is larger than the BIOS can handle (512MB for (E)IDE disks on older machines or larger than 8GB in general).
Make sure your GRUB is the beginning of the disk. Write it to the first partition.

widda 07-19-2009 09:35 AM

Thanks ANO,
I will now start finding out where to find out how to write something to a partition! I'll start in control centre.
Or maybe from the Mint disk I can control something.

ronlau9 07-19-2009 02:35 PM

Mint is a fork of Ubuntu .
So if you have not change anything during install it writes GRUB in MBR of sda
Unless you give told her to do different
How many drives do you have ?

ANO1453 07-19-2009 06:26 PM

Check this thread.

widda 07-24-2009 02:45 AM

only one drive. Anyway I now have mint installed ok EXCEPT for accessing net, and I couls get net on mandriva, but it won't instal because of grub18.
BUT I'm happy to stay with Mint on my lowpowered laptop. Only problem: although it says connection established (three bars) all websites return message in firefox: "please check connection, spelling, DNS servers etc.
I don't know about DNS servers.
I used to get this response in firefox with Windows and could often fix with "Tools - Delete Private Data". But that doesn't work.
So I think there is a setting wrong somewhere.
So I am at library every few days now to see if anyone can help with Optus3g function in firefox.

Should I take this question to another thread?
Also I have lost my list of applications in menu.
Thanks, I'll be back here in 3 days.

All times are GMT -5. The time now is 08:49 AM.