LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   mimms problems on QNAP with 2.6.33.2 (armv5tel) (https://www.linuxquestions.org/questions/linux-software-2/mimms-problems-on-qnap-with-2-6-33-2-armv5tel-4175418590/)

jdebs 07-25-2012 08:38 AM

mimms problems on QNAP with 2.6.33.2 (armv5tel)
 
Hello,
I have QNAP NAS server TS-219P II with following Linux version on it:
Code:

# uname -a
Linux NAS 2.6.33.2 #1 Sat Nov 26 04:24:41 CST 2011 armv5tel unknown

Lately I tried to dump such wma stream to the file:
Code:

<asx version = "3.0">
  <entry>
    <ref href = "mms://stream.polskieradio.pl/program3">
    <ref href = "rtsp://stream.polskieradio.pl/program3">
    <ref href = "http://stream.polskieradio.pl/program3">
  <Title>Trˇjka</Title>
  <Author>Polskie Radio SA</Author>
  <Copyright>Polskie Radio SA</Copyright>
  <Banner></Banner>
  </entry>
  <Title>Trˇjka</Title>
  <Author>Polskie Radio SA</Author>
  <Copyright>Polskie Radio SA</Copyright>
  <Banner></Banner>
  <LogURL href = ""/>
</asx>

and receive such problem:

Code:

[/] # mimms -o /share/MD0_DATA/Public/mms.wav mms://stream.polskieradio.pl/program3
host : >stream.polskieradio.pl<
port : >1755<
path : >program3<
file : >/share/MD0_DATA/Public/mms.wav<
time : >-1<
creating output file '/share/MD0_DATA/Public/mms.wav'
port: 0000db06
request: Connection refused

With other mms streams (BBC example: mms://wmlive.bbc.net.uk/wms/bbc_ami/radio1/radio1_bb_live_int_eq1_sl0) works mimms without problem and captures my favorite radio station. Does someone know where the probliem could be?

I tried several linux programs to capture this string. I was success with mplayer, but IMHO just for dumping stream I do not need such big environemnt. Thus looking solution with mimms. Streamripper does not support wma streams :(

I would appriciate any feedback or alternative solution for dumping this stream to the file.

Regards,
Jacek


All times are GMT -5. The time now is 05:00 PM.