-   Linux - Software (
-   -   Midnight Commander F-keys problem. (

c4c711 01-04-2010 05:18 AM

Midnight Commander F-keys problem.

I have annoying problem with Midnight Commander 4.7 on Gentoo Linux, namely F1 - F10 keys don't work at all. I've tried to delete ~/.mc directory, reemerge mc and ncurses, no results. If i run "learn keys" option (options->learn keys), and press F1-F10, everything looks good (OK appears near key description). Keys are running properly in mcedit and other applications that runs in Konsole. Problem occurs also in TTY and via SSH. I've checked, there is no duplicated shortcuts in Konsole or in KDE. The only way to use mc functions like copy is to click on menu and choose copy action by mouse. It's so annoying... Any ideas?

poorman_installer 01-05-2010 05:32 AM


Originally Posted by c4c711 (Post 3813387)
It's so annoying... Any ideas?

That sounds weird. I have no clue of what's going on, but you could try to tamper with fallback configuration files in /etc/mc and /usr/share/mc, besides deleting ~/.mc . Maybe backup those directories to avoid subsequent mess,
Sorry, no other ideas (sounds like a inherent problem of mc from your description).

c4c711 01-05-2010 07:22 AM


Yes, i've solved it! Yesterday after reemerge mc one more time, i've noticed that in install file list is /etc/mc/ directory, so i checked directory content and.. tada! mc.keymap file has been missing definitions only for f1-f10 panel keys. It's very strange because i couldn't edit this file - i even haven't been avare of existing such file (i'm the only one user of pc). Anyway, it works! ;) Thanks for reply

suozbek 05-21-2012 12:56 PM

I have a similar problem but not exactly the same. some of my f buttons are working and the others are not. to edit i can use f4 or to remove f8, but the others are not working. at first i suspect it is about the blue fn button as i'm using a laptop and some f buttons have other funtions but obviously that is not the case as f8 button also have a fn funtion to mute (and is working fine in mc) but f10 for example has no function and not working.

i'm using slackware 13.37 on a aspire 5742G with dwm as windows manager and it is frustrating to be forced to use mouse even in terminal. i would really appreciate any help.

All times are GMT -5. The time now is 02:35 PM.