LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-01-2013, 07:05 PM   #16
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Western Australia
Distribution: debian IceWM
Posts: 5,573

Rep: Reputation: Disabled

Hi

I don't use sudo so forgive me for assuming it.
I suggest you install bum or sysv-rc-conf then you can disable sudo from starting

now for a debian sid secret way YMMV

Code:
su
Password: 
root@box:/home/gordon/Desktop# alsa --help
Usage: /usr/sbin/alsa {unload|reload|force-unload|force-reload|suspend|resume}
root@box:/home/gordon/Desktop# /usr/sbin/alsa force-unload
Unloading ALSA sound driver modules: snd-hda-codec-idt snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-page-alloc snd-seq snd-seq-device snd-timer (failed: modules still loaded: snd-hda-codec-idt snd-hda-codec snd-hwdep snd-pcm snd-page-alloc snd-timer).
alsamixer
cannot open mixer: No such file or directory


(now the change to your file and now the reload command)

(change not shown of course thats your bit)

root@box:/home/gordon/Desktop# /usr/sbin/alsa force-reload
Unloading ALSA sound driver modules: snd-hda-codec-idt snd-hda-codec snd-hwdep snd-pcm snd-page-alloc snd-timer.
Loading ALSA sound driver modules: snd-hda-codec-idt snd-hda-codec snd-hwdep snd-pcm snd-page-alloc snd-timer.
root@box:/home/gordon/Desktop# modprobe snd_hda_intel
and alsamixer now works as should sound plus note the extra command to after reload to get alsa back
 
Old 12-03-2013, 12:46 PM   #17
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 373

Original Poster
Rep: Reputation: 21
I tried the:
Code:
# alsa force-unload
The result, unfortunately, is:
Code:
edbarx# alsa force-unload
Unloading ALSA sound driver modules: snd-hda-codec-realtek snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-page-alloc 
snd-seq snd-seq-device snd-timer (failed: modules still loaded: snd-hda-codec-realtek snd-hda-intel snd-hda-codec snd-hwdep 
snd-pcm snd-page-alloc snd-timer).
The culprit seems to be snd-hda-codec-realtek, as:
Code:
edbarx# modprobe -r snd-hda-codec-realtek
FATAL: Module snd_hda_codec_realtek is in use.
Thanks for all your patience in trying to help me.

I am suspecting the problem may be caused by snd-hda-codec-realtek because it is failing to be unloaded.

Last edited by edbarx; 12-03-2013 at 12:48 PM.
 
Old 12-03-2013, 05:52 PM   #18
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Western Australia
Distribution: debian IceWM
Posts: 5,573

Rep: Reputation: Disabled
Code:
I am suspecting the problem may be caused by snd-hda-codec-realtek because it is failing to be unloaded.
pls read my code box, heaps of mine not unloading either

don't get depressed unless you run alsamixer after unload and you still see a mixer
I assure you the hardware modules are unloaded
---the codec modules can do sweet fanny adams

try it and report again pls
 
Old 12-04-2013, 02:43 AM   #19
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 373

Original Poster
Rep: Reputation: 21
I will restart from the beginning.

These are the permissions of the contents of /etc/modprobe.d
Code:
:/etc/modprobe.d$ ls -l
total 16
-rw-r--r-- 1 root root  229 May  8  2013 alsa-base-blacklist.conf
-rw-r--r-- 1 root root 1186 May  8  2013 alsa-base.conf
-rw-r--r-- 1 root root  456 Apr 28  2013 fbdev-blacklist.conf
-rw-r--r-- 1 root root   26 Jan  6  2013 radeon-kms.conf
In your posts you suggested me chmod 755 instead of 644. Why? With the shown permissions, are the files used or not? What about file ownership? Does it make any difference?
 
Old 12-04-2013, 03:25 AM   #20
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Western Australia
Distribution: debian IceWM
Posts: 5,573

Rep: Reputation: Disabled
sorry for misleading you

No I do not want you to change any exist file permission

I was suggesting for most distros, a liberal or more umm permissive setting of 755.

644 is fine

2) try it again was referring to trying the alsamixer command after the root powered unload command

sorry to have caused you any angst.
 
Old 12-07-2013, 01:45 AM   #21
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 373

Original Poster
Rep: Reputation: 21
To: aus9

During the last two days I was too busy to spend any time on my computer. While appreciating your effort to help me, I would like to inform you that I will try your suggestions as soon as I can. I think, this will be tomorrow.
 
Old 12-08-2013, 12:58 PM   #22
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 373

Original Poster
Rep: Reputation: 21
I tried all the strings you supplied but none worked.
 
Old 12-08-2013, 06:56 PM   #23
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Western Australia
Distribution: debian IceWM
Posts: 5,573

Rep: Reputation: Disabled
ok hmmmm

for the moment delete that modprobe file and full reboot to take us back to your original setup

go back to alsamixer and raise volumes to at least 80% for controls,labelled
mic, digital and the 3 Internals from the right


redo these commands-----one test without mic in hole to test for embedded mic and test 2 with external mic inserted

Code:
arecord -d 5 -f cd test.wav 
aplay test.wav

2) Can you provide a link to your acer so we can prove or disprove it comes with no internal mic pls?

3) can you confirm what options are in your bios for mic pls

good luck
 
Old 12-20-2013, 12:37 AM   #24
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 373

Original Poster
Rep: Reputation: 21
I adjusted the mentioned controls to 80% as instructed without success. However, I noticed that pulseaudio is installed on my Debian Wheezy. I am wondering whether it may be causing the problem as I have read several text claiming it has some problems.

The laptop I am using had its original motherboard replaced. The original model was Acer Aspire 7715z. The new motherboard physically fitted perfectly, but the specifications are slightly different than the original. This change should not have affected whether there is an inbuilt microphone or not. The replacement motherboard is e-machines. It was extremely difficult to find a replacement.

For the specifications see:
http://www.manualslib.com/manual/443...ire-7715z.html

Last edited by edbarx; 12-20-2013 at 02:00 AM.
 
Old 12-20-2013, 01:54 AM   #25
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Western Australia
Distribution: debian IceWM
Posts: 5,573

Rep: Reputation: Disabled
huh?

if pulseaudio is installed it did not appear to be running
otherwise if you run alsamixer....with pulseaudio running
---you must see only one slider and its says pulseaudio

on debian you have the option to uninstall it
but for the moment lets go the full pulseaudio way and see if we can get a change

Code:
su
apt-get update
apt-get install pulseaudio paman pavucontrol pavumeter paprefs
now run pavucontrol as a normal user

click on each tab and setup how your want them, especially the pulldowns

report if any change

2) I use sysv-rc-conf to monitor and change my start up daemons
you can use a gui called bum.....boot up manager

ensure PA is showing for runlevel 5 same as alsa-utils

full reboot

run alsamixer and confirm you have only run slider

now retest and report when you can

I am going away shortly so hope others can reply if I don't
 
Old 12-20-2013, 03:24 AM   #26
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 373

Original Poster
Rep: Reputation: 21
Pulseaudio produced one single control but nothing more than that. So, I removed it. Using the xfce4 sound mixer I am capable of producing a strong feedback between the external microphone and internal speakers although arecord is still failing to record any sound.

Added Later:
At long last, I was able to record sound but with audacity and no pulseaudio. At first, audacity didn't work, but then I changed the Recording Device to: HDA Intel: Alc272X Analog (hw:0,0), and behold, sound could be recorded.

I think, somehow I must edit a linphone configuration file to include the setting mentioned above.

Last edited by edbarx; 12-20-2013 at 03:58 AM.
 
Old 12-20-2013, 05:43 AM   #27
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Western Australia
Distribution: debian IceWM
Posts: 5,573

Rep: Reputation: Disabled
HI

to truly remove try (for PA)

Code:
su
apt-get remove --purge pulseaudio paman pavucontrol pavumeter paprefs
2) the screenshot back at reply 12 shows you have mic boost on

reduce that to zero and retest

3) I don't use audacity but this link claims it knows how to configure your input device correctly
http://audacity.sourceforge.net/manu...s.html#audioio
 
Old 12-20-2013, 07:01 AM   #28
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 373

Original Poster
Rep: Reputation: 21
With Mic Boost set to zero I can still record my voice with audacity. I checked with alsamixer.
 
Old 01-05-2014, 03:15 AM   #29
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 373

Original Poster
Rep: Reputation: 21
I created a small (10 GB) partition in which I installed 32 bit Debian (Wheezy) in which I installed Skype. The latter works as the microphone is being used properly.

Thanks for taking the time and for having the patience to help me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
virtual microphone: FILE ---> MICROPHONE ---> APPLICATION jamal_mohammadi Linux - Hardware 1 02-13-2011 04:10 PM
linphone sancher Linux - Software 4 11-06-2009 12:40 AM
linphone fathgrufith Linux - Software 8 09-17-2009 09:40 PM
How can I be contacted on Linphone? Balarabay1 SUSE / openSUSE 4 06-27-2006 11:50 AM
Linphone on Fedora ? jonty_11 Programming 0 10-28-2004 01:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration