-   Linux - Software (
-   -   Mesalib 8.0.4 compile error due to file missing. (

Arcosanti 08-31-2012 02:23 AM

Mesalib 8.0.4 compile error due to file missing.
While attempting to compile the Mesalib 8.0.4 from source I came across an error where a file is being referenced but does not exist. Mesa-8.0.4/drivers/dri/noveau_driver.h references noveau_device.h but is nowhere to be found. Is there a patch for this somewhere?

Didier Spaier 08-31-2012 03:45 AM

I don't think that a patch be necessary as none is used to make the mesa-8.0.4 package available in Slackware-current.

I suggest that instead of compiling it manually you just make a Slackware package for mesa-8.0.4, using the SlackBuild available in Slackware-current in /source/x/mesa.

PS I confirm that the mesa-8.0.4 package installs nouveau_device.h in /usr/include/nouveau/

Arcosanti 08-31-2012 06:46 PM

Thanks for pointing me to the slackbuild on the installation media. I didn't realize that was there. Unfortunately though the slackbuild script got as far as I did manually. I did find out that I can bypass the noveau problem by specifying --with_dri_driver= option during configure as I am not needing noveau. I edited the slackbuilds script to do the same thing and it gets around the problem with noveau. I did find the noveau header files in /usr/include/noveau so I must have a path issue to resolve so these files will be found during compile time. Their not in the mesa tarbell as I have looked inside with Midnight Commander. They must have been installed with a header file package that Slackware had installed at the time of installation. Unfortuantely even after getting past the noveau problem I came across an error that stop the compile process both mananually and with the slack build scripts. I'll post another thread on that later since it's a different issue altogether.

Didier Spaier 08-31-2012 07:02 PM

Just a blind idea: did you become root with "su" before executing the SlackBuild? Then try with "su -" instead as else you keep the $PATH of your regular user.

Arcosanti 08-31-2012 08:04 PM

I tried both su and su -l only to find out that SlackBuilds doesn't seem to like that. So I just ran it as a regular user and it worked. I can add in /usr/include as a path to my reguler user account.

All times are GMT -5. The time now is 04:36 AM.