-   Linux - Software (
-   -   Mesa with DRI custom build shows black 3D windows (glxgears...) (

arond 08-20-2010 02:38 PM

Mesa with DRI custom build shows black 3D windows (glxgears...)
Hi, I'm using Opensuse 11.3 with the xorg and other video related packages from the X11org repo.

I have a question concerning the Mesa 3d library. The version from the X11org repository works well. However, building and installing Mesa by myself causes that certain 3d applications (glxgears or xmoto) only show a black screen. On both cases I can run compiz, which works quite well.

I have configured the custom Mesa build as follows (also tried enabling gallium), and in practice I use the i915 dri driver.


prefix: /usr
exec_prefix: ${prefix}
libdir: ${exec_prefix}/lib
includedir: ${prefix}/include

Driver: dri
OSMesa: no
DRI drivers: i810 i915 i965 mach64 mga r128 r200 r300 r600 radeon savage sis tdfx unichrome swrast
DRI driver dir: ${libdir}/dri
Use XCB: no

Gallium: no

Shared libs: yes
Static libs: no
EGL: glx dri2
GLU: yes
GLw: yes (Motif: no)
glut: no
Demos: no

CFLAGS: -g -O2 -Wall -Wmissing-prototypes -std=c99 -ffast-math -fvisibility=hidden -fno-strict-aliasing -m32 -fPIC -m32
CXXFLAGS: -g -O2 -Wall -fno-strict-aliasing -m32 -fPIC -m32
My question is what makes the opensuse build of Mesa different than my custom build? I see no big differences in the build configuration here:

Also, I tried xlib instead of dri and that works, but really slow so not an option. (Im using the i586 version of the packages)


All times are GMT -5. The time now is 11:01 AM.