LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   mencoder jpeg stream encoding (https://www.linuxquestions.org/questions/linux-software-2/mencoder-jpeg-stream-encoding-32421/)

bakuretsu 10-10-2002 09:17 AM

mencoder jpeg stream encoding
 
I've been trying to figure this thing out for days, the documentation is sparse and the HOWTOs aren't very helpful.

I need to encode a bunch of jpegs into a video. Any kind of video. It could be uncompressed, I don't care, it would just be nice if it were portable to Windows. Here is what I'm getting:
Code:

root@hobbes:/usr/local/apache/htdocs# mencoder -ovc copy -o test.avi \*.jpg -mf on:w=320:h=240:fps=1:type=jpg
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/share/locale


MEncoder 0.90pre8-RPM-3.1 (C) 2000-2002 Arpad Gereoffy (see DOCS!)

CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville (Family: 6, Stepping: 3)
CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Reading /root/.mplayer/codecs.conf: can't open '/root/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: 38 audio & 106 video codecs
File not found: 'frameno.avi'
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/share/mplayer/font/font.desc
success: format: 0  data: 0x0 - 0x0
forced mf.
[demuxer] mf support.
[mf] search expr: *.jpg
[mf] number of files: 36 (144)
[V] filefmt:16  fourcc:0x47504A49  size:320x240  fps: 1.00  ftime:=1.0000
videocodec: framecopy (320x240 24bpp fourcc=47504a49)
Writing AVI header...
Pos:  36.0s    36f ( 0%)  0fps Trem:  0min  0mb  A-V:0.000 [196:0]
Writing AVI index...
Fixup AVI header...
test.avi: error writing file.
Exiting...

No matter what codec specifications I use (I've tried -ova copy -ovc copy, even), I always get "error writing file." The kicker is that it writes a file, but it isn't viewable in Windows and that's my only testbed for video (I only run X through VNC).

I'm running mencoder as root, so it can't be a permissions problem, can it? I need insight! Has anyone done this before?

Thanks!


All times are GMT -5. The time now is 10:50 PM.