LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-14-2004, 06:24 PM   #1
rickenbacherus
Member
 
Registered: Mar 2003
Location: colorado springs. colorado
Distribution: Debian-Sid 2.6.24-rt1
Posts: 290

Rep: Reputation: 30
mc subshell.c: read (subshell_pty...):


Debian SID kernel 2.6.7

I can't figure this out. I can launch mc as root no problems but if I try as user the box gets loaded to 90% and I get this error:

$ mc

subshell.c: read (subshell_pty...): No child processes

Google has almost nothing on this error and certainly nothing in any language that I can read. I've tried dpkg -P mc then reinstaling but still the same. Thanks for any ideas.
 
Old 07-14-2004, 07:00 PM   #2
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 53
lets see, as normal user what do you get when you do
echo $SHELL

try as user at the virtual terminal to just type
$SHELL
this should put you in a subshell_pty
should take two exits to get out

are the permissions ok so that works ???
 
Old 07-14-2004, 07:14 PM   #3
rickenbacherus
Member
 
Registered: Mar 2003
Location: colorado springs. colorado
Distribution: Debian-Sid 2.6.24-rt1
Posts: 290

Original Poster
Rep: Reputation: 30
$ echo $SHELL
/bin/bash
Wed Jul 14 06:08 PM glenn@atilla $ $SHELL
Segmentation fault

Interestingly I cannot launch xterm as user either! It opens but no prompt appears then it closes. Eterm works fine.
Thanks for your help.

Last edited by rickenbacherus; 07-14-2004 at 07:22 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounted read-write Fat32 partition suddenly becomes read-only?? hohead Linux - General 8 04-05-2007 12:17 PM
mozzla problems-can not read files online, can not read attachments sarajevo Linux - Software 1 09-20-2005 06:58 PM
Example share in smb.conf doesn't work - read/write vs read only kleptophobiac Linux - Networking 0 09-01-2004 07:14 PM
Continuing a script on a new subshell dpillay Programming 2 05-29-2004 07:26 PM
kernel panic unable to mount root (yes ive read/read other posts) dmx9595 Linux - General 4 01-17-2004 05:07 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration