LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-12-2017, 08:47 AM   #1
Shm00nix
LQ Newbie
 
Registered: Jul 2009
Location: Lower S10b0v1a
Distribution: Debian
Posts: 18
Blog Entries: 1

Rep: Reputation: 1
Angry mc and gpm: still not working (together, after all these years)


A lot of people know that mc (Midnight Commander) goes haywire while accessing gpm in (I believe, so far) screen and tmux -- if you are not superuser. Just look at the out-of-control log growth -- and constant 100% CPU usage. This has been an ongoing issue for MANY years (Google it). The ONLY (AFAIK) known 'solution' to this vexing quirk is to set the TERM environment variable in the non-superuser screen/tmux window to 'TERM=xterm' (if there is more that can be done, I'm all eyes).

So: I'd like to know if anyone here has any clue as to progress on this thing. I can't believe it couldn't be easily fixed (I wish I'd had the time and the knowledge).
 
Old 01-12-2017, 01:55 PM   #2
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 17,401
Blog Entries: 10

Rep: Reputation: 5213Reputation: 5213Reputation: 5213Reputation: 5213Reputation: 5213Reputation: 5213Reputation: 5213Reputation: 5213Reputation: 5213Reputation: 5213Reputation: 5213
Code:
alias mc='TERM=xterm mc'
that help?
 
Old 01-12-2017, 09:55 PM   #3
Shm00nix
LQ Newbie
 
Registered: Jul 2009
Location: Lower S10b0v1a
Distribution: Debian
Posts: 18

Original Poster
Blog Entries: 1

Rep: Reputation: 1
Meh

Not a real solution, eh? The mc code base has to be debugged somehow.
 
  


Reply

Tags
gpm, mc, screen, tmux


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GPM not working with emacs skush Slackware 9 08-20-2014 03:42 AM
[SOLVED] gpm working erratically since upgrade to gpm-1.20.7-i486-3 RandomTroll Linux - Software 2 08-15-2014 11:53 PM
Gpm not working cant copy/paste spiky0011 Linux From Scratch 2 11-20-2011 01:48 PM
GPM not working on 10.2 distantlyyours Slackware - Installation 1 09-25-2005 04:15 PM
Why does gpm not working? gxie Linux - General 4 11-21-2003 10:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration