-   Linux - Software (
-   -   Matlab loading failure - Java - NoClassDefFoundError (

bharat_iyengar 04-05-2013 02:32 AM

Matlab loading failure - Java - NoClassDefFoundError
I wanted to install Matlab2012a in FC17 based system. Initially the installation process failed with an "unexpected error" prompt when Aerospace toolbox was being installed. The log reported this error:


java.util.concurrent.ExecutionException: java.lang.RuntimeException: data starting at 0 is in unknown format
When I deselected Aerospace toolbox Matlab installed successfully but failed to start and gave this error:


Exception in thread "main" java.lang.NoClassDefFoundError: com/mathworks/instwiz/arch/ArchGuiFactory
Caused by: java.lang.ClassNotFoundException: com.mathworks.instwiz.arch.ArchGuiFactory
        at$ Source)
        at Method)
        at Source)
        at sun.misc.Launcher$ExtClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClassInternal(Unknown Source)
Could not find the main class: com.mathworks.activationclient.ActivationApplication.  Program will exit.

i have openJDK7 ( and libXp installed. I tried the following withoout any success:

- reinstalling JDK
- reinstalling MATLAB
- specifying -javadir /usr/lib/jvm/java-1.7.0-openjdk- during install
- export MATLAB_JAVA=/usr/lib/jvm/java-1.7.0-openjdk-

the scripts- and also wont work and give the same error. Selecting Aerospace toolbox again causes installer to quit prematurely.

Is it true that MATLAB is not compliant with openJDK7. If so, then is it advisable to install openJDK6 along with openJDK7 ?

All times are GMT -5. The time now is 09:35 AM.