LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-10-2008, 02:03 PM   #1
Ifurita1981
LQ Newbie
 
Registered: Mar 2007
Location: Sweden
Distribution: SuSE10.2 & Gentoo
Posts: 7

Rep: Reputation: 0
Masked packages when emerging KDE


Hi.

When im trying to emerge KDE to my Gentoo it complains about masked packages. From what i read about masked packages it means what i am about to emerge isn't compatible with my "base" system and that it is not recommended to go passed this.

My question is as follows. What have i ,missed/done wrong ,in my installation to not be able to emerge a simple basic package like KDE?

The masked packages are as follows:
- kde-base/kde-meta-3.5.9 (masked by : required EAPI 1, supported EAPI 0)

- kde-base/kde-meta-4.0.5 (masked by : required EAPI 1, supported EAPI 0)

The command i used was:
# emerge -pv kdebase-meta

.. also tried ..
# emerge -pv kde-meta

.. and ..
# emerge kdebase-startkde

With the same results.
 
Old 07-11-2008, 08:05 AM   #2
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 55
Perhaps you should - from time to time - also run:
emerge -avuND world

This would update important packages to their newest version.
The culprit seems to be an too old (or not up to date) "portage" - which is the first thing to update or check for when problems occur.

as can be seen here:
http://forums.gentoo.org/viewtopic-t...59643b63281984
and here:
http://www.sabayonlinux.org/forum/vi...st=0&sk=t&sd=a

BTW: I just put this
Quote:
required EAPI 1, supported EAPI 0
into Google

Last edited by jomen; 07-11-2008 at 08:08 AM.
 
Old 07-11-2008, 06:00 PM   #3
Ifurita1981
LQ Newbie
 
Registered: Mar 2007
Location: Sweden
Distribution: SuSE10.2 & Gentoo
Posts: 7

Original Poster
Rep: Reputation: 0
Thanx for the answer. Still i have recently (like 5 days ago) installed gentoo online using the latest available portage and kernel (stable) to my knowledge. (portage-2.1.5.tar.bz2 and stage3-x86-2007.0.tar.bz2).

So without saying i am right i shouldn't need a world-update i don't think thats the problem here. If someone wise to gentoo claims a world-update still is a good idea please don't hesitate to say so.

Is there a possibility i have chosen a "to new" version of portage? Or is it possibly i have to wrong stage3 package?
 
Old 07-11-2008, 06:14 PM   #4
Acron_0248
Member
 
Registered: Feb 2006
Location: Venezuela
Distribution: Gentoo
Posts: 453

Rep: Reputation: 33
The problem as it shows (I mean, supported EAPI 0) is indeed related to portage, although in your case shouldn't be a problem since you're saying that you have the 2.1.5 version and EAPI 1 is supported since 2.1.3 version of portage or something like that.

However, AFAIK, only portage < 2.1.3 should give you that message so, just to be sure, do an emerge --sync and then emerge portage

If the problem continues then maybe we can check other options although to my knowledge there's not such options :P

Edit: I just checked gentoo-portage.com, since you have portage 2.1.5 which seems to be masked for all archs, then you should be able to update to 2.2

Last edited by Acron_0248; 07-11-2008 at 06:17 PM.
 
Old 07-12-2008, 03:02 AM   #5
Ifurita1981
LQ Newbie
 
Registered: Mar 2007
Location: Sweden
Distribution: SuSE10.2 & Gentoo
Posts: 7

Original Poster
Rep: Reputation: 0
Thanx for taking time to answer Acron. As i wrote earlier i just recently the last week installed my system in which i did a emerge --sync and according to the documentation which Jomen presented (and you confirmed) there shouldn't be a problem as my portage should support EAPI. However i'm gonna take your advice and do that emerge --sync anyways and see what happens. I have still a few questions before doing that.

A: Even if the newest version of portage in the mirrors at gentoo.org is my current (2.1.5) does that mean there still can be a version 2.2 available through emerge --sync?

B: In the installation handbook you are told to do a emerge --sync to update the portage-tree however there is no talk about emerge portage to make this happen.

C: Before i make my emerge --sync is there a command so i can see what version i am currently having (of portage). Since i did a emerge --sync at installation i guess i cant be sure i am still at (2.1.5).

EDIT

By the way i tried doing a emerge -avuND world but got like 2 screens of errors saying i didn't have this and that installed.

D: Real noob question but to make my print stop at every page so i can read the errors. Thought it would work with:

#emerge -avuND world -less

but i was wrong. :/

Last edited by Ifurita1981; 07-12-2008 at 03:06 AM.
 
Old 07-12-2008, 03:52 AM   #6
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 55
A) the newest is not always the right one
I run my system with ~x86 (unstable) and there the version of portage is 2.2_rc1
On a stable system like yours the highest stable version is 2.1.4.4

B) emerge --sync updates the database packages (of what portage knows to be available) - it does nothing else - not a single package is built and installed
You usually do a --sync because you want to update/change something afterwards - and you do the --sync to do the update/change with the newest versions.
emerge --sync does not install anything
emerge -avuND world upgrades the whole system to the newest versions by checking for USE-Flags you might have changed, checking deep dependencies, only upgrade and leave already installed packages alone, be verbose and ask you before doing so.

What you should do is (I would do that, that is...):
emerge --sync
emerge -av portage
emerge -avuND world

or even:
emerge -av world

C) emerge -av portage will tell you what version you have and what it is about to be up/downgraded to if you say "y".

D) ...don't know - if there is something wrong I always start at the bottom of the list - and scroll back in my terminal. That has always done the trick so far.
emerge -avuND world | less
will work - but (for me) without colors
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
strange problem with Emerging gentoo packages Net_Spy Linux - Newbie 1 11-03-2006 07:39 AM
SIGPROF is masked by select() .(in c) xiangbing Programming 2 01-08-2006 07:41 PM
Problem emerging KDE in Gentoo cdavidson Linux - Distributions 5 05-27-2005 07:59 PM
Upgrading Opera in Gentoo-masked packages bigjohn Linux - Distributions 2 03-11-2005 02:05 PM
gentoo: conflict when emerging kde Moebius Linux - Software 1 06-04-2004 01:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration