-   Linux - Software (
-   -   Mandrake 10.1 Apache2 with PHp and pear problem (

Jediman 04-18-2005 10:00 PM

Mandrake 10.1 Apache2 with PHp and pear problem
Hi all! My server has Apache 2 installed on it, along with php for it, and its running on a Mandrake 10.1 distro....I have tried and tried to get everything working with php BUT for some stupid reason its not working...

The error is as follows:
Warning: Unknown(/var/www/html/info.php): failed to open stream: Permission denied in Unknown on line 0

Warning: (null)(): Failed opening '/var/www/html/info.php' for inclusion (include_path='.:/usr/lib/php/:/usr/share/pear/') in Unknown on line 0

I tried everything including not having the include path terminate with slashes..out of ideas...someone please help! I even rebuilt with wget for pear...HELP!

sgrayban 04-19-2005 01:33 AM

apache2 and php5 suck -- use apache1.3.27/33 and mod_php

Jediman 04-19-2005 09:10 AM

That wasnt an option for me with Apache 1. The Mod_php in Mandrake 10.1 is for Apache 2 for one thing, and that response didnt exactly help :(

Jediman 04-19-2005 10:00 AM

Does anyone ELSE have any suggestions on getting this going?

sgrayban 04-19-2005 10:42 AM

mod_php in Mandrake 10.1 is for apache 1.3.x
apache2-mod_php is for apache.

# sudo urpmq -i apache2-mod_php
Name : apache2-mod_php
Version : 2.0.50_4.3.8
Release : 2mdk
Group : System/Servers
Size : 92023 Architecture: i586
Source RPM : apache2-mod_php-2.0.50_4.3.8-2mdk.src.rpm Build Host:
Packager : Oden Eriksson <>
Summary : The PHP4 HTML-embedded scripting language for use with apache2.

# sudo urpmq -i mod_php
Name : mod_php
Version : 4.3.10
Release : 4bgn
Group : System/Servers
Size : 90229 Architecture: i586
Source RPM : mod_php-4.3.10-4bgn.src.rpm Build Host:
Packager : Scott Grayban <>
Summary : The PHP4 HTML-embedded scripting language for use with Apache

Before you start talking like you know make sure before you look very newbie.

Jediman 04-19-2005 10:58 AM

I do know what the hell i'm talking about...whats listed on my 3 cd's does not include php for apache 1x else it would have been installed, and i havent had a lot of time to really delve into settting up mirrors and such for installs......regardless of this, I want to use Apache 2, and was looking for a solution to the current problem rather than ripping the server apart looking for other crap. So if someone can shed some light on this great.

sgrayban 04-19-2005 11:09 AM

Okie dokie --- keep looking like a fool then.

And your php issue is the fact that your using php4 code on a php5 mod and they arent compatible.

And if you keep wanting to be hard headed on this then dont bother asking for help.

I helped. I gave you the information you needed.

And if you that lazy to add a few lines into urpmi you have some real spoon feeding issues.

Jediman 04-19-2005 11:53 AM

First off...when I have time this week to configure my mirrors manually I will..secondly, I am not using php 5 i AM using php 4. I ended removing the rpm, and installing php manually. It still has no effect, in fact I found a few problems with apache 1x when using it before from Mandrake. Surely there is a workaround anyhow...the problem is essentially a linking issue with php->pear...and quite frankly I'd like to resolve it. Not bicker around about one thing or another. IF you are too much of a Better than Thou type of person then please DONT respond again. I appreciate the suggestion of going back to Apache 1x, however I really do not wish to.

sgrayban 04-19-2005 11:56 AM

pfft stop wasting our time then.

Jediman 04-19-2005 11:59 AM

Ok mods, lock this or delete it will you? I was trying to get an actual answer not a apache 2 sucks use this instead response. Quite frankly if you dont have anything to really add to the situation then stfu. I am new to linux and quite frankly you arent very inviting to talk to let alone seek infformation from. Remember, you were a newbie once too...

So without further ado, forget I asked, never mind, crawl back under your rock! Ta!

Jediman 04-19-2005 04:35 PM

The correct answr is this:

chmod a+r to the file itself..its a security issue.

All times are GMT -5. The time now is 10:10 AM.