Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 08-27-2003, 01:23 PM   #1
LQ Newbie
Registered: Aug 2003
Posts: 3

Rep: Reputation: 0
man pages and 'high bit' foreign chars

We've just installed RH 8.0 on a box that will be a mail and DNS server. We're getting strange results from 'man', where the hyphens seem to be replaced by a-caret (french character: a, with accent over it), following by two spaces.

This is in terminal mode using CRT, basic vt100 emulation, and I've not seen this on other boxes we've set up. Thought it could be an stty issue, so here are those if they will be of help:

speed 9600 baud; rows 29; columns 95; line = 0;
intr = ^C; quit = ^\; erase = ^H; kill = ^U; eof = ^D; eol = <undef>; eol2 = <undef>;
start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W; lnext = ^V; flush = ^O;
min = 1; time = 0;
-parenb -parodd cs8 -hupcl -cstopb cread -clocal -crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff -iuclc -ixany
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt echoctl echoke

Anyone got any clues on this? Anything else that could help? Thanks!

Old 08-27-2003, 02:02 PM   #2
LQ Newbie
Registered: Aug 2003
Posts: 3

Original Poster
Rep: Reputation: 0
Update.... looks like a straightforward terminal emulation issue, since X works fine. But what in a telnet/vt100 emulator would convert the '-' in man pages to this sort of stuff?
Old 09-29-2003, 08:00 AM   #3
Registered: May 2003
Location: philadelhpia pa
Posts: 92

Rep: Reputation: 15
yeh... looks like:

−a, −−

i was thinking COLOR,
but i cant figure out, how to turn it OFF either...
OH, how i yern for the old tty days sometimes
Old 09-29-2003, 08:13 AM   #4
Registered: May 2003
Location: philadelhpia pa
Posts: 92

Rep: Reputation: 15
HERE THE Answer:

normaly LANG="LANG=en_US.UTF-8"

(you can put this in .bashrc
Old 09-29-2003, 11:21 PM   #5
LQ Addict
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
or just make an alias:
alias man='env LC_ALL=en_US man'
in case you don't want to mess with the locale settings globally.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
C++ man pages Guest1234 Linux - Newbie 2 06-29-2008 09:12 AM
man pages? synaptical Debian 4 06-13-2005 08:16 PM
How to enter high-ascii chars in a Linux editor? Kropotkin Linux - Newbie 4 11-27-2004 10:28 AM
Strange fonts in mozilla for foreign pages tsitras Debian 1 04-15-2004 10:53 PM
man pages haobaba1 Linux - General 4 07-30-2003 02:09 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:05 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration