-   Linux - Software (
-   -   making ./configure find installed software (

poiuytrewq 11-11-2004 05:22 PM

making ./configure find installed software
when compiling programs, i quite often have the problem of configure not finding programs that i have installed

for example, while trying to configure gparted (a graphical partition editor)

configure: error: *** libparted >= 1.6.13 not installed - get it from ***

however, after i got that error the first time, i downloaded (>v1.6.13) it -> ./configure -> make -> make install

eveything seemed to work fine. but after runing the ./configure for gparted again, i still got the not installed error.

how can i make ./configure find that i have libparted

(i run Fedora core1 which is an rpm based distro, and usually get errors finding other programs that i installed through make install, and not ususally with rpm installed things. although that is not a strick rule)


btmiller 11-11-2004 06:05 PM

Try running ldconfig and see if that doesn't make the configure script pick it up. If not, there's usually an option --with-<package>-dir to tell configure exactly where certain things are. So if you configured libparted with a nonstandard prefix like /opt/parted or something,. you can user --with-libparted-dir=/opt/parted to tell configure where to find it.

poiuytrewq 11-12-2004 02:05 AM

where exactly are you suggesting i run ldconfig? in the libparted dir? in the gparted dir? before or after configuring?

windoze killa 05-11-2005 06:40 AM

Come on guys. It has been 6 months and no answer. Now I am having the same problem. I even looked for parted and found it in /sbin but this was obviously the wrong version. I also found the correct version in /usr/local/sbin but no matter what I tried I could not get the gparted configure to find it. Why is this always a problem? Why can't the direction to correct this be made so some of us non software gurus be able to understand it. I have been trying to give nano mush the boot for years but eveytime I find a program that allows me to move on I have trouble installing it. Sorry about the bitch session but it does drive me (and I know a lot of others) crazy.

Hope you can help.

__J 05-11-2005 06:50 AM


Originally posted by windoze killa
. Why is this always a problem? Why can't the direction to correct this be made so some of us non software gurus be able to understand it.
Hope you can help.

because you did it wrong? because the system works when the person using it knows what they are doing. first, ./configure, make, make install will only get you so far before you start having problems, some packages need to be built certain ways. it's hard to say what your problem is considering you didn't post the error message from configure, but (as a guess) libparted uses pkg-config to export the include and linking flags to gcc and ld and you have libparted in /usr/local, which pkg-config does not search ( unless you tell it to). also, your problem with rpm complaining about missing deps when you install something from source is because "make install" does not update the rpm database, rpm does. look into rpmbuild or checkinstall to learn how to make rpm's of your builds and install them instead of doing make install, it'll make life easier for you.

windoze killa 05-12-2005 06:49 AM

Thanks for your reply. But I didn't mention anything about RPM complaining about missing deps. I am trying to install from source. I also agree whole heartedly that pkg-config is looking in the wrong spot. Problem is, how do I tell it to look in the right spot? Once before I tried to install something and when it failed it told me what to do to fix it. What parameter to set when running ./configure. Also the error message is the same as in the first post.

configure: error: *** libparted >= 1.6.13 not installed - get it from ***

The following is the section out of the configure script. Obviously PARTED_PATH is the thing that has to be specified. How do you do it?

if test -n "$PARTED_PATH"; then
echo "$as_me:$LINENO: result: $PARTED_PATH" >&5
echo "${ECHO_T}$PARTED_PATH" >&6
echo "$as_me:$LINENO: result: no" >&5
echo "${ECHO_T}no" >&6

if ! (( ($( $PARTED_PATH --version | cut -d. -f3 | cut -d' ' -f1 )) > 12 )) 2>/dev/null
{ { echo "$as_me:$LINENO: error: *** libparted >= 1.6.13 not installed - get it from ***" >&5
echo "$as_me: error: *** libparted >= 1.6.13 not installed - get it from ***" >&2;}
{ (exit 1); exit 1; }; }

Maybe I am missing something very simple.

Also why can't there be a STANDARD spot for installing certain things. It seems that FC2 installed parted in the right spot but is too old. You would think that the writers of parted would make it so when you install a newer version it would go to the same spot. It would safe a lot of problems if it did. This also applies to most other apps I have tried to install.

I also like your suggestion of making my own RPMs but unfortunately I don't have the time to learn that right now.

Thanks again

camelrider 05-12-2005 01:48 PM

Try running locate libparted | less in order to find where the libs are installed.

Then make sure the directories that contain libparted and libparted-devel appear in the file /etc/

then, as root, run ldconfig

This should enable pkg-cfg to find the libraries.

Komakino 05-12-2005 02:12 PM

to /etc/
then run ldconfig.
Failing that, reinstall libparted, this time doing:
./configure --prefix=/usr
to put it in a more standard location.

windoze killa 05-13-2005 01:56 AM

I will try it. Shouldn't have to but will, just to prove a point.

PS. QTparted managed to find it ok, why not gparted????????

PPS. Love your sig. Just hope some people take note.

__J 05-13-2005 06:41 AM

the gparted configure script is searching your PATH for $PREFIX/sbin/parted, is /usr/local/sbin in your $PATH?

windoze killa 05-13-2005 06:06 PM

Not sure. How do I add it?

__J 05-13-2005 07:25 PM

export PATH=<new path>:$PATH

so if "new path" is /usr/local/sbin:

export PATH=/usr/local/sbin:$PATH

windoze killa 05-14-2005 07:43 AM

Thank you. Didn't solve my problem. Still comes up with the same error.

Will stick with qtparted I think.

__J 05-14-2005 07:48 AM

and you are sure parted is in your path?

I've never used gparted, so I figured I'd try it out, and configure picked up libparted without complaint.

it's allright, but it's no cfdisk :D

windoze killa 05-14-2005 05:56 PM

Where was your libparted? And what is cfdisk??

All times are GMT -5. The time now is 12:37 AM.