-   Linux - Software (
-   -   Making a Remote Desktop Connection over a VPN (

zak89 10-08-2009 07:13 PM

Making a Remote Desktop Connection over a VPN
Greetings all!

I am trying to set up a remote desktop connection to my work machine (running Windows XP). I have Remote Desktop access enabled on the remote machine, and I have a pptp connection to the remote VPN. I am trying to use tsclient (on Ubuntu Jaunty). However, that's where I am a bit stuck. I don't know exactly what the different options in the tsclient configuration actually are. Below are the ones I am particularly interest in:

"Computer:" - Hmm? Would this be the local ip address of the remote machine?

"Domain:" - Would this be my vpn gateway address? Like ""?

"Client Hostname:" - What's the difference between the "Client Host Name" and "Computer"?

"Protocol File:" - Don't have one; I'm assuming this is optional?

Just going by my intuition, I tried filling out the config options with the following:

The remote PCs IP address as "Computer" (note that this is the IP address listed under "My Computer" on the remote machine);

The vpn gateway address as "Domain";

The remote PC's hostname as "Client Hostname".

I left the protocol line blank; I assume this is for an optional config file?

Anyways, using the above settings, tsclient's dialog disappears for a few seconds, then a blank window appears for just a second, and the config dialog is back. No error messages; running tsclient from the commandline gives only the following message:

"(tsclient:11150): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.20.1/gobject/gsignal.c:2387: instance `0x92d2d40' has no handler with id `6658".

I doubt that is related. I don't know what log files to check, or what else to look at to seee what went wrong. Any ideas?

zak89 10-08-2009 10:22 PM

Hmm, it appears that others find this confusing as well. Well, I have some more confusion to add to the mix (to make sure nobody will ever reply). I tried setting up a remote desktop connection on a local Windows XP machine (which was already connected to the remote VPN), following the online directions from Microsoft's own website, and it still doesn't work. What's more interesting, is that it has the same result as the tsclient connection; the config dialog basically disappears and reappears, with no error message or anything else to give a hint as to what went wrong.

Anyone have an idea of what's going wrong?

All times are GMT -5. The time now is 09:28 PM.