LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-06-2005, 07:02 PM   #1
dlublink
Member
 
Registered: Oct 2004
Location: Canada
Distribution: Ubuntu
Posts: 330

Rep: Reputation: 30
make php does not create libphp4.so


Hi.

I downloaded the latest version of php 4 (4.3.10). I untar it (tar -zxvf php-4.3.10.tar.gz) to a folder(php-4.3.10). I tried to compile ( ./configure --with-mysql && make && make install). It seemed to do everything, but it does not create the file libphp4.so. The INSTALL file said that this file is the file that should be loaded with in httpd.conf (LoadModule php4_module libexex/libphp4.so). When I configured Apache, although this should make no different to the trouble I am having, I used the option --enable-module=so.

I searched the entier system and libphp4.so does not exist.

Where did I go wrong?


thanks,

David
 
Old 02-07-2005, 03:15 AM   #2
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
did it create libphp4.so.x.x.x? did you pass --enable-shared to configure?
 
Old 02-07-2005, 04:10 AM   #3
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,739

Rep: Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838
You should configure php --with-apxs(2)=/path/to/apache(2)/bin/apxs
N.B. (2) is for apache2
 
Old 02-07-2005, 10:28 PM   #4
dlublink
Member
 
Registered: Oct 2004
Location: Canada
Distribution: Ubuntu
Posts: 330

Original Poster
Rep: Reputation: 30
It would seem that I confused apxs with something else. I thought apxs was some add in that I did not need, I did not realize that it was a vital part of PHP/Apache installations.

It appears that this was the problem.

Mine was in /usr/local/apache/bin/apxs.

Thanks a bunch. If anyone else has this trouble, and like me, has forgotten where apache was installed.

Just do

find / | grep apxs

There is a better way to find it , but heck, it works for me

David
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
With RH 9, cannot create libphp4.so rtcary Linux - Software 7 07-08-2005 08:30 AM
RH 9: how to create libphp4.so rtcary Linux - Software 0 07-06-2005 08:59 AM
PHP - Apache - libphp4.so TBomb Linux - Software 10 12-24-2004 03:33 PM
php installed but no sign of libphp4.so (apache needs it) unholy Linux - General 6 01-18-2004 05:15 PM
Apache & PHP error - libphp4.so.... ReSync Linux - General 7 08-06-2002 01:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration