LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   "make" not working on Puppy 1.0.4 (https://www.linuxquestions.org/questions/linux-software-2/make-not-working-on-puppy-1-0-4-a-467417/)

rico.thorn 07-25-2006 07:32 AM

"make" not working on Puppy 1.0.4
 
Hi there,

I'm using puppy linux 1.0.4,
I've downloaded the extra file that adds developement tools to the system (usr_devx.sfs) and put it in /mnt/home/ and / (different sources gave different locations).

Now I want to install dhcp-3.0.4 (i have already uncompressed it and opened a terminal in that directory), so I type "./configure"
I get the following...

Code:

System Type: linux-2.2
make: No such file or directory

./configure is supposed to identify your system so it seems to be working atleast in part

If i try to type "make" after that i get the same error "make: No such file or directory"

Any suggestions?

jstephens84 07-25-2006 09:41 AM

That can be a confusing error sometime but all that means is that the make command is not found on you system. to install the make command you will need to add that from your install cd. Or you can use your package manager to install it. I am not sure what package manager puppy uses so I am unable to help you there. Hopefully this will give you a starting point.

rico.thorn 07-25-2006 10:40 AM

Thanks, that helps. I think i know what's wrong, cuz make comes in a separate file called usr_devx.sfs but that's made so the live cd can use it, i'm running it on my HDD so i need to get it uncompressed or something like that

rico.thorn 07-26-2006 09:14 AM

I realized that it's not mounting usr_devx.sfs so this is how i tried to fix it...

I mounted the file usr_devx.sfs to /mnt/dir and then copied everything from there to root. Then i rebooted and now it's broke...

As it starts X...

Code:

mice: PS/2 mouse device common for all mice.
It seems not, Removing USB Keyboard driver.
Note: /etc/modules.conf is more recent than /lib/modules/2.4.29/modules.dep
usbc: deregistering driver hid
usbc: deregistering driver hiddiv
usbc: deregistering driver usbmouse
Note: /etc/modules.conf is more recent than /lib/modules/2.4.29/modules.dep
usbc: deregistering driver usbkbd

Enter mouse type serial, ps/2, usb [ps/w]: ps/2
Note: /etc/modules.conf is more recent than /lib/modules/2.4.29/modules.dep
modprobe: Can't locate module psmouse
You have selected psaux as your mouse device.
This information is saved in file /etc/mousedevice.

Do you have a wheel/scroll type of mouse? y/n [n]: n
... you choose "no".
The file /etc/mousebuttons has been created, with content "3".
Starting X with video mode 0x0114 and mouse psaux...
Exited from X. Type "xwin [fvmw95|jwm]" to restart X ([] means optional).
(To change mouse and keyboard, type "rm /etc/mousedevice", then run xwin)

Any suggestions?

jstephens84 07-26-2006 10:10 AM

To be honest I am lost at this point. I have never used puppy linux before. You may want to ask a moderator if you can have this moved to the puppy forum to get more leads. Sorry I could not be of more assistance. Good luck and I hope you get this solved soon.

rico.thorn 07-27-2006 05:16 AM

ok thanks, didn't know there was a puppy section

jstephens84 07-27-2006 10:09 AM

Hey atleast I could point you into the right direction. Again not sure if you did but you can get a moderator to move this thread over to the puppy forum.

rico.thorn 07-28-2006 01:21 AM

i actually started a new thread in the puppy forum becuase the subject of this one is irrelevant now.

jstephens84 07-28-2006 12:35 PM

Ok, well I hope you get this issue solved soon. I know how frustrating it can be when something is holding you back from accomplishing another task.


All times are GMT -5. The time now is 02:06 PM.