LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-21-2005, 02:49 AM   #1
swatward
Member
 
Registered: Jan 2005
Distribution: slackware
Posts: 83

Rep: Reputation: 15
make install errors in vsftpd


in the terminal, if i type "make install" (w/o quotes) i get this error...
Quote:
root@rooks:~/vsftpd-2.0.3# make install
if [ -x /usr/local/sbin ]; then \
install -m 755 vsftpd /usr/local/sbin/vsftpd; \
else \
install -m 755 vsftpd /usr/sbin/vsftpd; fi
if [ -x /usr/local/man ]; then \
install -m 644 vsftpd.8 /usr/local/man/man8/vsftpd.8; \
install -m 644 vsftpd.conf.5 /usr/local/man/man5/vsftpd.conf.5; \
elif [ -x /usr/share/man ]; then \
install -m 644 vsftpd.8 /usr/share/man/man8/vsftpd.8; \
install -m 644 vsftpd.conf.5 /usr/share/man/man5/vsftpd.conf.5; \
else \
install -m 644 vsftpd.8 /usr/man/man8/vsftpd.8; \
install -m 644 vsftpd.conf.5 /usr/man/man5/vsftpd.conf.5; fi
if [ -x /etc/xinetd.d ]; then \
install -m 644 xinetd.d/vsftpd /etc/xinetd.d/vsftpd; fi
root@rooks:~/vsftpd-2.0.3#
and then if i try and run the vsftpd exectuable i get these errors..
Quote:
root@rooks:~/vsftpd-2.0.3# /usr/local/sbin/vsftpd: line 6: service: command not found
/usr/local/sbin/vsftpd: line 8: socket_type: command not found
/usr/local/sbin/vsftpd: line 9: wait: `=': not a pid or valid job spec
/usr/local/sbin/vsftpd: line 9: wait: `no': not a pid or valid job spec
/usr/local/sbin/vsftpd: line 10: user: command not found
/usr/local/sbin/vsftpd: line 11: server: command not found
nice: =: No such file or directory
/usr/local/sbin/vsftpd: line 16: disable: command not found

[1]+ Exit 127 /usr/local/sbin/vsftpd
Do those have anything to do with each other? what am i doing wrong?
Thanks for any help.
 
Old 08-22-2005, 01:48 AM   #2
swatward
Member
 
Registered: Jan 2005
Distribution: slackware
Posts: 83

Original Poster
Rep: Reputation: 15
ah... its because i didnt have a c compiler...
 
Old 09-02-2005, 03:33 PM   #3
longsiu
LQ Newbie
 
Registered: Sep 2005
Posts: 1

Rep: Reputation: 0
which package should be installed for the C compiler?

I'm using RH linux 9
 
Old 09-07-2005, 11:33 AM   #4
maidenseye
LQ Newbie
 
Registered: Aug 2005
Posts: 8

Rep: Reputation: 0
I'm having the same problem, what's the fix on this anyone know?
 
Old 09-20-2005, 09:47 PM   #5
swatward
Member
 
Registered: Jan 2005
Distribution: slackware
Posts: 83

Original Poster
Rep: Reputation: 15
i was using slackware 10, i think it was gcc
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Madwifi - modprobe errors during 'make install' kk_davey Linux - Software 1 07-03-2005 11:10 PM
'Make install' errors lazwaz Red Hat 2 05-21-2005 05:03 PM
Chap 5 Binutils make LDFLAGS & make install errors shotokan Linux From Scratch 5 04-10-2005 03:01 AM
make install errors on kernel harrycrumb11 Linux - General 5 10-06-2003 08:31 PM
Xine errors on Make install? rlculver Linux - Software 9 08-17-2002 03:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration