LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-06-2004, 01:40 PM   #1
irvken
Member
 
Registered: Dec 2003
Location: uk
Distribution: Ubuntu/Debian/Android
Posts: 218

Rep: Reputation: 30
make evolution launch mozilla


i want to launch Mozilla rather than Konqueror when clicking on links in my email in Evolution (under KDE)

I've somehow broken the Konqueror link anyway, so I can't autolaunch any browser.

Any ideas?
 
Old 03-06-2004, 02:58 PM   #2
jib2
Member
 
Registered: Sep 2003
Location: Paris, France
Distribution: Arch x86_64
Posts: 221

Rep: Reputation: 30
From a terminal, run gnome-default-applications-properties and set mozilla as your default browser. Evo uses this setting and doesn't care about KDE.
 
Old 03-06-2004, 06:17 PM   #3
Sebboh
Member
 
Registered: Nov 2003
Posts: 53

Rep: Reputation: 15
Thx Jib... good to know...
 
Old 03-06-2004, 06:51 PM   #4
irvken
Member
 
Registered: Dec 2003
Location: uk
Distribution: Ubuntu/Debian/Android
Posts: 218

Original Poster
Rep: Reputation: 30
superb, that worked instantly and I didn't even have to restart evolution.
 
Old 05-05-2004, 11:11 AM   #5
secho
Member
 
Registered: Mar 2004
Distribution: Gentoo
Posts: 34

Rep: Reputation: 15
So what should you do if you don't have gnome-default-applications-properties installed?
 
Old 05-05-2004, 11:38 AM   #6
jib2
Member
 
Registered: Sep 2003
Location: Paris, France
Distribution: Arch x86_64
Posts: 221

Rep: Reputation: 30
Look at this thread from evolution mailing list :
http://lists.ximian.com/archives/pub...st/032253.html
 
Old 05-05-2004, 02:31 PM   #7
secho
Member
 
Registered: Mar 2004
Distribution: Gentoo
Posts: 34

Rep: Reputation: 15
Rock thanks, I had to change the /http and /https values as well as the /unknown, but no biggie. works great now :P
 
Old 09-11-2005, 08:48 PM   #8
ejennings_98
Member
 
Registered: Sep 2003
Location: Canada, West Coast
Distribution: Mandriva 2012.1 i586 & x86_64
Posts: 69

Rep: Reputation: 15
I have been living with the "links not working" with Evolution under KDE for some time now. Somehow Evolution would not launch any browser when clicking a link. The problem started when I upgraded to the latest version of Mandriva; some of the gnome settings got screwed up. I finally decided to get to it and solve the problem.

Firstly, I know that evolution ignores KDE, so the "browser to launch" setting must be set with Gnome tools. I tried the "gnome-default-applications-properties" described above, but it did not work.
To solve the great mystery I installed the "gnome-control-center" and then launched it from the console. Make sure you are logged on as yourself and not su in the console or else the wrong config file will be modified; I speak from experience. Once the control center has been started I did the following:

Selected the "Advanced" tab with the left navigation icons, then selected the "Preferred Applications". With the Proffered Applications, I set the "Select a web browser" to my browser of choice.
And guess what, thats it; the great mystery was solved!! I cant believe it was that simple. I hope someone else is able to benefit from this.

Eric
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Evolution 2.2beta won't launch except via console dhave Linux - Software 0 12-08-2004 08:02 AM
Evolution Email Launch Problem seanmaggs Linux - Software 2 02-18-2004 07:58 PM
Launch JUST Mozilla Mail? GT_Onizuka Linux - Software 5 10-13-2003 10:09 PM
Can't launch Mozilla eg_wwkaa Programming 4 06-18-2003 09:34 PM
mozilla mailto: -> evolution, not mozilla mail mjgeiger Linux - Software 4 03-18-2003 08:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration