LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-09-2009, 06:13 PM   #1
hallve_revera
LQ Newbie
 
Registered: Dec 2008
Posts: 25

Rep: Reputation: 15
"Make" command


Hi,,,
i have installed kubuntu intrepid live usb persistence in usb hdd,

when i try to install program like madwifi and aircrack, i got and eror when typing "make"...
How do i fix it......
 
Old 01-09-2009, 08:22 PM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,716
Blog Entries: 3

Rep: Reputation: 483Reputation: 483Reputation: 483Reputation: 483Reputation: 483
Quote:
Originally Posted by hallve_revera View Post
Hi,,,
i have installed kubuntu intrepid live usb persistence in usb hdd,

when i try to install program like madwifi and aircrack, i got and eror when typing "make"...
How do i fix it......
https://help.ubuntu.com/community/CompilingSoftware read hear
 
Old 01-09-2009, 09:06 PM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,511

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
Madwifi is in the package manager / repo :
linux-restricted-drivers

Or use : sudo apt-get install linux-restricted-drivers

Aircrack : sudo apt-get install aircrack-ng

If you some day find an app not amongst the 28000
packages in the package manager, and cannot compile,
please tell, which error you get.
....
 
Old 01-09-2009, 09:31 PM   #4
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD, Raspbian, Arch
Posts: 2,331

Rep: Reputation: 357Reputation: 357Reputation: 357Reputation: 357
Quote:
Originally Posted by hallve_revera View Post
...i got and eror when typing "make"...
How do i fix it......
Any PARTICULAR make error you're trying to diagnose?! There are only about 15 gadzillion ones you could potentially stumble into. Posting the output of your make command would certainly help...
 
Old 01-09-2009, 09:33 PM   #5
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,716
Blog Entries: 3

Rep: Reputation: 483Reputation: 483Reputation: 483Reputation: 483Reputation: 483
Quote:
Originally Posted by knudfl View Post
Madwifi is in the package manager / repo :
linux-restricted-drivers

Or use : sudo apt-get install linux-restricted-drivers

Aircrack : sudo apt-get install aircrack-ng

If you some day find an app not amongst the 28000
packages in the package manager, and cannot compile,
please tell, which error you get.
....
some times you need to compile. apt-get me a beer. lol
 
Old 01-10-2009, 06:20 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,511

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
Drakeo # 5

Of course, I do it all the time, but using as many packages
as possible ( if they work ), is a good fundament, I believe.
 
Old 01-11-2009, 09:53 PM   #7
hallve_revera
LQ Newbie
 
Registered: Dec 2008
Posts: 25

Original Poster
Rep: Reputation: 15
hii...
this is the error thai i got when installing aircrack-ng

----------------------------------------------------------------------------------------------------------------------------make -C src all
make[1]: Entering directory `/home/ubuntu/Program/aircrack-ng-1.0-rc1/src'
make -C osdep
make[2]: Entering directory `/home/ubuntu/Program/aircrack-ng-1.0-rc1/src/osdep'
Building for Linux
make[3]: Entering directory `/home/ubuntu/Program/aircrack-ng-1.0-rc1/src/osdep'
gcc -g -W -Wall -Werror -O3 -D_FILE_OFFSET_BITS=64 -D_REVISION=0 -fPIC -I.. -c -o linux.o linux.c
cc1: warnings being treated as errors
linux.c: In function ‘is_ndiswrapper’:
linux.c:164: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c: In function ‘linux_set_rate’:
linux.c:355: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c: In function ‘linux_set_channel’:
linux.c:729: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:751: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:767: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c: In function ‘linux_set_freq’:
linux.c:820: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c: In function ‘set_monitor’:
linux.c:941: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:961: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:980: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:997: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:1035: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:1043: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:1051: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c: In function ‘do_linux_open’:
linux.c:1425: error: ignoring return value of ‘system’, declared with attributewarn_unused_result
linux.c:1474: error: ignoring return value of ‘system’, declared with attributewarn_unused_result
linux.c:1495: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:1521: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:1539: error: ignoring return value of ‘fgets’, declared with attribute warn_unused_result
linux.c:1553: error: ignoring return value of ‘fgets’, declared with attribute warn_unused_result
linux.c:1598: error: ignoring return value of ‘fgets’, declared with attribute warn_unused_result
linux.c:1627: error: ignoring return value of ‘fgets’, declared with attribute warn_unused_result
make[3]: *** [linux.o] Error 1
make[3]: Leaving directory `/home/ubuntu/Program/aircrack-ng-1.0-rc1/src/osdep'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/ubuntu/Program/aircrack-ng-1.0-rc1/src/osdep'
make[1]: *** [osd] Error 2
make[1]: Leaving directory `/home/ubuntu/Program/aircrack-ng-1.0-rc1/src'
make: *** [all] Error 2make -C src all
make[1]: Entering directory `/home/ubuntu/Program/aircrack-ng-1.0-rc1/src'
make -C osdep make -C src all
make[1]: Entering directory `/home/ubuntu/Program/aircrack-ng-1.0-rc1/src'
make -C osdep
make[2]: Entering directory `/home/ubuntu/Program/aircrack-ng-1.0-rc1/src/osdep'
Building for Linux
make[3]: Entering directory `/home/ubuntu/Program/aircrack-ng-1.0-rc1/src/osdep'
gcc -g -W -Wall -Werror -O3 -D_FILE_OFFSET_BITS=64 -D_REVISION=0 -fPIC -I.. -c -o linux.o linux.c
cc1: warnings being treated as errors
linux.c: In function ‘is_ndiswrapper’:
linux.c:164: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c: In function ‘linux_set_rate’:
linux.c:355: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c: In function ‘linux_set_channel’:
linux.c:729: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:751: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:767: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c: In function ‘linux_set_freq’:
linux.c:820: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c: In function ‘set_monitor’:
linux.c:941: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:961: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:980: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:997: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:1035: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:1043: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:1051: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c: In function ‘do_linux_open’:
linux.c:1425: error: ignoring return value of ‘system’, declared with attributewarn_unused_result
linux.c:1474: error: ignoring return value of ‘system’, declared with attributewarn_unused_result
linux.c:1495: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:1521: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:1539: error: ignoring return value of ‘fgets’, declared with attribute warn_unused_result
linux.c:1553: error: ignoring return value of ‘fgets’, declared with attribute warn_unused_result
linux.c:1598: error: ignoring return value of ‘fgets’, declared with attribute warn_unused_result
linux.c:1627: error: ignoring return value of ‘fgets’, declared with attribute warn_unused_result
make[3]: *** [linux.o] Error 1
make[3]: Leaving directory `/home/ubuntu/Program/aircrack-ng-1.0-rc1/src/osdep'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/ubuntu/Program/aircrack-ng-1.0-rc1/src/osdep'
make[1]: *** [osd] Error 2
make[1]: Leaving directory `/home/ubuntu/Program/aircrack-ng-1.0-rc1/src'
make: *** [all] Error 2
make[2]: Entering directory `/home/ubuntu/Program/aircrack-ng-1.0-rc1/src/osdep'
Building for Linux
make[3]: Entering directory `/home/ubuntu/Program/aircrack-ng-1.0-rc1/src/osdep'
gcc -g -W -Wall -Werror -O3 -D_FILE_OFFSET_BITS=64 -D_REVISION=0 -fPIC -I.. -c -o linux.o linux.c
cc1: warnings being treated as errors
linux.c: In function ‘is_ndiswrapper’:
linux.c:164: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c: In function ‘linux_set_rate’:
linux.c:355: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c: In function ‘linux_set_channel’:
linux.c:729: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:751: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:767: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c: In function ‘linux_set_freq’:
linux.c:820: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c: In function ‘set_monitor’:
linux.c:941: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:961: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:980: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:997: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:1035: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:1043: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:1051: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c: In function ‘do_linux_open’:
linux.c:1425: error: ignoring return value of ‘system’, declared with attributewarn_unused_result
linux.c:1474: error: ignoring return value of ‘system’, declared with attributewarn_unused_result
linux.c:1495: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:1521: error: ignoring return value of ‘chdir’, declared with attribute warn_unused_result
linux.c:1539: error: ignoring return value of ‘fgets’, declared with attribute warn_unused_result
linux.c:1553: error: ignoring return value of ‘fgets’, declared with attribute warn_unused_result
linux.c:1598: error: ignoring return value of ‘fgets’, declared with attribute warn_unused_result
linux.c:1627: error: ignoring return value of ‘fgets’, declared with attribute warn_unused_result
make[3]: *** [linux.o] Error 1
make[3]: Leaving directory `/home/ubuntu/Program/aircrack-ng-1.0-rc1/src/osdep'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/ubuntu/Program/aircrack-ng-1.0-rc1/src/osdep'
make[1]: *** [osd] Error 2
make[1]: Leaving directory `/home/ubuntu/Program/aircrack-ng-1.0-rc1/src'
make: *** [all] Error 2

----------------------------------------------------------------------------------------------------------------------------
 
Old 01-12-2009, 01:07 AM   #8
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD, Raspbian, Arch
Posts: 2,331

Rep: Reputation: 357Reputation: 357Reputation: 357Reputation: 357
What you have here is, gcc (the compiler) is being told to "treat warnings as errors". You can see this in your make output where gcc is called with the "-Werror" flag. Evidently the code you are trying to compile has lots of warnings. The ones I see in your output are (usually!) harmless though (like ignoring the return value from a function, etc.) While it may be harmless, technically it's a bit of sloppy programming. But since you didn't write the code you are trying to compile, you're stuck with it. Past versions of compilers/configures weren't so strict about this warning stuff, so many (most?) programmers didn't treat warnings in their code very seriously. That's what you appear to be running into.

So to "fix" it (without rewriting the code to not have warnings), you turn off this "treat warnings as errors" stuff. One way to do that is to hack into your makefile(s) and remove the "-Werror" references. There is probably a better way to do this during the configure step (you most likely ran configure prior to running make). Is there an option to tell configure to leave out the -Werror it is putting into your makefile(s)? I'm not 100% sure, but you might try calling configure with the --disable-fail flag and then rerun your make. In case there were other points of slopiness in this code you're trying to compile, your should try running "make clean" before reconfiguring. The developers may not have included a "clean" option for make however. You can try to brute-force your way through a "make clean" type of operation with something like this "rm -r *.o" (that's the letter "oh", not the digit "zero"). Only run this rm command from the root directory of the source tree you are trying to compile!

e.g.,

Code:
make clean
rm -r *.o
./configure --disable-fail
make
 
Old 01-12-2009, 02:45 AM   #9
hallve_revera
LQ Newbie
 
Registered: Dec 2008
Posts: 25

Original Poster
Rep: Reputation: 15
"the root directory of the source tree you are trying to compile!" ,, is that mean where did i put my aircrack-ng folders
like this "ubuntu@ubuntu:~/Program/aircrack-ng-1.0-rc1$" ??????
 
Old 01-12-2009, 03:20 AM   #10
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 682Reputation: 682Reputation: 682Reputation: 682Reputation: 682Reputation: 682
It this what you are referring to?
Code:
  --prefix=PREFIX         install architecture-independent files in PREFIX
                          [/usr/local]
If you are building a source package from your own distro, /usr/ is probably best. That's what the binary package would use.
If you are building from downloaded source, then /usr/local/ may be better. The distro is guaranteed not to mess with files under /usr/local/. You may need to add '/usr/local/bin' to your PATH variable in ~/.bashrc.
 
Old 01-12-2009, 02:11 PM   #11
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD, Raspbian, Arch
Posts: 2,331

Rep: Reputation: 357Reputation: 357Reputation: 357Reputation: 357
Quote:
Originally Posted by hallve_revera View Post
"the root directory of the source tree you are trying to compile!"
I am talking about the directory where you untar'ed the source files. Where the source code resides that you are trying to compile. Where you run the "make" command from. For example, I always un-tar my source packages under /usr/local/src/<package_name> but you could have untar'ed yours anywhere.

So for example, say I downloaded the source code to /tmp/whatever.tar.gz

Code:
cd /usr/local/src
tar zxvf /tmp/whatever.tar.gz
This should have created a new subdirectory under /usr/local/src with "whatever" in it's name, along with some version number in the name. For this example, we'll use version "1.12.3" for illustration.

Code:
cd /usr/local/src/whatever-1.12.3
./configure --disable-fail
make
 
Old 01-14-2009, 02:27 AM   #12
hallve_revera
LQ Newbie
 
Registered: Dec 2008
Posts: 25

Original Poster
Rep: Reputation: 15
what about this error ....

____________________________________________________________________________________________________ ________________________Checking requirements... ok.

Checking kernel configuration... ok.

make -C /lib/modules/2.6.27-7-generic/build SUBDIRS=/home/ubuntu/New Folder/madwifi-hal-0.10.5.6-r3879-20081204
modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.27-7-generic'

make[1]: *** No rule to make target `Folder/madwifi-hal-0.10.5.6-r3879-20081204'.
Stop.
make[1]: Leaving directory `/usr/src/linux-headers-2.6.27-7-generic'

make: *** [modules] Error 2

____________________________________________________________________________________________________ ________________________

this is the error from the instalation of madwifi snapshot for ar5007eg
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
So many errors when I typed the "make" and "make install" command Niceman2005 Linux - Software 23 07-22-2009 02:33 PM
Standard commands give "-bash: open: command not found" even in "su -" and "su root" mibo12 Linux - General 4 11-11-2007 10:18 PM
Make "ls" command show colors without "--color=always" switch SharpyWarpy Linux - General 4 07-16-2007 11:00 PM
Constant errors during "make" or "make install" with SUSE 10.1 Alpha 4 TehFlyingDutchman Linux - Software 3 12-30-2005 06:25 PM
How to install "make" command from rpm on cd 2 - red hat linux 7.0 ZARGON Linux - Newbie 2 08-31-2004 10:53 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration