LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-26-2005, 02:06 PM   #1
jeffman
LQ Newbie
 
Registered: Jan 2005
Distribution: slackware
Posts: 6

Rep: Reputation: 0
make[1]: *** [ffmpeg2theora] Error 1


Hi,
first: I'm sorry for my English.

I have a problem with compiling, building ffmpeg2theora, so i would be happy if somebody could help me.

here are the Errors from make:

Making all in kino_export
make[1]: Entering directory `/root/build/ogg_vorbis_new/ffmpeg2theora/ffmpeg2theora-0.12/kino_export'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/root/build/ogg_vorbis_new/ffmpeg2theora/ffmpeg2theora-0.12/kino_export'
make[1]: Entering directory `/root/build/ogg_vorbis_new/ffmpeg2theora/ffmpeg2theora-0.12'
if gcc -DPACKAGE_NAME=\"ffmpeg2theora\" -DPACKAGE_TARNAME=\"ffmpeg2theora\" -DPACKAGE_VERSION=\"0.12\" -DPACKAGE_STRING=\"ffmpeg2theora\ 0.12\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"ffmpeg2theora\" -DVERSION=\"0.12\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DHAVE__USR_LIB_LIBAVCODEC_LIBAVCODEC_A=1 -DHAVE__USR_LIB_LIBAVFORMAT_LIBAVFORMAT_A=1 -I. -I. -I/usr/include/ffmpeg -I/usr/include/lame -D_FILE_OFFSET_BITS=64 -I/usr/include -I/usr/lib/libavformat -I/usr/lib/libavcodec -O2 -mcpu=athlon-xp -march=athlon-xp -mfpmath=sse -mmmx -m3dnow -MT ffmpeg2theora-ffmpeg2theora.o -MD -MP -MF ".deps/ffmpeg2theora-ffmpeg2theora.Tpo" -c -o ffmpeg2theora-ffmpeg2theora.o `test -f 'ffmpeg2theora.c' || echo './'`ffmpeg2theora.c; \
then mv -f ".deps/ffmpeg2theora-ffmpeg2theora.Tpo" ".deps/ffmpeg2theora-ffmpeg2theora.Po"; else rm -f ".deps/ffmpeg2theora-ffmpeg2theora.Tpo"; exit 1; fi
if gcc -DPACKAGE_NAME=\"ffmpeg2theora\" -DPACKAGE_TARNAME=\"ffmpeg2theora\" -DPACKAGE_VERSION=\"0.12\" -DPACKAGE_STRING=\"ffmpeg2theora\ 0.12\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"ffmpeg2theora\" -DVERSION=\"0.12\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DHAVE__USR_LIB_LIBAVCODEC_LIBAVCODEC_A=1 -DHAVE__USR_LIB_LIBAVFORMAT_LIBAVFORMAT_A=1 -I. -I. -I/usr/include/ffmpeg -I/usr/include/lame -D_FILE_OFFSET_BITS=64 -I/usr/include -I/usr/lib/libavformat -I/usr/lib/libavcodec -O2 -mcpu=athlon-xp -march=athlon-xp -mfpmath=sse -mmmx -m3dnow -MT ffmpeg2theora-theorautils.o -MD -MP -MF ".deps/ffmpeg2theora-theorautils.Tpo" -c -o ffmpeg2theora-theorautils.o `test -f 'theorautils.c' || echo './'`theorautils.c; \
then mv -f ".deps/ffmpeg2theora-theorautils.Tpo" ".deps/ffmpeg2theora-theorautils.Po"; else rm -f ".deps/ffmpeg2theora-theorautils.Tpo"; exit 1; fi
/bin/sh ./libtool --mode=link gcc -O2 -mcpu=athlon-xp -march=athlon-xp -mfpmath=sse -mmmx -m3dnow -L/usr/lib -o ffmpeg2theora -static -L/usr/lib /usr/lib/libavformat/libavformat.a /usr/lib/libavcodec/libavcodec.a -lm -lz -lfaad -lvorbisenc -lvorbis -lm -ltheora -logg ffmpeg2theora-ffmpeg2theora.o ffmpeg2theora-theorautils.o
mkdir .libs
gcc -O2 -mcpu=athlon-xp -march=athlon-xp -mfpmath=sse -mmmx -m3dnow -o ffmpeg2theora ffmpeg2theora-ffmpeg2theora.o ffmpeg2theora-theorautils.o -L/usr/lib /usr/lib/libavformat/libavformat.a /usr/lib/libavcodec/libavcodec.a -lz /usr/lib/libfaad.a -L/usr/local/samba/lib /usr/lib/libvorbisenc.a /usr/lib/libvorbis.a -lm /usr/lib/libtheora.a /usr/lib/libogg.a
/usr/lib/libavcodec/libavcodec.a(faac.o)(.text+0x48): In function `Faac_encode_init':
: undefined reference to `faacEncOpen'
/usr/lib/libavcodec/libavcodec.a(faac.o)(.text+0x52): In function `Faac_encode_init':
: undefined reference to `faacEncGetCurrentConfiguration'
/usr/lib/libavcodec/libavcodec.a(faac.o)(.text+0x89): In function `Faac_encode_init':
: undefined reference to `faacEncClose'
/usr/lib/libavcodec/libavcodec.a(faac.o)(.text+0xce): In function `Faac_encode_init':
: undefined reference to `faacEncSetConfiguration'
/usr/lib/libavcodec/libavcodec.a(faac.o)(.text+0x135): In function `Faac_encode_init':
: undefined reference to `faacEncGetDecoderSpecificInfo'
/usr/lib/libavcodec/libavcodec.a(faac.o)(.text+0x185): In function `Faac_encode_frame':
: undefined reference to `faacEncEncode'
/usr/lib/libavcodec/libavcodec.a(faac.o)(.text+0x1b5): In function `Faac_encode_close':
: undefined reference to `faacEncClose'
/usr/lib/libavcodec/libavcodec.a(mp3lameaudio.o)(.text+0x36): In function `MP3lame_encode_init':
: undefined reference to `lame_init'
/usr/lib/libavcodec/libavcodec.a(mp3lameaudio.o)(.text+0x54): In function `MP3lame_encode_init':
: undefined reference to `lame_set_in_samplerate'
/usr/lib/libavcodec/libavcodec.a(mp3lameaudio.o)(.text+0x65): In function `MP3lame_encode_init':
: undefined reference to `lame_set_out_samplerate'
/usr/lib/libavcodec/libavcodec.a(mp3lameaudio.o)(.text+0x76): In function `MP3lame_encode_init':
: undefined reference to `lame_set_num_channels'
/usr/lib/libavcodec/libavcodec.a(mp3lameaudio.o)(.text+0x88): In function `MP3lame_encode_init':
: undefined reference to `lame_set_quality'
/usr/lib/libavcodec/libavcodec.a(mp3lameaudio.o)(.text+0x9a): In function `MP3lame_encode_init':
: undefined reference to `lame_set_mode'
/usr/lib/libavcodec/libavcodec.a(mp3lameaudio.o)(.text+0xbe): In function `MP3lame_encode_init':
: undefined reference to `lame_set_brate'
/usr/lib/libavcodec/libavcodec.a(mp3lameaudio.o)(.text+0xd0): In function `MP3lame_encode_init':
: undefined reference to `lame_set_bWriteVbrTag'
/usr/lib/libavcodec/libavcodec.a(mp3lameaudio.o)(.text+0xda): In function `MP3lame_encode_init':
: undefined reference to `lame_init_params'
/usr/lib/libavcodec/libavcodec.a(mp3lameaudio.o)(.text+0xe8): In function `MP3lame_encode_init':
: undefined reference to `lame_get_framesize'
/usr/lib/libavcodec/libavcodec.a(mp3lameaudio.o)(.text+0x10e): In function `MP3lame_encode_init':
: undefined reference to `lame_close'
/usr/lib/libavcodec/libavcodec.a(mp3lameaudio.o)(.text+0x297): In function `MP3lame_encode_frame':
: undefined reference to `lame_encode_buffer_interleaved'
/usr/lib/libavcodec/libavcodec.a(mp3lameaudio.o)(.text+0x389): In function `MP3lame_encode_frame':
: undefined reference to `lame_encode_buffer'
/usr/lib/libavcodec/libavcodec.a(mp3lameaudio.o)(.text+0x3b6): In function `MP3lame_encode_frame':
: undefined reference to `lame_encode_flush'
/usr/lib/libavcodec/libavcodec.a(mp3lameaudio.o)(.text+0x3e5): In function `MP3lame_encode_close':
: undefined reference to `lame_close'
collect2: ld returned 1 exit status
make[1]: *** [ffmpeg2theora] Error 1
make[1]: Leaving directory `/root/build/ogg_vorbis_new/ffmpeg2theora/ffmpeg2theora-0.12'
make: *** [all-recursive] Error 1

best Regards jeffman
 
Old 01-26-2005, 02:15 PM   #2
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
have you installed ffmpeg (Faac_encode_init is a funcion of ffmpeg).
 
Old 01-26-2005, 02:22 PM   #3
jeffman
LQ Newbie
 
Registered: Jan 2005
Distribution: slackware
Posts: 6

Original Poster
Rep: Reputation: 0
yes i have ffmpeg installed

with following:

./configure \
--prefix=/usr \
--enable-mp3lame \
--enable-vorbis \
--enable-faad \
--enable-faac \
--enable-a52 \
--enable-pp \
--enable-shared \
--disable-debug \
--enable-gpl

make
checkinstall
 
Old 01-26-2005, 02:30 PM   #4
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
try this:

updatedb ( this will take a min)
slocate libflac

and see if you get any output (FaacEncOpen is in libflac so we need to make sure we have that lib)
 
Old 01-26-2005, 03:32 PM   #5
jeffman
LQ Newbie
 
Registered: Jan 2005
Distribution: slackware
Posts: 6

Original Poster
Rep: Reputation: 0
there is no "libflac", but "libFLAC" see following:
i have made flac by my self, with ./configure && make and checkinstall

root@darkstar:~# slocate libflac
root@darkstar:~#
root@darkstar:~# slocate libFLAC
/usr/lib/libFLAC++.la
/usr/lib/libFLAC++.so
/usr/lib/libFLAC.la
/usr/lib/libFLAC.so
/usr/lib/libFLAC++.so.4.0.1
/usr/lib/libFLAC.so.6.0.1
/usr/lib/libFLAC++.so.2
/usr/lib/libFLAC++.so.2.1.2
/usr/lib/libFLAC.so.4.1.2
/usr/lib/libFLAC++.so.4
/usr/lib/libFLAC.so.4
/usr/lib/libFLAC.so.6
/usr/lib/libFLAC++.a
/usr/lib/libFLAC.a
/usr/share/aclocal/libFLAC++.m4
/usr/share/aclocal/libFLAC.m4
root@darkstar:~# more /var/log/packages/flac-1.1.1*

-----------------------------------------------------------------------------
PACKAGE DESCRIPTION:
flac-1.1.1-athlon-xp-1.tgz
PACKAGE DESCRIPTION:
FILE LIST:
./
install/
install/description
install/doinst.sh
usr/
usr/bin/
usr/bin/flac
usr/bin/metaflac
usr/doc/
usr/doc/flac-1.1.1/
usr/doc/flac-1.1.1/AUTHORS
usr/doc/flac-1.1.1/COPYING.FDL
usr/doc/flac-1.1.1/COPYING.GPL
usr/doc/flac-1.1.1/COPYING.LGPL
usr/doc/flac-1.1.1/COPYING.Xiph
usr/doc/flac-1.1.1/FLAC.tag
usr/doc/flac-1.1.1/README
usr/doc/flac-1.1.1/html/
usr/doc/flac-1.1.1/html/changelog.html
usr/doc/flac-1.1.1/html/comparison.html
usr/doc/flac-1.1.1/html/developers.html
usr/doc/flac-1.1.1/html/documentation.html
usr/doc/flac-1.1.1/html/download.html
usr/doc/flac-1.1.1/html/faq.html
usr/doc/flac-1.1.1/html/features.html
usr/doc/flac-1.1.1/html/format.html
usr/doc/flac-1.1.1/html/goals.html
usr/doc/flac-1.1.1/html/id.html
usr/doc/flac-1.1.1/html/images/
usr/doc/flac-1.1.1/html/images/1x1.gif
usr/doc/flac-1.1.1/html/images/cafebug.gif
usr/doc/flac-1.1.1/html/images/logo100.gif
usr/doc/flac-1.1.1/html/images/logo130.gif
usr/doc/flac-1.1.1/html/index.html
usr/doc/flac-1.1.1/html/license.html
usr/doc/flac-1.1.1/html/links.html
usr/doc/flac-1.1.1/html/news.html
usr/doc/flac-1.1.1/html/ogg_mapping.html
usr/doc/flac-1.1.1/html/ru/
usr/doc/flac-1.1.1/html/ru/authors.html
usr/doc/flac-1.1.1/html/ru/comparison.html
usr/doc/flac-1.1.1/html/ru/developers.html
usr/doc/flac-1.1.1/html/ru/documentation.html
usr/doc/flac-1.1.1/html/ru/download.html
usr/doc/flac-1.1.1/html/ru/features.html
usr/doc/flac-1.1.1/html/ru/format.html
usr/doc/flac-1.1.1/html/ru/goals.html
usr/doc/flac-1.1.1/html/ru/id.html
usr/doc/flac-1.1.1/html/ru/index.html
usr/doc/flac-1.1.1/html/ru/links.html
usr/doc/flac-1.1.1/html/ru/news.html
usr/include/
usr/include/FLAC/
usr/include/FLAC/all.h
usr/include/FLAC/assert.h
usr/include/FLAC/callback.h
usr/include/FLAC/export.h
usr/include/FLAC/file_decoder.h
usr/include/FLAC/file_encoder.h
usr/include/FLAC/format.h
usr/include/FLAC/metadata.h
usr/include/FLAC/ordinals.h
usr/include/FLAC/stream_decoder.h
usr/include/FLAC/stream_encoder.h
usr/include/FLAC/seekable_stream_decoder.h
usr/include/FLAC/seekable_stream_encoder.h
usr/include/FLAC++/
usr/include/FLAC++/all.h
usr/include/FLAC++/decoder.h
usr/include/FLAC++/encoder.h
usr/include/FLAC++/export.h
usr/include/FLAC++/metadata.h
usr/include/OggFLAC/
usr/include/OggFLAC/all.h
usr/include/OggFLAC/export.h
usr/include/OggFLAC/file_decoder.h
usr/include/OggFLAC/file_encoder.h
usr/include/OggFLAC/stream_decoder.h
usr/include/OggFLAC/stream_encoder.h
usr/include/OggFLAC/seekable_stream_decoder.h
usr/include/OggFLAC/seekable_stream_encoder.h
usr/include/OggFLAC++/
usr/include/OggFLAC++/all.h
usr/include/OggFLAC++/decoder.h
usr/include/OggFLAC++/encoder.h
usr/include/OggFLAC++/export.h
usr/lib/
usr/lib/libFLAC++.la
usr/lib/libFLAC.la
usr/lib/libOggFLAC++.la
usr/lib/libOggFLAC.la
usr/lib/libFLAC++.so.4.0.1
usr/lib/libFLAC.so.6.0.1
usr/lib/libOggFLAC++.so.0.1.1
usr/lib/libOggFLAC.so.1.1.1
usr/lib/libFLAC++.so.2.1.2
usr/lib/libFLAC.so.4.1.2
usr/lib/libOggFLAC.so.1.0.2
usr/lib/libOggFLAC++.so.0.0.4
usr/lib/libFLAC++.a
usr/lib/libFLAC.a
usr/lib/libOggFLAC++.a
usr/lib/libOggFLAC.a
usr/man/
usr/man/man1/
usr/man/man1/flac.1.gz
usr/man/man1/metaflac.1.gz
usr/share/
usr/share/aclocal/
usr/share/aclocal/libFLAC++.m4
usr/share/aclocal/libFLAC.m4
usr/share/aclocal/libOggFLAC++.m4
usr/share/aclocal/libOggFLAC.m4

by the way
i have slackware 9.0
 
Old 01-26-2005, 04:15 PM   #6
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
do you have faac-1.24 installed also?
 
Old 01-26-2005, 05:22 PM   #7
jeffman
LQ Newbie
 
Registered: Jan 2005
Distribution: slackware
Posts: 6

Original Poster
Rep: Reputation: 0
yes, faac-1.24


PACKAGE DESCRIPTION:
faac-1.24-athlon-xp-1.tgz
PACKAGE DESCRIPTION:
FILE LIST:
./
install/
install/description
install/doinst.sh
usr/
usr/bin/
usr/bin/faac
usr/doc/
usr/doc/faac/
usr/doc/faac/AUTHORS
usr/doc/faac/COPYING
usr/doc/faac/ChangeLog
usr/doc/faac/INSTALL
usr/doc/faac/NEWS
usr/doc/faac/README
usr/doc/faac/TODO
usr/include/
usr/include/faac.h
usr/include/faaccfg.h
usr/lib/
usr/lib/libfaac.la
usr/lib/libfaac.so.0.0.0
usr/lib/libfaac.a
 
Old 01-27-2005, 03:28 PM   #8
jeffman
LQ Newbie
 
Registered: Jan 2005
Distribution: slackware
Posts: 6

Original Poster
Rep: Reputation: 0
@_J
Thank for your help, but i have the solution.
I have to compile ffmpeg without faac and without mp3lame or without libavcodec.
But the last should be inserted, i think.

mfg jeffman
 
Old 01-27-2005, 04:00 PM   #9
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
kinda wierd, you shouldn't have to omit those for a succesful build. All of this built without error on a slack 10.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Really, really Weird trouble with make (make error 2) flyeater SUSE / openSUSE 5 06-20-2005 12:05 PM
ffmpeg pipe to ffmpeg2theora Phorem Linux - Software 1 01-11-2005 08:43 PM
lopster v1.2.2 make error: No rule to make target `m4/glibc21.m4' Kropotkin Fedora 0 10-31-2004 11:19 AM
make failing to make with this error. Help needed? vdemuth Linux - Software 4 06-20-2004 03:08 PM
make: cc: command not found make: *** [gzip.o]error 127 zyjk Linux - Newbie 5 02-08-2002 09:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration