LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   mailto-links from iceweasel don't work (https://www.linuxquestions.org/questions/linux-software-2/mailto-links-from-iceweasel-dont-work-767246/)

rdozijn_2 11-06-2009 02:18 AM

mailto-links from iceweasel don't work
 
hi forum,

I use iceweasel 3.0.6 on debian. My problem is that clicking the mailto-links make evolution start up, while I want to use icedove.

The strange thing is that i set network.protocol-handler.app.mailto to /usr/bin icedove (using the about:config interface). But still I get evolution. Can anybody guide me through this? I haven't got the faintest idea what I can do about this.....

thanks in advance, Ruud

bathory 11-06-2009 02:37 AM

Hi,

I don't use iceweasel nor icedove, but AFAIK iceweasel is based on firefox.
So you have to leave "network.protocol-handler.app.mailto" as it was and change the mail application from Preferences.
In firefox, you have to go: Preferences-->Applications
write "mail" in the search field and change Content-Type "mailto" to your preferred application

Hope that helps

rdozijn_2 11-06-2009 03:09 AM

preferences
 
hi bathory,

thank you for your reply. I was not aware of the possibility to change it via preferences. However, I did what you proposed, and guess what? It contained the value 'use icedove (default)'.

I have started /usr/bin/icedove from the command line and indeed, icedove starts and not evince. :(

regards, Ruud

bathory 11-06-2009 03:42 AM

It looks like you hit this bug in iceweasel.
You can follow the instructions of post #15 and see if it works after resetting the mime type file.

Regards

rdozijn_2 11-06-2009 09:41 AM

hi bathory,

thanks again. But again, this time no success. I did what message #15 said, that is voiding the value of the mailto preference and removing mimeTypes.rdf. Right-clicking on the links didn't give me the mentioned option (send....). Left-clicking caused again evolution to start.

But this trick gave me another idea, which was successful:
in preferences, I changed Icedove (default) to allways ask. Then I could pick the mailapplication. After that, I changed always ask back to Icedove, which was a new entry in the dropdown box.

Now clicking a mailto link starts a Iceweasel window. Thanks for putting me on the right track!

Regards, Ruud


All times are GMT -5. The time now is 04:33 PM.