LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-02-2003, 07:12 AM   #1
Hylke Hogewind
LQ Newbie
 
Registered: Apr 2003
Location: Netherlands
Posts: 5

Rep: Reputation: 0
Mail problems 503 5.0.0 Need RCPT (recipient)


Just configured sendmail for the first time on a Linux RedHat 8.0 (sendmail-8.12.5-7.i386.rpm)

When installing Linux RedHat 8.0 I made two accounts: root and administrator

After installation I used : [root@fbw root]# useradd Antoni
[root@fbw root]# password Antoni

When I use:
[root@fbw root]# mail -s 'testmail' root
test 01
.
Cc:
--- The message arrives in /var/spool/mail/root
--- OK
and
[root@fbw root]# mail -s 'testmail' administrator
test 01
.
Cc:
--- The message arrives in /var/spool/mail/administrator
--- OK
but when I use:

[root@fbw root]# mail -s 'testmail' Antoni
test 01
.
Cc:

--- The message ends up in /var/spool/mail/root with the following description:
Date: Wed, 2 Apr 2003 12:44:48 +0200
From: Mail Delivery Subsystem <MAILER-DAEMON@fbw.mailserver.nl>
To: root@fbw.mailserver.nl
Subject: Returned mail: see transcript for details

The original message was received at Wed, 2 Apr 2003 12:44:47 +0200
from root@localhost

----- The following addresses had permanent fatal errors -----
Antoni
(reason: 550 5.1.1 <Antoni@fbw.mailserver.nl>... User unknown)
(expanded from: Antoni)

----- Transcript of session follows -----
... while talking to localhost.mailserver.nl.:
>>> DATA
<<< 550 5.1.1 <Antoni@fbw.mailserver.nl>... User unknown
550 5.1.1 Antoni... User unknown
<<< 503 5.0.0 Need RCPT (recipient)

I used :

/usr/sbin/sendmail -OdontBlameSendmail=GroupWritableDirPathSafe -bd -q1h
/usr/sbin/sendmail -OdontBlameSendmail=GroupWritableDirPathSafe -C /etc/mail/submit.cf -q1h

The sendmail.mc file i used with the m4 macro looks like this:

I added: define(`confDONT_BLAME_SENDMAIL', `GroupWritableDirPathSafe')
define(`confDOMAIN_NAME', `$w.mailserver.nl')dnl


divert(-1)
dnl This is the sendmail macro config file. If you make changes to this file,
dnl you need the sendmail-cf rpm installed and then have to generate a
dnl new /etc/mail/sendmail.cf by running the following command:
dnl
dnl m4 /etc/mail/sendmail.mc > /etc/mail/sendmail.cf
dnl
include(`/usr/share/sendmail-cf/m4/cf.m4')
VERSIONID(`linux setup for Red Hat Linux')dnl
OSTYPE(`linux')
dnl Uncomment and edit the following line if your mail needs to be sent out
dnl through an external mail server:
dnl define(`SMART_HOST',`smtp.cablewanadoo.nl')
define(`confDEF_USER_ID',``8:12'')dnl
undefine(`UUCP_RELAY')dnl
undefine(`BITNET_RELAY')dnl
dnl define(`confAUTO_REBUILD')dnl
define(`confTO_CONNECT', `1m')dnl
define(`confTRY_NULL_MX_LIST',true)dnl
define(`confDONT_PROBE_INTERFACES',true)dnl
define(`PROCMAIL_MAILER_PATH',`/usr/bin/procmail')dnl
define(`ALIAS_FILE', `/etc/aliases')dnl
dnl define(`STATUS_FILE', `/etc/mail/statistics')dnl
define(`UUCP_MAILER_MAX', `2000000')dnl
define(`confUSERDB_SPEC', `/etc/mail/userdb.db')dnl
define(`confPRIVACY_FLAGS', `authwarnings,novrfy,noexpn,restrictqrun')dnl
define(`confAUTH_OPTIONS', `A')dnl
define(`confDONT_BLAME_SENDMAIL', `GroupWritableDirPathSafe')
define(`confDOMAIN_NAME', `$w.mailserver.nl')dnl
dnl TRUST_AUTH_MECH(`EXTERNAL DIGEST-MD5 CRAM-MD5 LOGIN PLAIN')dnl
dnl define(`confAUTH_MECHANISMS', `EXTERNAL GSSAPI DIGEST-MD5 CRAM-MD5 LOGIN PLAIN')dnl
dnl define(`confCACERT_PATH',`/usr/share/ssl/certs')
dnl define(`confCACERT',`/usr/share/ssl/certs/ca-bundle.crt')
dnl define(`confSERVER_CERT',`/usr/share/ssl/certs/sendmail.pem')
dnl define(`confSERVER_KEY',`/usr/share/ssl/certs/sendmail.pem')
dnl define(`confTO_QUEUEWARN', `4h')dnl
dnl define(`confTO_QUEUERETURN', `5d')dnl
dnl define(`confQUEUE_LA', `12')dnl
dnl define(`confREFUSE_LA', `18')dnl
define(`confTO_IDENT', `0')dnl
dnl FEATURE(delay_checks)dnl
FEATURE(`no_default_msa',`dnl')dnl
FEATURE(`smrsh',`/usr/sbin/smrsh')dnl
FEATURE(`mailertable',`hash -o /etc/mail/mailertable.db')dnl
FEATURE(`virtusertable',`hash -o /etc/mail/virtusertable.db')dnl
FEATURE(redirect)dnl
FEATURE(always_add_domain)dnl
FEATURE(use_cw_file)dnl
FEATURE(use_ct_file)dnl
dnl The '-t' option will retry delivery if e.g. the user runs over his quota.
FEATURE(local_procmail,`',`procmail -t -Y -a $h -d $u')dnl
FEATURE(`access_db',`hash -T<TMPF> -o /etc/mail/access.db')dnl
FEATURE(`blacklist_recipients')dnl
EXPOSED_USER(`root')dnl
dnl This changes sendmail to only listen on the loopback device 127.0.0.1
dnl and not on any other network devices. Comment this out if you want
dnl to accept email over the network.
dnl DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')
dnl NOTE: binding both IPv4 and IPv6 daemon to the same port requires
dnl a kernel patch
dnl DAEMON_OPTIONS(`port=smtp,Addr=::1, Name=MTA-v6, Family=inet6')
dnl We strongly recommend to comment this one out if you want to protect
dnl yourself from spam. However, the laptop and users on computers that do
dnl not have 24x7 DNS do need this.
FEATURE(`accept_unresolvable_domains')dnl
dnl FEATURE(`relay_based_on_MX')dnl
MAILER(smtp)dnl
MAILER(procmail)dnl
Cwlocalhost.localdomain

I browsed the internet for about one day but didn't find any solution to this problem so far.
Any suggestions?
 
Old 04-02-2003, 02:14 PM   #2
dorian33
Member
 
Registered: Jan 2003
Location: Poland, Warsaw
Distribution: LFS, Gentoo
Posts: 591

Rep: Reputation: 32
I do not know sendmail (I am using qmail) but are you sure that adding the shell user 'Antoni' you are also added the mail user?
Above sample presents the case when the mail user 'root' exists (usually it is created by default by most of the MTA and is assumed to exist by most of the software) whereas 'Antoni' is not known as mail receipient (no account)
 
Old 04-03-2003, 04:16 AM   #3
Hylke Hogewind
LQ Newbie
 
Registered: Apr 2003
Location: Netherlands
Posts: 5

Original Poster
Rep: Reputation: 0
Don't use capital letters in usernames
 
Old 04-03-2003, 08:50 AM   #4
fsbooks
Member
 
Registered: Jan 2002
Location: Missoula. Montana, USA
Distribution: Slackware (various)
Posts: 457

Rep: Reputation: 41
Check to see what the following lines are in your /etc/sendmail.cf (this is from mine).

# "Smart" relay host (may be null)
DS

# who I send unqualified names to (null means deliver locally)
DR

# who gets all local email traffic ($R has precedence for unqualified names)
DH

# class E: names that should be exposed as from this host, even if we masquerade
# class L: names that should be delivered locally, even if we have a relay
# class M: domains that should be converted to $M
# class N: domains that should not be converted to $M
CL root

I suspect that root and administrator are listed in the CL class, and that you have either a DS or a DH class setup (particularly since you have "dnl define(`SMART_HOST',`smtp.cablewanadoo.nl')" listed in your sendmail.mc file). You could add antoni (and other users) to the CL class (so that the mail is delivered locally rather than relayed to where there is no antoni) and/or remove the indicators to DS or DH, so the your box is responsible for the mail delivery without relay through another host.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problem:: Internet recipient cannot receive mail adrianmak Linux - Software 2 08-16-2005 06:30 AM
Linux mail server.... set headers on recipient email til Linux - General 2 12-04-2004 09:24 PM
Error 503 Apache v2-ncl Linux - Software 1 07-07-2004 07:36 PM
Exim: temporarily rejected RCPT bulliver Linux - General 3 05-02-2004 06:08 AM
Help with Sendmail filters for outgoing mail by sender/recipient gljoe Linux - Software 18 08-12-2003 09:56 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration